summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-09-03 07:59:45 +0200
committerHans de Graaff <graaff@gentoo.org>2016-09-03 07:59:45 +0200
commit5c5f2d4a08bbd9d7a1e82d436db63b3869c96ac2 (patch)
treef7817b903a189f3ad54f286c2de765fcc1062b91
parentwww-apps/airdcpp-webui: remove old (diff)
downloadgentoo-5c5f2d4a08bbd9d7a1e82d436db63b3869c96ac2.tar.gz
gentoo-5c5f2d4a08bbd9d7a1e82d436db63b3869c96ac2.tar.bz2
gentoo-5c5f2d4a08bbd9d7a1e82d436db63b3869c96ac2.zip
net-p2p/gtk-gnutella: add 1.1.10
Package-Manager: portage-2.2.28
-rw-r--r--net-p2p/gtk-gnutella/Manifest1
-rw-r--r--net-p2p/gtk-gnutella/gtk-gnutella-1.1.10.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/net-p2p/gtk-gnutella/Manifest b/net-p2p/gtk-gnutella/Manifest
index 5f7083f7fe80..8ec437880072 100644
--- a/net-p2p/gtk-gnutella/Manifest
+++ b/net-p2p/gtk-gnutella/Manifest
@@ -1,2 +1,3 @@
+DIST gtk-gnutella-1.1.10.tar.bz2 19827825 SHA256 95e2a030124e7cc05e19e351eebc16f40f4520381b7bb306e8b940ed4e2e6409 SHA512 33afdd8a98ff57f4fb5b91ba365921b8dbf72cc04431f95ff0d8162d37213861ea796f3b43d4fec257939d7a42822ab3e1ed80d49c9b93a1626024ee7ca7a13a WHIRLPOOL bbef0a0c2a05a8268e06a08d9c1f02136b81afb9a8b2a845242960a9abb88c6314072f793203c854d50b7493fa356cf234cadcde8bac4c2c0458955c279a5ec0
DIST gtk-gnutella-1.1.8.tar.bz2 19690815 SHA256 271aadb6da4a807dd98094d7f2fa42a2215e273cdc799c188e68594896586079 SHA512 f1b0130a660d41690fb0555eae157c35c73bdd541ab7cce43acd3a0cc4fcb0fb00dc51947065c227df516062af944cc7267437c09f67bfb0dfa9b3dbf96bce2f WHIRLPOOL 568651daa74fb9b71f228a25d6f8086ec26646c521f8161ae85e5524d22c42d618017252dabe77d87468a4c3280754c1279a6d2c526cd7f805177e18e8614f16
DIST gtk-gnutella-1.1.9.tar.bz2 19766381 SHA256 3b2e913969834a57edd93d22733646037b2a141172d5d4a240f5d6a9f56b6aff SHA512 45ea6a5d51592879e19c61e728a60c77352e7d9b0c92ef1ac5c4fa52db122d70fdcc3f724b8da36f5dab3cea3170ba214db2552c31a156ea71e45e3a0048940c WHIRLPOOL e528c00bff42642fe3e949a3a4d1b2dfb70fbc8e408a2e90926689d30b185ec6042807841921aa013d07064a9c5fe7a3f027d67f0ccac40bf4c2588175af2192
diff --git a/net-p2p/gtk-gnutella/gtk-gnutella-1.1.10.ebuild b/net-p2p/gtk-gnutella/gtk-gnutella-1.1.10.ebuild
new file mode 100644
index 000000000000..be3536464461
--- /dev/null
+++ b/net-p2p/gtk-gnutella/gtk-gnutella-1.1.10.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils
+
+IUSE="nls dbus ssl +gtk"
+
+DESCRIPTION="A GTK+ Gnutella client"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://gtk-gnutella.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ dev-libs/glib:2
+ sys-libs/zlib
+ gtk? ( >=x11-libs/gtk+-2.2.1:2 )
+ dbus? ( >=sys-apps/dbus-0.35.2 )
+ ssl? ( >=net-libs/gnutls-2.2.5 )
+ nls? ( >=sys-devel/gettext-0.11.5 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ strip-linguas -i po
+
+ echo "# Gentoo-selected LINGUAS" > po/LINGUAS
+ for ling in ${LINGUAS}; do
+ echo $ling >> po/LINGUAS
+ done
+
+ default
+}
+
+src_configure() {
+ # There is no option to turn off optimization through the build.sh
+ # script.
+ sed -i -e "s/Configure -Oder/Configure -Oder -Doptimize=none/" build.sh || die
+
+ # The build script does not support the equivalent --enable
+ # options so we must construct the configuration by hand.
+
+ local myconf
+
+ if ! use nls; then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ if ! use dbus; then
+ myconf="${myconf} --disable-dbus"
+ fi
+
+ if ! use ssl; then
+ myconf="${myconf} --disable-gnutls"
+ fi
+
+ if use gtk; then
+ myconf="${myconf} --gtk2"
+ else
+ myconf="${myconf} --topless"
+ fi
+
+ ./build.sh \
+ --configure-only \
+ --prefix="/usr" \
+ --cc=$(tc-getCC) \
+ ${myconf}
+}
+
+src_compile() {
+ # Build system is not parallel-safe, bug 500760
+ emake -j1
+}
+
+src_install() {
+ dodir /usr/bin
+ emake INSTALL_PREFIX="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog README TODO
+
+ # Touch the symbols file into the future to avoid warnings from
+ # gtk-gnutella later on, since we will most likely strip the binary.
+ touch --date="next minute" "${D}/usr/lib/gtk-gnutella/gtk-gnutella.nm" || die
+}