summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2022-01-11 22:09:58 +0200
committerMart Raudsepp <leio@gentoo.org>2022-01-11 22:41:45 +0200
commit5c788635a97587983284b2b5c761884ae1974e7b (patch)
treeeadebddc686c0609016177f4831bd566c70b3fe4
parentgnome-base/gnome-shell: remove old (diff)
downloadgentoo-5c788635a97587983284b2b5c761884ae1974e7b.tar.gz
gentoo-5c788635a97587983284b2b5c761884ae1974e7b.tar.bz2
gentoo-5c788635a97587983284b2b5c761884ae1974e7b.zip
gnome-base/gnome-shell: bump to 41.3
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--gnome-base/gnome-shell/Manifest1
-rw-r--r--gnome-base/gnome-shell/gnome-shell-41.3.ebuild201
2 files changed, 202 insertions, 0 deletions
diff --git a/gnome-base/gnome-shell/Manifest b/gnome-base/gnome-shell/Manifest
index 9369fa6933c8..4b460253fe4a 100644
--- a/gnome-base/gnome-shell/Manifest
+++ b/gnome-base/gnome-shell/Manifest
@@ -1,3 +1,4 @@
DIST gnome-shell-40.4.tar.xz 1870468 BLAKE2B 78b0a749850e5df18beabd25cc35214b2d1f9a254dd095b9e783b2acdc9bac30edd7ffae3e6b15dd14d5b0877e8453c17548298e29b57642353e80ed505e556d SHA512 305d12cc7273f23e4a0c294f532cbf951816fd2de81959bef769048f4d5717e9e1886b64fe17b2f5ef6ee216ea67a6b913293a8903ec5dc5214bd29fbb1d3b32
DIST gnome-shell-40.5.tar.xz 1871284 BLAKE2B 39c7392541af8a043627fb7aa19b723ee3b36e3d8001a64f34b14a6f23d68d3b160a0abe0f90659c55b99bf898cfdf30d88f62b8e113fc47814a55ef37c58725 SHA512 98bb0321aa9bc9da10ff6262cac802f575e2958600f429d446f3f87ec1ea40c837dd6e2fecae9dab0c2e224d2bf8b434a188ade84d4f480260102dcc80fdc5c9
DIST gnome-shell-41.2.tar.xz 1896672 BLAKE2B 634cc8e4b77a94899af123fa9ce2a11271b913467007084bde90cfe2f4dbddd65bb1ed115c42ba21a697cb591e48387a19c5b0c3764e13950b9034c9fbc493d9 SHA512 4ec29881030933f8c15ea1d11a431ca07ea84566cd7c1ab69afbf25c1b588b2d75ade17b623b5bf644b42bf5b82e375b67a833169b5b0b6c7c0dd8dbd3e56835
+DIST gnome-shell-41.3.tar.xz 1897228 BLAKE2B 41cfc32488f7fcc3b0b565f8b63586ff0b2e7573e47d5e858e864ed7744b8cd535872312f4ccbb86fe7dea306f2c1460ce3a9ed93521f5d93bd124ce92634420 SHA512 3ef18f992c55ecb76e55f64306d43a15dc104b372db2faaaae2435d10edbc44bc0b8f9e27d173c0cac11b812c27648517543f210470c07d5dbc1f04ce4d811cc
diff --git a/gnome-base/gnome-shell/gnome-shell-41.3.ebuild b/gnome-base/gnome-shell/gnome-shell-41.3.ebuild
new file mode 100644
index 000000000000..a5b2b5a53e21
--- /dev/null
+++ b/gnome-base/gnome-shell/gnome-shell-41.3.ebuild
@@ -0,0 +1,201 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit gnome.org gnome2-utils meson python-single-r1 virtualx xdg
+
+DESCRIPTION="Provides core UI functions for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShell"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="+bluetooth +browser-extension elogind gtk-doc +ibus +networkmanager systemd telepathy"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ ?? ( elogind systemd )"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+# libXfixes-5.0 needed for pointer barriers and #include <X11/extensions/Xfixes.h>
+# FIXME:
+# * gstreamer/pipewire support is currently automagic
+DEPEND="
+ >=gnome-extra/evolution-data-server-3.33.1:=
+ >=app-crypt/gcr-3.7.5[introspection]
+ >=dev-libs/glib-2.68:2
+ >=dev-libs/gobject-introspection-1.49.1:=
+ >=dev-libs/gjs-1.69.2
+ >=x11-libs/gtk+-3.15.0:3[introspection]
+ >=x11-wm/mutter-41.0:0/9[introspection]
+ >=sys-auth/polkit-0.100[introspection]
+ >=gnome-base/gsettings-desktop-schemas-41_alpha[introspection]
+ >=x11-libs/startup-notification-0.11
+ >=app-i18n/ibus-1.5.19
+ >=gnome-base/gnome-desktop-3.35.90:3=[introspection]
+ bluetooth? ( >=net-wireless/gnome-bluetooth-3.9[introspection] )
+ >=media-libs/gstreamer-0.11.92:1.0
+ media-libs/gst-plugins-base:1.0
+ >=media-video/pipewire-0.3.0:=
+ networkmanager? (
+ >=net-misc/networkmanager-1.10.4:=[introspection]
+ net-libs/libnma[introspection]
+ >=app-crypt/libsecret-0.18
+ dev-libs/dbus-glib )
+ systemd? ( >=sys-apps/systemd-242
+ >=gnome-base/gnome-desktop-3.34.2:3=[systemd] )
+ elogind? ( >=sys-auth/elogind-237 )
+
+ app-arch/gnome-autoar
+ dev-libs/json-glib
+
+ >=app-accessibility/at-spi2-atk-2.5.3
+ x11-libs/gdk-pixbuf:2[introspection]
+ dev-libs/libxml2:2
+ x11-libs/libX11
+
+ >=media-sound/pulseaudio-2[glib]
+ >=dev-libs/atk-2[introspection]
+ dev-libs/libical:=
+ >=x11-libs/libXfixes-5.0
+
+ gui-libs/gtk:4[introspection]
+
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ media-libs/mesa[X(+)]
+"
+# Runtime-only deps are probably incomplete and approximate.
+# Introspection deps generated from inspection of the output of:
+# for i in `rg -INUo 'const(?s).*imports.gi' |cut -d= -f1 |cut -c7- |sort -u`; do echo $i ;done |cut -d, -f1 |sort -u
+# or
+# rg -INUo 'const(?s).*imports.gi' |cut -d= -f1 |cut -c7- | sed -e 's:[{}]::g' | awk '{$1=$1; print}' | awk -F',' '{$1=$1;print}' | tr ' ' '\n' | sort -u | sed -e 's/://g'
+# These will give a lot of unnecessary things due to greedy matching (TODO), and `(?s).*?` doesn't seem to work as desired.
+# Compare with `grep -rhI 'imports.gi.versions' |sort -u` for any SLOT requirements
+# Each block:
+# 1. Introspection stuff needed via imports.gi (those that build time check may be listed above already)
+# 2. gnome-session needed for shutdown/reboot/inhibitors/etc
+# 3. Control shell settings
+# 4. xdg-utils needed for xdg-open, used by extension tool
+# 5. adwaita-icon-theme needed for various icons & arrows (3.26 for new video-joined-displays-symbolic and co icons; review for 3.28+)
+# 6. mobile-broadband-provider-info, timezone-data for shell-mobile-providers.c # TODO: Review
+# 7. IBus is needed for nls integration
+# 8. Optional telepathy chat integration
+# 9. Cantarell font used in gnome-shell global CSS (if removing this for some reason, make sure it's pulled in somehow for non-meta users still too)
+# 10. xdg-desktop-portal-gtk for various integration, e.g. #764632
+# 11. TODO: semi-optional webkit-gtk[introspection] for captive portal helper
+RDEPEND="${DEPEND}
+ >=sys-apps/accountsservice-0.6.14[introspection]
+ app-accessibility/at-spi2-core:2[introspection]
+ app-misc/geoclue[introspection]
+ media-libs/graphene[introspection]
+ >=dev-libs/libgweather-3.26:2[introspection]
+ x11-libs/pango[introspection]
+ net-libs/libsoup:2.4[introspection]
+ >=sys-power/upower-0.99:=[introspection]
+ gnome-base/librsvg:2[introspection]
+
+ >=gnome-base/gnome-session-2.91.91
+ >=gnome-base/gnome-settings-daemon-3.8.3
+
+ x11-misc/xdg-utils
+
+ >=x11-themes/adwaita-icon-theme-3.26
+
+ networkmanager? (
+ net-misc/mobile-broadband-provider-info
+ sys-libs/timezone-data )
+ ibus? ( >=app-i18n/ibus-1.4.99[dconf(+),gtk,introspection] )
+ telepathy? (
+ >=net-im/telepathy-logger-0.2.4[introspection]
+ >=net-libs/telepathy-glib-0.19[introspection] )
+ media-fonts/cantarell
+
+ sys-apps/xdg-desktop-portal-gtk
+"
+# avoid circular dependency, see bug #546134
+PDEPEND="
+ >=gnome-base/gdm-3.5[introspection(+)]
+ >=gnome-base/gnome-control-center-3.26[bluetooth(+)?,networkmanager(+)?]
+ browser-extension? ( gnome-extra/chrome-gnome-shell )
+"
+BDEPEND="
+ dev-libs/libxslt
+ >=dev-util/gdbus-codegen-2.45.3
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.17
+ app-text/docbook-xml-dtd:4.5 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# These are not needed from tarballs, unless stylesheets or manpage get patched with patchset:
+# dev-lang/sassc
+# app-text/asciidoc
+
+PATCHES=(
+ # Fix automagic gnome-bluetooth dep, bug #398145
+ "${FILESDIR}"/40.0-optional-bluetooth.patch
+ # Change favorites defaults, bug #479918
+ "${FILESDIR}"/40.0-defaults.patch
+)
+
+src_prepare() {
+ xdg_src_prepare
+ # Hack in correct python shebang
+ sed -e "s:python\.path():'/usr/bin/env ${EPYTHON}':" -i src/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use bluetooth)
+ -Dextensions_tool=true
+ -Dextensions_app=true
+ $(meson_use gtk-doc gtk_doc)
+ -Dman=true
+ $(meson_use test tests)
+ $(meson_use networkmanager)
+ $(meson_use systemd) # this controls journald integration and desktop file user services related property only as of 3.34.4
+ # (structured logging and having gnome-shell launched apps use its own identifier instead of gnome-session)
+ # suspend support is runtime optional via /run/systemd/seats presence and org.freedesktop.login1.Manager dbus interface; elogind should provide what's necessary
+ -Dsoup2=true # libslot SLOT needs to match with what libgweather is using
+ )
+ meson_src_configure
+}
+
+src_test() {
+ gnome2_environment_reset # Avoid dconf that looks at XDG_DATA_DIRS, which can sandbox fail if flatpak is installed
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version 'media-libs/gst-plugins-good:1.0' || \
+ ! has_version 'media-plugins/gst-plugins-vpx:1.0'; then
+ ewarn "To make use of GNOME Shell's built-in screen recording utility,"
+ ewarn "you need to either install media-libs/gst-plugins-good:1.0"
+ ewarn "and media-plugins/gst-plugins-vpx:1.0, or use dconf-editor to change"
+ ewarn "apps.gnome-shell.recorder/pipeline to what you want to use."
+ fi
+
+ if ! has_version "media-libs/mesa[llvm]"; then
+ elog "llvmpipe is used as fallback when no 3D acceleration"
+ elog "is available. You will need to enable llvm USE for"
+ elog "media-libs/mesa if you do not have hardware 3D setup."
+ fi
+
+ # https://bugs.gentoo.org/show_bug.cgi?id=563084
+ # TODO: Is this still the case after various fixed in 3.28 for detecting non-working KMS for wayland (to fall back to X)?
+ if has_version "x11-drivers/nvidia-drivers[-kms]"; then
+ ewarn "You will need to enable kms support in x11-drivers/nvidia-drivers,"
+ ewarn "otherwise Gnome will fail to start"
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}