summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-05-01 20:46:16 +0200
committerJohannes Huber <johu@gentoo.org>2018-05-01 20:49:31 +0200
commit5c933d0c1863147db8a63c8503eb6002a581d52d (patch)
tree0e4d7f34697497ce44029b4d769412cefce26fb9
parentdev-python/routes: use HTTPS (diff)
downloadgentoo-5c933d0c1863147db8a63c8503eb6002a581d52d.tar.gz
gentoo-5c933d0c1863147db8a63c8503eb6002a581d52d.tar.bz2
gentoo-5c933d0c1863147db8a63c8503eb6002a581d52d.zip
media-sound/tomahawk: Snapshot bump 0.9.0_pre20180501
Package-Manager: Portage-2.3.31, Repoman-2.3.9
-rw-r--r--media-sound/tomahawk/Manifest1
-rw-r--r--media-sound/tomahawk/tomahawk-0.9.0_pre20180501.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/media-sound/tomahawk/Manifest b/media-sound/tomahawk/Manifest
index dfa5a8e47936..5b46c7f1068a 100644
--- a/media-sound/tomahawk/Manifest
+++ b/media-sound/tomahawk/Manifest
@@ -1 +1,2 @@
DIST tomahawk-0.9.0_pre20170808.tar.gz 9913232 BLAKE2B 5a7ebd9419fece090c0aec1f8f47bf35e1f0fbae5cd6a41803ac265e7310dadac61ba4f2e25b0d2fbbb0068cbb3f7098c1d330ac81e671be1028ed3b78d32560 SHA512 edaa4c1637ca460f838dfdd7ecc9d5dae0b66a8280deb8dc6140c673ecc76aa1055efbbac1e9b2937ec01d6dd657935b907cadceb2059f8e055305e872866c2b
+DIST tomahawk-0.9.0_pre20180501.tar.gz 9913223 BLAKE2B 430fedf1a06307721d36ce733dc6f380e56ca4ba018816b4d6cf70370a383945033220bded8fef1aaeb0deb49ec89422c4ade6add997d9034620d42c43ba2b8f SHA512 51ee268a7165ee4968cd3fbd883c8e86fdee049dbf85d11ff3212d1648f08557c868c0c3f0f448c3a7fa6a825af4ee94b498b5027a788b545587bf4bae1be1c7
diff --git a/media-sound/tomahawk/tomahawk-0.9.0_pre20180501.ebuild b/media-sound/tomahawk/tomahawk-0.9.0_pre20180501.ebuild
new file mode 100644
index 000000000000..78600519cd52
--- /dev/null
+++ b/media-sound/tomahawk/tomahawk-0.9.0_pre20180501.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMIT=34c1f88171f00a3e9fae57250799f3d3623b5f74
+inherit kde5 vcs-snapshot
+
+DESCRIPTION="Multi-source social music player"
+HOMEPAGE="https://www.tomahawk-player.org/"
+SRC_URI="https://github.com/${PN}-player/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+hatchet telepathy xmpp"
+
+CDEPEND="
+ $(add_frameworks_dep attica)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtsql)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwebkit)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ $(add_qt_dep qtxml)
+ app-crypt/qca:2[qt5(+)]
+ dev-cpp/lucene++
+ dev-cpp/sparsehash
+ dev-libs/boost:=
+ dev-libs/qtkeychain:=[qt5(+)]
+ >=dev-libs/quazip-0.7.2[qt5(+)]
+ >=media-libs/liblastfm-1.1.0_pre20150206
+ >=media-libs/taglib-1.8.0
+ media-video/vlc:=[flac,dvbpsi,ffmpeg,mp3]
+ >=net-libs/gnutls-3.2:=
+ x11-libs/libX11
+ hatchet? ( dev-cpp/websocketpp )
+ telepathy? ( >=net-libs/telepathy-qt-0.9.7-r1[qt5(+)] )
+ xmpp? ( >=net-libs/jreen-1.3.0[qt5(+)] )
+"
+DEPEND="${CDEPEND}
+ $(add_qt_dep designer)
+ $(add_qt_dep linguist-tools)
+ $(add_qt_dep qtconcurrent)
+"
+RDEPEND="${CDEPEND}
+ app-crypt/qca:2[ssl]
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_CRASHREPORTER=OFF
+ -DBUILD_TESTS=OFF
+ -DBUILD_TOOLS=OFF
+ -DBUILD_WITH_QT4=OFF
+ -DWITH_KDE4=OFF
+ -DBUILD_HATCHET=$(usex hatchet)
+ -DWITH_TelepathyQt=$(usex telepathy)
+ -DWITH_Jreen=$(usex xmpp)
+ )
+
+ if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ mycmakeargs+=( -DBUILD_RELEASE=ON )
+ fi
+
+ kde5_src_configure
+}