summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-01 22:41:08 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-01 22:41:56 +0300
commit5cb6512d7f31eda248efcf78408d74a9feee0ee5 (patch)
tree5c39084b29eb4e4bcfb4b24d79507147a0271d9e
parentdev-python/nbclient: add 0.6.7 (diff)
downloadgentoo-5cb6512d7f31eda248efcf78408d74a9feee0ee5.tar.gz
gentoo-5cb6512d7f31eda248efcf78408d74a9feee0ee5.tar.bz2
gentoo-5cb6512d7f31eda248efcf78408d74a9feee0ee5.zip
dev-python/psycopg: add 3.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/psycopg/Manifest1
-rw-r--r--dev-python/psycopg/psycopg-3.1.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/psycopg/Manifest b/dev-python/psycopg/Manifest
index b7e2b0d57f26..79a4dc3be840 100644
--- a/dev-python/psycopg/Manifest
+++ b/dev-python/psycopg/Manifest
@@ -1,2 +1,3 @@
DIST psycopg-3.0.16.gh.tar.gz 386693 BLAKE2B c6c0bd9832e65180e7de76b04ef7c81f4c2d0981894d090b933ce0efaaafdf6b62d1d71a4c70c7c9b848b67e576a71953116925f9e991a4ed99b53067e24cbba SHA512 655e01bb00972dacae590f2e8ce5948226acb827b55099e7f362fdee9210f07b755f4da10d2fadd468aa95eaa3f72e7658a1ab26870d4ac159ee266ce1f8140c
+DIST psycopg-3.1.gh.tar.gz 463892 BLAKE2B 94100bed4807771f6c4d0469737b160955f3f6bfcff84240c9e15dd9b7b88765583952b712642740c97f6ec42223edcf74fb2c5390a185f44ca0eb8858e76100 SHA512 057a14d614ccb9f36a7db7a82c3d48953658a1c6af2a2265a93a3f6c1db421275e51e1be4d59e2ea98b638f3da8c24c9d2a4d9aabf6190c47691dd632c9339f9
DIST psycopg2-2.9.3.tar.gz 380611 BLAKE2B 78099da7378dcfa8b7f28aae4d533a7e890cdb7ae4c0cc718a9411e630fd07b56f074760fc29de8fe08fe727328cca39414a5f297fb92ed2f7471a24e633d18d SHA512 048184d1d162a371fc0fba711448a6fa8a6aac193421f4484c7f7b91c39065d5b632fa34fc15a901eca055d597302b1f9e38330b248ed0e4653dcdc544b0d660
diff --git a/dev-python/psycopg/psycopg-3.1.ebuild b/dev-python/psycopg/psycopg-3.1.ebuild
new file mode 100644
index 000000000000..8bd1346c397b
--- /dev/null
+++ b/dev-python/psycopg/psycopg-3.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="PostgreSQL database adapter for Python"
+HOMEPAGE="
+ https://www.psycopg.org/psycopg3/
+ https://github.com/psycopg/psycopg/
+ https://pypi.org/project/psycopg/
+"
+SRC_URI="
+ https://github.com/psycopg/psycopg/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${P}/psycopg
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+
+DEPEND="
+ >=dev-db/postgresql-8.1:*
+"
+RDEPEND="
+ ${DEPEND}
+ $(python_gen_cond_dep '
+ >=dev-python/backports-zoneinfo-0.2.0[${PYTHON_USEDEP}]
+ ' 3.8)
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.1[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-db/postgresql-8.1[server]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # tests for the psycopg_pool package
+ tests/pool
+ # some broken mypy magic
+ tests/test_module.py::test_version
+ tests/test_module.py::test_version_c
+ tests/test_typing.py
+ tests/crdb/test_typing.py
+ # TODO, relying on undefined ordering in Python?
+ tests/test_dns_srv.py::test_srv
+)
+
+src_test() {
+ # tests are lurking in top-level directory
+ cd .. || die
+
+ initdb -D "${T}"/pgsql || die
+ # TODO: random port
+ pg_ctl -w -D "${T}"/pgsql start \
+ -o "-h '' -k '${T}'" || die
+ createdb -h "${T}" test || die
+
+ local -x PSYCOPG_TEST_DSN="host=${T} dbname=test"
+ distutils-r1_src_test
+
+ pg_ctl -w -D "${T}"/pgsql stop || die
+}