summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-12 17:58:14 +0000
committerSam James <sam@gentoo.org>2022-02-15 19:49:43 +0000
commit5cf44c5ab2ca709df6fb7b90434d02487faed323 (patch)
treeaa4c12db1c667681961be146908ce51c5bc3434b
parentmedia-libs/openimageio: adjust to unslotted OpenEXR (diff)
downloadgentoo-5cf44c5ab2ca709df6fb7b90434d02487faed323.tar.gz
gentoo-5cf44c5ab2ca709df6fb7b90434d02487faed323.tar.bz2
gentoo-5cf44c5ab2ca709df6fb7b90434d02487faed323.zip
media-libs/opencolorio: adjust to unslotted OpenEXR
Bug: https://bugs.gentoo.org/833158 Closes: https://bugs.gentoo.org/831357 Closes: https://bugs.gentoo.org/832862 Closes: https://bugs.gentoo.org/821247 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/opencolorio/files/opencolorio-2.1.1-imath-openexr-3.patch75
-rw-r--r--media-libs/opencolorio/opencolorio-2.1.1-r4.ebuild (renamed from media-libs/opencolorio/opencolorio-2.1.1-r3.ebuild)4
2 files changed, 0 insertions, 79 deletions
diff --git a/media-libs/opencolorio/files/opencolorio-2.1.1-imath-openexr-3.patch b/media-libs/opencolorio/files/opencolorio-2.1.1-imath-openexr-3.patch
deleted file mode 100644
index bf606889865d..000000000000
--- a/media-libs/opencolorio/files/opencolorio-2.1.1-imath-openexr-3.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-diff --git a/share/cmake/modules/FindImath.cmake b/share/cmake/modules/FindImath.cmake
-index 44a55e8..8a2d7ca 100644
---- a/share/cmake/modules/FindImath.cmake
-+++ b/share/cmake/modules/FindImath.cmake
-@@ -49,6 +49,7 @@ if(NOT OCIO_INSTALL_EXT_PACKAGES STREQUAL ALL)
- find_path(Imath_INCLUDE_DIR
- NAMES
- Imath/ImathConfig.h
-+ Imath-3/IMathConfig.h
- HINTS
- ${Imath_ROOT}
- ${PC_Imath_INCLUDE_DIRS}
-@@ -90,8 +91,8 @@ if(NOT OCIO_INSTALL_EXT_PACKAGES STREQUAL ALL)
-
- # Get version from config header file
- if(Imath_INCLUDE_DIR)
-- if(EXISTS "${Imath_INCLUDE_DIR}/Imath/ImathConfig.h")
-- set(_Imath_CONFIG "${Imath_INCLUDE_DIR}/Imath/ImathConfig.h")
-+ if(EXISTS "${Imath_INCLUDE_DIR}/Imath-3/ImathConfig.h")
-+ set(_Imath_CONFIG "${Imath_INCLUDE_DIR}/Imath-3/ImathConfig.h")
- endif()
- endif()
-
-diff --git a/src/utils/Half.h.in b/src/utils/Half.h.in
-index 3784341..237f3ed 100644
---- a/src/utils/Half.h.in
-+++ b/src/utils/Half.h.in
-@@ -8,7 +8,7 @@
- #define OCIO_USE_IMATH_HALF @OCIO_USE_IMATH_HALF@
-
- #if OCIO_USE_IMATH_HALF
--# include <Imath/half.h>
-+# include <Imath-3/half.h>
- #else
- # include <OpenEXR/half.h>
- #endif
-diff --git a/vendor/aftereffects/vc/vc15/utils/Half.h b/vendor/aftereffects/vc/vc15/utils/Half.h
-index 5035750..5144e72 100644
---- a/vendor/aftereffects/vc/vc15/utils/Half.h
-+++ b/vendor/aftereffects/vc/vc15/utils/Half.h
-@@ -8,7 +8,7 @@
- #define OCIO_USE_IMATH_HALF 0
-
- #if OCIO_USE_IMATH_HALF
--# include <Imath/half.h>
-+# include <Imath-3/half.h>
- #else
- # include <OpenEXR/half.h>
- #endif
-diff --git a/vendor/aftereffects/xcode/xcode12/utils/Half.h b/vendor/aftereffects/xcode/xcode12/utils/Half.h
-index 5035750..5144e72 100644
---- a/vendor/aftereffects/xcode/xcode12/utils/Half.h
-+++ b/vendor/aftereffects/xcode/xcode12/utils/Half.h
-@@ -8,7 +8,7 @@
- #define OCIO_USE_IMATH_HALF 0
-
- #if OCIO_USE_IMATH_HALF
--# include <Imath/half.h>
-+# include <Imath-3/half.h>
- #else
- # include <OpenEXR/half.h>
- #endif
-diff --git a/vendor/aftereffects/xcode/xcode9/utils/Half.h b/vendor/aftereffects/xcode/xcode9/utils/Half.h
-index 5035750..5144e72 100644
---- a/vendor/aftereffects/xcode/xcode9/utils/Half.h
-+++ b/vendor/aftereffects/xcode/xcode9/utils/Half.h
-@@ -8,7 +8,7 @@
- #define OCIO_USE_IMATH_HALF 0
-
- #if OCIO_USE_IMATH_HALF
--# include <Imath/half.h>
-+# include <Imath-3/half.h>
- #else
- # include <OpenEXR/half.h>
- #endif
diff --git a/media-libs/opencolorio/opencolorio-2.1.1-r3.ebuild b/media-libs/opencolorio/opencolorio-2.1.1-r4.ebuild
index 65a48f36c3c7..f90a88c6c238 100644
--- a/media-libs/opencolorio/opencolorio-2.1.1-r3.ebuild
+++ b/media-libs/opencolorio/opencolorio-2.1.1-r4.ebuild
@@ -59,10 +59,6 @@ RESTRICT="test"
CMAKE_BUILD_TYPE=RelWithDebInfo
-PATCHES=(
- "${FILESDIR}"/${PN}-2.1.1-imath-openexr-3.patch
-)
-
pkg_setup() {
use python && python-single-r1_pkg_setup
}