summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-08-05 11:37:29 +0200
committerDavid Seifert <soap@gentoo.org>2021-08-05 11:37:29 +0200
commit5dcf89790135c0f6424557c703d0308b6601be76 (patch)
treeca178d00beafd5958f3a10b128447626f629d039
parentdev-python/immutables: Backport hash fixes for 32-bit platforms (diff)
downloadgentoo-5dcf89790135c0f6424557c703d0308b6601be76.tar.gz
gentoo-5dcf89790135c0f6424557c703d0308b6601be76.tar.bz2
gentoo-5dcf89790135c0f6424557c703d0308b6601be76.zip
app-crypt/md5deep: update EAPI 6 -> 8
Closes: https://bugs.gentoo.org/787302 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--app-crypt/md5deep/files/md5deep-4.4-pointer-comparison.patch11
-rw-r--r--app-crypt/md5deep/md5deep-4.4.ebuild20
2 files changed, 22 insertions, 9 deletions
diff --git a/app-crypt/md5deep/files/md5deep-4.4-pointer-comparison.patch b/app-crypt/md5deep/files/md5deep-4.4-pointer-comparison.patch
new file mode 100644
index 000000000000..dbd6e74519d6
--- /dev/null
+++ b/app-crypt/md5deep/files/md5deep-4.4-pointer-comparison.patch
@@ -0,0 +1,11 @@
+--- a/src/hash.cpp
++++ b/src/hash.cpp
+@@ -279,7 +279,7 @@
+ MAP_FILE|
+ #endif
+ MAP_SHARED,fd,0);
+- if(fdht->base>0){
++ if(fdht->base){
+ /* mmap is successful, so set the bounds.
+ * if it is not successful, we default to reading the fd
+ */
diff --git a/app-crypt/md5deep/md5deep-4.4.ebuild b/app-crypt/md5deep/md5deep-4.4.ebuild
index a7637a6fdfde..281022555627 100644
--- a/app-crypt/md5deep/md5deep-4.4.ebuild
+++ b/app-crypt/md5deep/md5deep-4.4.ebuild
@@ -1,25 +1,27 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
DESCRIPTION="Expanded md5sum program with recursive and comparison options"
HOMEPAGE="http://md5deep.sourceforge.net/"
-SRC_URI="https://github.com/jessek/hashdeep/archive/release-${PV}.tar.gz
- -> ${P}.tar.gz"
+SRC_URI="https://github.com/jessek/hashdeep/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/hashdeep-release-${PV}"
LICENSE="public-domain GPL-2"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~mips ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-S=${WORKDIR}/hashdeep-release-${PV}
-
-DOCS=( AUTHORS ChangeLog FILEFORMAT NEWS README.md TODO )
+PATCHES=( "${FILESDIR}"/${PN}-4.4-pointer-comparison.patch )
src_prepare() {
- eapply_user
+ default
eautoreconf
}
+
+src_install() {
+ default
+ dodoc FILEFORMAT
+}