summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-09-10 11:09:16 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-09-17 23:32:12 +0200
commit5e6ab7bbb8bae984f628fa0255789a5ec8899864 (patch)
tree5813c3948bbbfa5b8a95090c2bfbe1249bc723b3
parentdev-cpp/libcmis: Add 0.5.2_pre20160820 snapshot (diff)
downloadgentoo-5e6ab7bb.tar.gz
gentoo-5e6ab7bb.tar.bz2
gentoo-5e6ab7bb.zip
app-text/liblangtag: Add USE=debug,doc and sync ebuild fixes
Gentoo-bug: 593240 0.6.0 Version bump overlapped with commit 432384028d4eaf1060ca3f44b3f546187c9a195d Package-Manager: portage-2.3.0
-rw-r--r--app-text/liblangtag/liblangtag-0.6.0-r2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-text/liblangtag/liblangtag-0.6.0-r2.ebuild b/app-text/liblangtag/liblangtag-0.6.0-r2.ebuild
new file mode 100644
index 000000000000..3bca60009346
--- /dev/null
+++ b/app-text/liblangtag/liblangtag-0.6.0-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils xdg-utils
+
+DESCRIPTION="An interface library to access tags for identifying languages"
+HOMEPAGE="https://tagoh.bitbucket.org/liblangtag/"
+SRC_URI="https://bitbucket.org/tagoh/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="|| ( LGPL-3 MPL-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="debug doc introspection static-libs test"
+
+RDEPEND="
+ dev-libs/libxml2
+ introspection? ( dev-libs/gobject-introspection )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ doc? ( dev-util/gtk-doc )
+ introspection? ( dev-libs/gobject-introspection-common )
+ test? ( dev-libs/check )
+"
+
+# Upstream expect liblangtag to be installed when one runs tests...
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${P}-enum.patch )
+
+src_prepare() {
+ default
+ xdg_environment_reset
+ if [[ -d docs/html ]]; then
+ rm -r docs/html || die "Failed to remove existing gtk-doc"
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable introspection) \
+ $(use_enable static-libs static) \
+ $(use_enable test)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}