summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-09-28 17:26:19 +0200
committerMike Gilbert <floppym@gentoo.org>2017-09-28 13:10:57 -0400
commit5f80a5be1a768e5964f4d4f3399eb3b91912c81f (patch)
tree4f43e44f169ed355047dc445461782b0e59c3e4f
parentwww-client/firefox-bin: bump to 56.0 (diff)
downloadgentoo-5f80a5be1a768e5964f4d4f3399eb3b91912c81f.tar.gz
gentoo-5f80a5be1a768e5964f4d4f3399eb3b91912c81f.tar.bz2
gentoo-5f80a5be1a768e5964f4d4f3399eb3b91912c81f.zip
dev-db/sqlite: Fix csv extension on ppc/ppc64 (bug #630698).
-rw-r--r--dev-db/sqlite/files/sqlite-3.20.1-full_tarball-csv-unsigned_char.patch33
-rw-r--r--dev-db/sqlite/sqlite-3.20.1-r1.ebuild (renamed from dev-db/sqlite/sqlite-3.20.1.ebuild)1
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-db/sqlite/files/sqlite-3.20.1-full_tarball-csv-unsigned_char.patch b/dev-db/sqlite/files/sqlite-3.20.1-full_tarball-csv-unsigned_char.patch
new file mode 100644
index 000000000000..86236c4b4bfe
--- /dev/null
+++ b/dev-db/sqlite/files/sqlite-3.20.1-full_tarball-csv-unsigned_char.patch
@@ -0,0 +1,33 @@
+https://sqlite.org/src/info/42f0777555675875
+
+--- ext/misc/csv.c
++++ ext/misc/csv.c
+@@ -78,7 +78,7 @@
+ int nAlloc; /* Space allocated for z[] */
+ int nLine; /* Current line number */
+ int bNotFirst; /* True if prior text has been seen */
+- char cTerm; /* Character that terminated the most recent field */
++ int cTerm; /* Character that terminated the most recent field */
+ size_t iIn; /* Next unread character in the input buffer */
+ size_t nIn; /* Number of characters in the input buffer */
+ char *zIn; /* The input buffer */
+@@ -166,7 +166,7 @@
+ if( p->in!=0 ) return csv_getc_refill(p);
+ return EOF;
+ }
+- return p->zIn[p->iIn++];
++ return ((unsigned char*)p->zIn)[p->iIn++];
+ }
+
+ /* Increase the size of p->z and append character c to the end.
+--- test/releasetest.tcl
++++ test/releasetest.tcl
+@@ -114,7 +114,7 @@
+ }
+ "Debug-One" {
+ --disable-shared
+- -O2
++ -O2 -funsigned-char
+ -DSQLITE_DEBUG=1
+ -DSQLITE_MEMDEBUG=1
+ -DSQLITE_MUTEX_NOOP=1
diff --git a/dev-db/sqlite/sqlite-3.20.1.ebuild b/dev-db/sqlite/sqlite-3.20.1-r1.ebuild
index ee52cadc0f77..7b6ce7814c0f 100644
--- a/dev-db/sqlite/sqlite-3.20.1.ebuild
+++ b/dev-db/sqlite/sqlite-3.20.1-r1.ebuild
@@ -50,6 +50,7 @@ pkg_setup() {
src_prepare() {
if full_tarball; then
eapply -p0 "${FILESDIR}/${PN}-3.20.0-full_tarball-build.patch"
+ eapply -p0 "${FILESDIR}/${PN}-3.20.1-full_tarball-csv-unsigned_char.patch"
eapply_user