summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2019-10-13 19:46:41 +0000
committerPatrick Lauer <patrick@gentoo.org>2019-10-13 19:48:17 +0000
commit5fdd98cf85ca32682a4b1607725f735d040ed1a0 (patch)
tree18052470a7afd59d7102e6828018d308a9e2a7cd
parentmedia-libs/gegl: Drop old versions (diff)
downloadgentoo-5fdd98cf85ca32682a4b1607725f735d040ed1a0.tar.gz
gentoo-5fdd98cf85ca32682a4b1607725f735d040ed1a0.tar.bz2
gentoo-5fdd98cf85ca32682a4b1607725f735d040ed1a0.zip
sci-libs/geos: Bump
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
-rw-r--r--sci-libs/geos/Manifest1
-rw-r--r--sci-libs/geos/geos-3.8.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/sci-libs/geos/Manifest b/sci-libs/geos/Manifest
index 30e3b5649631..c6bf7a54fccb 100644
--- a/sci-libs/geos/Manifest
+++ b/sci-libs/geos/Manifest
@@ -1,2 +1,3 @@
DIST geos-3.7.0.tar.bz2 2028814 BLAKE2B 17385d9be831d4812391a30627e13989d3ca099ca9b0a719a92cdb2503dadff3693d4b3d320652764185db05782b33760ca14d155365d87167bb4ef6d6c2463c SHA512 fcca5e503efa32bb388376b2a06b9ca5c74fbcddba750cce6b3b4109eb2eb122058aead12b9462cdd881f425cd75d7241645ab344f25ce022bc0659954560742
DIST geos-3.7.2.tar.bz2 2071465 BLAKE2B ba968488aa5d845e582d3771d8d2b1f67b0f301e73fad5834a0805a912c8f3b1200bba93d8758f43539ce269758de348d999db3db9738e7abf5c1a443f388d8c SHA512 ff0fde2e21ed9d2770c139aa50c6efd22d9cff3c6bfd8f1ef86b064efd1ad318b08dec66e34661bc1c7a341b0837978853494f27d63988be865a8ee4f7611d38
+DIST geos-3.8.0.tar.bz2 2399403 BLAKE2B 0f9b6d7f9a4052b9b84e77d534be6e2909e5dc4995287f34e3b7e7c1537c9a73088d4a49f96f43034723eb37c88674aae469e26d7db3eb40efbcdf5551553a1a SHA512 c89b25b42092152ef261090f25ff64b229f30f67d42fdf44c2871e78b66bb2c42e23b9ae21f9aea0e48823bdb0267d609ab2ee77d310abcb76fa672c6614d8f1
diff --git a/sci-libs/geos/geos-3.8.0.ebuild b/sci-libs/geos/geos-3.8.0.ebuild
new file mode 100644
index 000000000000..3ad295e1f4be
--- /dev/null
+++ b/sci-libs/geos/geos-3.8.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+MY_PV=${PV/_/}
+S=${WORKDIR}/${PN}-${MY_PV}
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="http://trac.osgeo.org/geos/"
+SRC_URI="http://download.osgeo.org/geos/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc python ruby static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( dev-lang/ruby:* )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ python? ( dev-lang/swig:0 )
+ ruby? ( dev-lang/swig:0 )
+"
+
+RESTRICT="test"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ echo "#!${EPREFIX}/bin/bash" > py-compile
+}
+
+src_configure() {
+ econf \
+ $(use_enable python) \
+ $(use_enable ruby) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+ use doc && emake -C "${S}/doc" doxygen-html
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doc/doxygen_docs/html/. )
+ default
+ use python && python_optimize "${D}$(python_get_sitedir)"/geos/
+
+ find "${D}" -name '*.la' -delete || die
+}