summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-09-23 19:47:46 -0700
committerMatt Turner <mattst88@gentoo.org>2021-09-23 19:54:27 -0700
commit6035fefb46e93cd3471c779bbf3bdd431b060a99 (patch)
tree9942118666d06f65989bd24360e4fd75b447d71e
parentdev-libs/wayland-protocols: Version bump to 1.23 (diff)
downloadgentoo-6035fefb46e93cd3471c779bbf3bdd431b060a99.tar.gz
gentoo-6035fefb46e93cd3471c779bbf3bdd431b060a99.tar.bz2
gentoo-6035fefb46e93cd3471c779bbf3bdd431b060a99.zip
x11-libs/libxkbcommon: Version bump to 1.3.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-libs/libxkbcommon/Manifest1
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-1.3.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index 4d717f518ba9..c60f8ee9f9c3 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -1 +1,2 @@
DIST libxkbcommon-1.3.0.tar.xz 455256 BLAKE2B f53a47005dd411855d1d5c39a33ef58d22982b2d4c2014320722f7fe9a9b468366c6090fadd067e50a846f22de7b80164b684615a8bcb1b14a478609cc4deb74 SHA512 9585ab1df7f2d95b991a786ee1f1de0a645aa315edb93cb093f3409fc76ef7b8f8189a6a7bfd179dc01c5d105d9c9eea40a395762eeffe0618b0c3ee116c0d18
+DIST libxkbcommon-1.3.1.tar.xz 471036 BLAKE2B c46d39876bd4477fe838e17e744ed04388417cfae8bb77c7de48237d31f51fe230d2705733dc0873253b48c61530fbe932e4da7317217c31a7897702fa1d03b4 SHA512 3b2cf6ae9ba4dc8b6fe702ac1fa700034fbc9bd147c73bd2cd93546bcfb71865734b3e46bad35a8fd618ed97266a02dad1dc966c63e6b10404a64919459d933e
diff --git a/x11-libs/libxkbcommon/libxkbcommon-1.3.1.ebuild b/x11-libs/libxkbcommon/libxkbcommon-1.3.1.ebuild
new file mode 100644
index 000000000000..afdec5dec587
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-1.3.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit meson-multilib ${GIT_ECLASS} python-any-r1 virtualx
+
+DESCRIPTION="keymap handling library for toolkits and window systems"
+HOMEPAGE="https://xkbcommon.org/ https://github.com/xkbcommon/libxkbcommon/"
+LICENSE="MIT"
+IUSE="doc static-libs test wayland X"
+RESTRICT="!test? ( test )"
+SLOT="0"
+
+BDEPEND="
+ sys-devel/bison
+ doc? ( app-doc/doxygen )
+ test? ( ${PYTHON_DEPS} )
+ wayland? ( dev-util/wayland-scanner )
+"
+RDEPEND="
+ X? ( >=x11-libs/libxcb-1.10:=[${MULTILIB_USEDEP},xkb] )
+ wayland? ( >=dev-libs/wayland-1.2.0 )
+ dev-libs/libxml2[${MULTILIB_USEDEP}]
+ x11-misc/compose-tables
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+ wayland? ( >=dev-libs/wayland-protocols-1.12 )
+"
+
+pkg_setup() {
+ if use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library="$(usex static-libs both shared)"
+ -Dxkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ $(meson_use wayland enable-wayland)
+ $(meson_use X enable-x11)
+ $(meson_use doc enable-docs)
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ virtx meson_src_test
+}