summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-11-30 14:39:18 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-11-30 14:57:00 +0100
commit6067d19b4660a0e43c37280dcbf01b20d0d8a33a (patch)
treeb6a0953370eadf8e9fe9196a284990c7341e01fd
parentmedia-video/ffmpeg: update zimg dep in live ebuild (diff)
downloadgentoo-6067d19b.tar.gz
gentoo-6067d19b.tar.bz2
gentoo-6067d19b.zip
media-libs/zimg: bump to 2.6.3
Closes: https://bugs.gentoo.org/633748 Package-Manager: Portage-2.3.16, Repoman-2.3.6
-rw-r--r--media-libs/zimg/Manifest5
-rw-r--r--media-libs/zimg/zimg-2.6.3.ebuild36
-rw-r--r--media-libs/zimg/zimg-9999.ebuild2
3 files changed, 40 insertions, 3 deletions
diff --git a/media-libs/zimg/Manifest b/media-libs/zimg/Manifest
index 6a4583d130c0..9a040bff121b 100644
--- a/media-libs/zimg/Manifest
+++ b/media-libs/zimg/Manifest
@@ -1,2 +1,3 @@
-DIST zimg-2.5.1.tar.gz 213083 SHA256 deb85887081cab7fa9c492b588900d60d6466e61ee8ea51a84ca280688d93de9 SHA512 c16402ee7aff40b811cd8c69c1e5d5f13775e628f3d5300e82548b6cc97d17e5317fa58d498a0cb4f7699d4eb2d1f424c3f4d9858f4cfbdda36612d6693961a0 WHIRLPOOL 7dac4a8f305e471b10db50bd6f189d9591e2ca46ec008c7bec1e4d6f6b47f409dfeed575e5bc7a00678430e5a673196ab814c5c45b1afeb43145b33f8dcc63dc
-DIST zimg-2.5.tar.gz 213054 SHA256 50b2bcc49e51cd36011a0c363ff914a81b6f161aefdffeaa2bc4a4627c13784d SHA512 7fc48c704b434d837c36d4bafc51b35789eaf90fc81a68dcd7ec546f1e82a3e41c53263f8d381541d5c0ce58e25dddf0adaf1c3575512842ae633b5581778938 WHIRLPOOL 38ec8b7c26b8b358551a8158372f0cf1d27fbb4a0666ec8b56c3b7227f18bda4267f252596eba5a26347463ef8426982c9befe2ccf9bb1384a17d393ff35390a
+DIST zimg-2.5.1.tar.gz 213083 BLAKE2B d0ea74d409fa19b6e9ed946c70d2c41d0ee35e38955b8c14eba9c9f769405db97fc4884043ab378c2e4c36540fae524ce97173ecd2e30f6ecde12bc579327a88 SHA512 c16402ee7aff40b811cd8c69c1e5d5f13775e628f3d5300e82548b6cc97d17e5317fa58d498a0cb4f7699d4eb2d1f424c3f4d9858f4cfbdda36612d6693961a0
+DIST zimg-2.5.tar.gz 213054 BLAKE2B 0532693c11c1b2bcc0d5bde3a0bc16bf4f736ceff5fcda5d9bf491fcebe7e8be538041cc536e40bc110e438370c8599ce0be35f71cea00429b16c6eeb680cb86 SHA512 7fc48c704b434d837c36d4bafc51b35789eaf90fc81a68dcd7ec546f1e82a3e41c53263f8d381541d5c0ce58e25dddf0adaf1c3575512842ae633b5581778938
+DIST zimg-2.6.3.tar.gz 238372 BLAKE2B 4651381c61b978bedd78871117fbe0b1be7e40e3b0d32b399ab47cab06d596befb61078a6f979f2a2ea962ba66046f776e18a2bbf304dee4a2428b303a3094a7 SHA512 497d3b5b0c004fe720c9be2460f251196789ed055a0081b774c78f8c311dc097c2b5d975cb0a7d41e819ca21527e961186b665b5791032787c3b30647011e7da
diff --git a/media-libs/zimg/zimg-2.6.3.ebuild b/media-libs/zimg/zimg-2.6.3.ebuild
new file mode 100644
index 000000000000..efc3a2b24237
--- /dev/null
+++ b/media-libs/zimg/zimg-2.6.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+SCM=""
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
+fi
+
+inherit autotools-multilib ${SCM}
+
+DESCRIPTION="Scaling, colorspace conversion, and dithering library"
+HOMEPAGE="https://github.com/sekrit-twc/zimg"
+
+if [ "${PV#9999}" = "${PV}" ] ; then
+ SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+ S="${WORKDIR}/${PN}-release-${PV}/"
+fi
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="static-libs cpu_flags_x86_sse"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ autotools-multilib_src_configure \
+ $(use_enable cpu_flags_x86_sse x86simd)
+}
diff --git a/media-libs/zimg/zimg-9999.ebuild b/media-libs/zimg/zimg-9999.ebuild
index d9ebe7355623..efc3a2b24237 100644
--- a/media-libs/zimg/zimg-9999.ebuild
+++ b/media-libs/zimg/zimg-9999.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="https://github.com/sekrit-twc/zimg"
if [ "${PV#9999}" = "${PV}" ] ; then
SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
S="${WORKDIR}/${PN}-release-${PV}/"
fi