summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-09-23 00:38:25 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-09-23 00:43:16 -0700
commit60c6294ba52b585673ef679432fe6ab4ca71b108 (patch)
tree2f69a24b6132fd3518a81faa41ee914ba90a48c5
parentdev-python/pymysql: Mark ALLARCHES (diff)
downloadgentoo-60c6294ba52b585673ef679432fe6ab4ca71b108.tar.gz
gentoo-60c6294ba52b585673ef679432fe6ab4ca71b108.tar.bz2
gentoo-60c6294ba52b585673ef679432fe6ab4ca71b108.zip
app-emulation/docker: fix runc symlink
Closes: https://bugs.gentoo.org/744253 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--app-emulation/docker/docker-19.03.13-r1.ebuild (renamed from app-emulation/docker/docker-19.03.13.ebuild)3
1 files changed, 2 insertions, 1 deletions
diff --git a/app-emulation/docker/docker-19.03.13.ebuild b/app-emulation/docker/docker-19.03.13-r1.ebuild
index e1df62c680d7..94fb34cc447e 100644
--- a/app-emulation/docker/docker-19.03.13.ebuild
+++ b/app-emulation/docker/docker-19.03.13-r1.ebuild
@@ -30,6 +30,7 @@ IUSE="apparmor aufs btrfs +container-init device-mapper hardened overlay seccomp
BDEPEND="
>=dev-lang/go-1.13.12
dev-go/go-md2man
+ virtual/pkgconfig
"
DEPEND="
@@ -254,7 +255,7 @@ src_compile() {
src_install() {
dosym containerd /usr/bin/docker-containerd
dosym containerd-shim /usr/bin/docker-containerd-shim
- dosym runc /usr/bin/docker-runc
+ dosym ../sbin/runc /usr/bin/docker-runc
use container-init && dosym tini /usr/bin/docker-init
pushd components/engine || die