summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-04-15 17:25:05 -0700
committerMatt Turner <mattst88@gentoo.org>2018-04-15 17:25:09 -0700
commit60e1ee0405610605c00c0640bb37d1a43b2358df (patch)
treec62452e9913985ed05c37de85b34a9c16352a926
parentmedia-libs/vulkan-loader: Fix installation with ninja (diff)
downloadgentoo-60e1ee0405610605c00c0640bb37d1a43b2358df.tar.gz
gentoo-60e1ee0405610605c00c0640bb37d1a43b2358df.tar.bz2
gentoo-60e1ee0405610605c00c0640bb37d1a43b2358df.zip
media-libs/vulkan-loader: Drop old versions
Intentionally dropping only stable versions.
-rw-r--r--media-libs/vulkan-loader/Manifest6
-rw-r--r--media-libs/vulkan-loader/files/vulkan-loader-1.0.54.0-remove-executable-stack.patch25
-rw-r--r--media-libs/vulkan-loader/vulkan-loader-1.0.42.0.ebuild50
-rw-r--r--media-libs/vulkan-loader/vulkan-loader-1.0.42.2.ebuild50
-rw-r--r--media-libs/vulkan-loader/vulkan-loader-1.0.46.0.ebuild50
-rw-r--r--media-libs/vulkan-loader/vulkan-loader-1.0.51.0.ebuild50
-rw-r--r--media-libs/vulkan-loader/vulkan-loader-1.0.54.0.ebuild52
-rw-r--r--media-libs/vulkan-loader/vulkan-loader-1.0.61.1.ebuild50
8 files changed, 0 insertions, 333 deletions
diff --git a/media-libs/vulkan-loader/Manifest b/media-libs/vulkan-loader/Manifest
index c53ca107c93..0e4ad6f0f75 100644
--- a/media-libs/vulkan-loader/Manifest
+++ b/media-libs/vulkan-loader/Manifest
@@ -1,7 +1 @@
-DIST vulkan-loader-1.0.42.0.tar.gz 3699030 BLAKE2B acf29a2379f37367b37f2d8278cf1b512fb016c05fb5f5ee0d5d4b9c995123310728a01d1f0e341686bc2041265a9d9f64c19be451e8e6e608b748ee4d3035af SHA512 2c35aecffc60992023184e499d036d99a3c39b3b3856341f341fc9c5b2b0c71cc49a4658634165f4d5218a7202f4c2ddfb95107ba95f2c8a9870e375cff7a15b
-DIST vulkan-loader-1.0.42.2.tar.gz 3701608 BLAKE2B b6769a29c1a385ec564cdd897255a1055c583c95d9948ee8bd653606bcfb0d07dbf4abf10c3d2711059635a0d9d73edb82fda4f7aeb12107f0b2b705c809ade4 SHA512 6f591bcb69edde516cf170936e23a3f19f2f57a22b65d19683c10528ed6559501d3dae29ee1d3e820a81a5cd6e608f5710ba15f7c9bc050ea0eaceef2cf82d37
-DIST vulkan-loader-1.0.46.0.tar.gz 3732605 BLAKE2B 364f6a763d016bebb1100dc594a006da7b4a27147398ce9efdceac4ca7bc5ced235ab6bad978cfa9bca4489e6a069c145030b38354778dccbc8559babba1cbf5 SHA512 dc0728c00e017a2ed0b1e34a500a6335f6dee5dd77c7801d7d450c68c6e8c7cd5dec640be6dec1dea28941d927764a636b82a628e0260ca724163afa4152d8b6
-DIST vulkan-loader-1.0.51.0.tar.gz 3796337 BLAKE2B 9a418e6e4cfe1f19c8716788452f4ed219be14fcdadf3c5cb983d031f3a95a7f6322a94aced391711ba486274611ff5ea2ae87c2116a6c16b9aa0b2f97e10c72 SHA512 5d198fc9537c8fa3cbde19fc74f8d47595fabcb52c8db1c626fa157f171ed74ad202e086f7c9e94827c1ab682d03bae58af690c510c6705ca92db0548ee575f6
-DIST vulkan-loader-1.0.54.0.tar.gz 3842785 BLAKE2B 72b14546859f38f090554a9ff04dce91fb0764f5180ca22a3e863e992276c4c4e9a85ca946b18a0c54fed99b58a39b9c65a67c4302aa337e89a04d435a606df2 SHA512 f5478e1a7f966a2d09b97a3b47a04b4c9ccd68b88126fefcd6f97bfd0347c5a5bebf52e1cdfccc4863d22dd3b875e04cddf406e3e546eb3dc50d2ef61d85a21f
-DIST vulkan-loader-1.0.61.1.tar.gz 3889453 BLAKE2B 0d5f1335e874294350e02063b11e5efb3d1f3bb69a7c970f2b6a6cbe9b78651c7810644d30b404016ed126ad63c4ab46b017c2ef033ba1c45046fd310218cd55 SHA512 e16599ca458dc1c636c80a03693edc4a24563e08768de95e7711cd7927d7cfdcd0ce14d16d938ca066bfe4ce8fe43836d2b61973bc2a7ba6ad14ab5f18166e0e
DIST vulkan-loader-1.1.70.0.tar.gz 4107351 BLAKE2B 86859e74839a0a7c667476db62a1bc73d89f22e6bb951f2742bc6990ed498e9201bd17973e887f360b2eec610e29d547e79d5323ed74fd5618cb0fc75dbba063 SHA512 ae57e6890225b6e4607fde04a296a14bc54fd6b61b360b771bd24f00607dcb6fff06b3ec38a761173c92c90628a139f1424445e174c21adad4af6f445b91ed26
diff --git a/media-libs/vulkan-loader/files/vulkan-loader-1.0.54.0-remove-executable-stack.patch b/media-libs/vulkan-loader/files/vulkan-loader-1.0.54.0-remove-executable-stack.patch
deleted file mode 100644
index 36b50b91e73..00000000000
--- a/media-libs/vulkan-loader/files/vulkan-loader-1.0.54.0-remove-executable-stack.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 3152f2a5056077d3e1061ac61e3ef7888ff96dc7 Mon Sep 17 00:00:00 2001
-From: Lenny Komow <lenny@lunarg.com>
-Date: Thu, 20 Jul 2017 16:07:14 -0600
-Subject: [PATCH] loader: Remove executable stack from libvulkan.so
-
-Change-Id: Id77d5560479cbbc6f5453a6362c5a20dd721fdd0
----
- loader/unknown_ext_chain_gas.asm | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/loader/unknown_ext_chain_gas.asm b/loader/unknown_ext_chain_gas.asm
-index e463f45be..798760bd8 100644
---- a/loader/unknown_ext_chain_gas.asm
-+++ b/loader/unknown_ext_chain_gas.asm
-@@ -108,6 +108,10 @@ vkdev_ext\num:
-
- .endif
-
-+#if defined(__ELF__)
-+.section .note.GNU-stack,"",%progbits
-+#endif
-+
- .data
-
- termin_error_string:
diff --git a/media-libs/vulkan-loader/vulkan-loader-1.0.42.0.ebuild b/media-libs/vulkan-loader/vulkan-loader-1.0.42.0.ebuild
deleted file mode 100644
index 56caaa6fd6e..00000000000
--- a/media-libs/vulkan-loader/vulkan-loader-1.0.42.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{4,5} )
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers.git"
- inherit git-r3
-else
- KEYWORDS="amd64"
- SRC_URI="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers/archive/sdk-${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/Vulkan-LoaderAndValidationLayers-sdk-${PV}"
-fi
-
-inherit python-any-r1 cmake-multilib
-
-DESCRIPTION="Vulkan Installable Client Driver (ICD) Loader"
-HOMEPAGE="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="wayland X"
-
-RDEPEND=""
-DEPEND="${PYTHON_DEPS}
- wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
- X? ( x11-libs/libX11:=[${MULTILIB_USEDEP}] )"
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DCMAKE_SKIP_RPATH=True
- -DBUILD_TESTS=False
- -DBUILD_LAYERS=False
- -DBUILD_DEMOS=False
- -DBUILD_VKJSON=False
- -DBUILD_LOADER=True
- -DBUILD_WSI_MIR_SUPPORT=False
- -DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
- -DBUILD_WSI_XCB_SUPPORT=$(usex X)
- -DBUILD_WSI_XLIB_SUPPORT=$(usex X)
- )
- cmake-utils_src_configure
-}
-
-multilib_src_install() {
- keepdir /etc/vulkan/icd.d
-
- default
-}
diff --git a/media-libs/vulkan-loader/vulkan-loader-1.0.42.2.ebuild b/media-libs/vulkan-loader/vulkan-loader-1.0.42.2.ebuild
deleted file mode 100644
index 4ab7f86d549..00000000000
--- a/media-libs/vulkan-loader/vulkan-loader-1.0.42.2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{4,5} )
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers.git"
- inherit git-r3
-else
- KEYWORDS="~amd64"
- SRC_URI="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers/archive/sdk-${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/Vulkan-LoaderAndValidationLayers-sdk-${PV}"
-fi
-
-inherit python-any-r1 cmake-multilib
-
-DESCRIPTION="Vulkan Installable Client Driver (ICD) Loader"
-HOMEPAGE="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="wayland X"
-
-RDEPEND=""
-DEPEND="${PYTHON_DEPS}
- wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
- X? ( x11-libs/libX11:=[${MULTILIB_USEDEP}] )"
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DCMAKE_SKIP_RPATH=True
- -DBUILD_TESTS=False
- -DBUILD_LAYERS=False
- -DBUILD_DEMOS=False
- -DBUILD_VKJSON=False
- -DBUILD_LOADER=True
- -DBUILD_WSI_MIR_SUPPORT=False
- -DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
- -DBUILD_WSI_XCB_SUPPORT=$(usex X)
- -DBUILD_WSI_XLIB_SUPPORT=$(usex X)
- )
- cmake-utils_src_configure
-}
-
-multilib_src_install() {
- keepdir /etc/vulkan/icd.d
-
- default
-}
diff --git a/media-libs/vulkan-loader/vulkan-loader-1.0.46.0.ebuild b/media-libs/vulkan-loader/vulkan-loader-1.0.46.0.ebuild
deleted file mode 100644
index 56caaa6fd6e..00000000000
--- a/media-libs/vulkan-loader/vulkan-loader-1.0.46.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{4,5} )
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers.git"
- inherit git-r3
-else
- KEYWORDS="amd64"
- SRC_URI="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers/archive/sdk-${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/Vulkan-LoaderAndValidationLayers-sdk-${PV}"
-fi
-
-inherit python-any-r1 cmake-multilib
-
-DESCRIPTION="Vulkan Installable Client Driver (ICD) Loader"
-HOMEPAGE="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="wayland X"
-
-RDEPEND=""
-DEPEND="${PYTHON_DEPS}
- wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
- X? ( x11-libs/libX11:=[${MULTILIB_USEDEP}] )"
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DCMAKE_SKIP_RPATH=True
- -DBUILD_TESTS=False
- -DBUILD_LAYERS=False
- -DBUILD_DEMOS=False
- -DBUILD_VKJSON=False
- -DBUILD_LOADER=True
- -DBUILD_WSI_MIR_SUPPORT=False
- -DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
- -DBUILD_WSI_XCB_SUPPORT=$(usex X)
- -DBUILD_WSI_XLIB_SUPPORT=$(usex X)
- )
- cmake-utils_src_configure
-}
-
-multilib_src_install() {
- keepdir /etc/vulkan/icd.d
-
- default
-}
diff --git a/media-libs/vulkan-loader/vulkan-loader-1.0.51.0.ebuild b/media-libs/vulkan-loader/vulkan-loader-1.0.51.0.ebuild
deleted file mode 100644
index 4ab7f86d549..00000000000
--- a/media-libs/vulkan-loader/vulkan-loader-1.0.51.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{4,5} )
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers.git"
- inherit git-r3
-else
- KEYWORDS="~amd64"
- SRC_URI="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers/archive/sdk-${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/Vulkan-LoaderAndValidationLayers-sdk-${PV}"
-fi
-
-inherit python-any-r1 cmake-multilib
-
-DESCRIPTION="Vulkan Installable Client Driver (ICD) Loader"
-HOMEPAGE="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="wayland X"
-
-RDEPEND=""
-DEPEND="${PYTHON_DEPS}
- wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
- X? ( x11-libs/libX11:=[${MULTILIB_USEDEP}] )"
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DCMAKE_SKIP_RPATH=True
- -DBUILD_TESTS=False
- -DBUILD_LAYERS=False
- -DBUILD_DEMOS=False
- -DBUILD_VKJSON=False
- -DBUILD_LOADER=True
- -DBUILD_WSI_MIR_SUPPORT=False
- -DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
- -DBUILD_WSI_XCB_SUPPORT=$(usex X)
- -DBUILD_WSI_XLIB_SUPPORT=$(usex X)
- )
- cmake-utils_src_configure
-}
-
-multilib_src_install() {
- keepdir /etc/vulkan/icd.d
-
- default
-}
diff --git a/media-libs/vulkan-loader/vulkan-loader-1.0.54.0.ebuild b/media-libs/vulkan-loader/vulkan-loader-1.0.54.0.ebuild
deleted file mode 100644
index 6ad40bf0e05..00000000000
--- a/media-libs/vulkan-loader/vulkan-loader-1.0.54.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{4,5} )
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers.git"
- inherit git-r3
-else
- KEYWORDS="~amd64"
- SRC_URI="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers/archive/sdk-${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/Vulkan-LoaderAndValidationLayers-sdk-${PV}"
-fi
-
-inherit python-any-r1 cmake-multilib
-
-DESCRIPTION="Vulkan Installable Client Driver (ICD) Loader"
-HOMEPAGE="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="wayland X"
-
-RDEPEND=""
-DEPEND="${PYTHON_DEPS}
- wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
- X? ( x11-libs/libX11:=[${MULTILIB_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/${P}-remove-executable-stack.patch )
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DCMAKE_SKIP_RPATH=True
- -DBUILD_TESTS=False
- -DBUILD_LAYERS=False
- -DBUILD_DEMOS=False
- -DBUILD_VKJSON=False
- -DBUILD_LOADER=True
- -DBUILD_WSI_MIR_SUPPORT=False
- -DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
- -DBUILD_WSI_XCB_SUPPORT=$(usex X)
- -DBUILD_WSI_XLIB_SUPPORT=$(usex X)
- )
- cmake-utils_src_configure
-}
-
-multilib_src_install() {
- keepdir /etc/vulkan/icd.d
-
- default
-}
diff --git a/media-libs/vulkan-loader/vulkan-loader-1.0.61.1.ebuild b/media-libs/vulkan-loader/vulkan-loader-1.0.61.1.ebuild
deleted file mode 100644
index c4fe082f078..00000000000
--- a/media-libs/vulkan-loader/vulkan-loader-1.0.61.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{4,5,6} )
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers.git"
- inherit git-r3
-else
- KEYWORDS="~amd64"
- SRC_URI="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers/archive/sdk-${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/Vulkan-LoaderAndValidationLayers-sdk-${PV}"
-fi
-
-inherit python-any-r1 cmake-multilib
-
-DESCRIPTION="Vulkan Installable Client Driver (ICD) Loader"
-HOMEPAGE="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="wayland X"
-
-RDEPEND=""
-DEPEND="${PYTHON_DEPS}
- wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
- X? ( x11-libs/libX11:=[${MULTILIB_USEDEP}] )"
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DCMAKE_SKIP_RPATH=True
- -DBUILD_TESTS=False
- -DBUILD_LAYERS=False
- -DBUILD_DEMOS=False
- -DBUILD_VKJSON=False
- -DBUILD_LOADER=True
- -DBUILD_WSI_MIR_SUPPORT=False
- -DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
- -DBUILD_WSI_XCB_SUPPORT=$(usex X)
- -DBUILD_WSI_XLIB_SUPPORT=$(usex X)
- )
- cmake-utils_src_configure
-}
-
-multilib_src_install() {
- keepdir /etc/vulkan/icd.d
-
- default
-}