summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-03-18 17:04:28 +0100
committerDavid Seifert <soap@gentoo.org>2023-03-18 17:04:28 +0100
commit618bfbe7d912eebdc4e2dcc6c9638de120ae987b (patch)
tree37a4d286b339d564ce86f4d49840c0a9427c184a
parentdev-python/setuptools_trial: treeclean (diff)
downloadgentoo-618bfbe7d912eebdc4e2dcc6c9638de120ae987b.tar.gz
gentoo-618bfbe7d912eebdc4e2dcc6c9638de120ae987b.tar.bz2
gentoo-618bfbe7d912eebdc4e2dcc6c9638de120ae987b.zip
dev-python/scandir: treeclean
Closes: https://bugs.gentoo.org/828921 Closes: https://bugs.gentoo.org/895198 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-python/scandir/Manifest1
-rw-r--r--dev-python/scandir/files/scandir-1.10.0-python3.9.patch62
-rw-r--r--dev-python/scandir/metadata.xml16
-rw-r--r--dev-python/scandir/scandir-1.10.0-r3.ebuild26
-rw-r--r--profiles/package.mask7
5 files changed, 0 insertions, 112 deletions
diff --git a/dev-python/scandir/Manifest b/dev-python/scandir/Manifest
deleted file mode 100644
index 4e7260a6434e..000000000000
--- a/dev-python/scandir/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST scandir-1.10.0.tar.gz 33311 BLAKE2B 47576618c41a477ff7bab9daecf2e4719ed0c497a25fd68b4bacae073fc418f9fc51503812af726d1d124f07cccfb418ae09c196cf7ce283abf5d3bbc36b7e09 SHA512 42a570320018ffff2172ada67002334446c73c53813b36d63558d3854ded2fac0b266fcaf399cf9a735ceba110636b6901683fb26cde1e286ff476bc37e3d335
diff --git a/dev-python/scandir/files/scandir-1.10.0-python3.9.patch b/dev-python/scandir/files/scandir-1.10.0-python3.9.patch
deleted file mode 100644
index c8683c1c6b9b..000000000000
--- a/dev-python/scandir/files/scandir-1.10.0-python3.9.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-https://github.com/benhoyt/scandir/commit/3396aa4155ffde8600a0e9ca50d5872569169b5d
-
-From 3396aa4155ffde8600a0e9ca50d5872569169b5d Mon Sep 17 00:00:00 2001
-From: Ben Hoyt <benhoyt@gmail.com>
-Date: Mon, 24 Jan 2022 08:44:07 +1300
-Subject: [PATCH] Add Python 3.10 to tests (#137)
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Fix PyStructSequence_UnnamedField build issues on Python 3.9/3.10
-
-_scandir.c:663:7: error: conflicting type qualifiers for ‘PyStructSequence_UnnamedField’
- 663 | char *PyStructSequence_UnnamedField = "unnamed field";
- | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-In file included from /usr/local/include/python3.10/Python.h:127,
- from _scandir.c:14:
-/usr/local/include/python3.10/structseq.h:22:27: note: previous declaration of ‘PyStructSequence_UnnamedField’ was here
- 22 | extern const char * const PyStructSequence_UnnamedField;
- | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-
-Fixes https://github.com/benhoyt/scandir/pull/137
----
- _scandir.c | 10 +++++-----
- scandir.py | 2 +-
- 3 files changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/_scandir.c b/_scandir.c
-index 6cc28c8..433483f 100644
---- a/_scandir.c
-+++ b/_scandir.c
-@@ -660,7 +660,7 @@ _pystat_fromstructstat(STRUCT_STAT *st)
- return v;
- }
-
--char *PyStructSequence_UnnamedField = "unnamed field";
-+static char *scandir_unnamed_field = "unnamed field";
-
- PyDoc_STRVAR(stat_result__doc__,
- "stat_result: Result from stat, fstat, or lstat.\n\n\
-@@ -681,7 +681,7 @@ static PyStructSequence_Field stat_result_fields[] = {
- {"st_uid", "user ID of owner"},
- {"st_gid", "group ID of owner"},
- {"st_size", "total size, in bytes"},
-- /* The NULL is replaced with PyStructSequence_UnnamedField later. */
-+ /* The NULL is replaced with scandir_unnamed_field later. */
- {NULL, "integer time of last access"},
- {NULL, "integer time of last modification"},
- {NULL, "integer time of last change"},
-@@ -1817,9 +1817,9 @@ init_scandir(void)
- if (!billion)
- INIT_ERROR;
-
-- stat_result_desc.fields[7].name = PyStructSequence_UnnamedField;
-- stat_result_desc.fields[8].name = PyStructSequence_UnnamedField;
-- stat_result_desc.fields[9].name = PyStructSequence_UnnamedField;
-+ stat_result_desc.fields[7].name = scandir_unnamed_field;
-+ stat_result_desc.fields[8].name = scandir_unnamed_field;
-+ stat_result_desc.fields[9].name = scandir_unnamed_field;
- PyStructSequence_InitType(&StatResultType, &stat_result_desc);
- structseq_new = StatResultType.tp_new;
- StatResultType.tp_new = statresult_new;
diff --git a/dev-python/scandir/metadata.xml b/dev-python/scandir/metadata.xml
deleted file mode 100644
index 525e3bfdcccb..000000000000
--- a/dev-python/scandir/metadata.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <maintainer type="person">
- <email>monsieurp@gentoo.org</email>
- <name>Patrice Clement</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">scandir</remote-id>
- <remote-id type="github">benhoyt/scandir</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/scandir/scandir-1.10.0-r3.ebuild b/dev-python/scandir/scandir-1.10.0-r3.ebuild
deleted file mode 100644
index 3110d3be206b..000000000000
--- a/dev-python/scandir/scandir-1.10.0-r3.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-# Do NOT add Python 3.11 without verifying the C extension is actually built
-# and installed for it!
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A better directory iterator and faster os.walk()"
-HOMEPAGE="https://github.com/benhoyt/scandir"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-PATCHES=(
- "${FILESDIR}"/${P}-python3.9.patch
-)
-
-python_test() {
- "${EPYTHON}" test/run_tests.py -v || die "tests failed under ${EPYTHON}"
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index 90fd97817a23..b5068fbb2d18 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -263,13 +263,6 @@ app-eselect/eselect-opencascade
# Removal on 2023-03-21. Bug #895342.
dev-python/flask-script
-# Sam James <sam@gentoo.org> (2023-02-18)
-# Backport to Python 3.5(!) hence irrelevant for newer versions of Python
-# where os.scandir() and os.walk() improvements were integrated in the stdlib.
-# Incompatible with Python 3.11. No reverse dependencies.
-# Removal on 2023-03-18. bug #895198
-dev-python/scandir
-
# Michał Górny <mgorny@gentoo.org> (2023-02-17)
# Merged into dev-python/pytest-cov in 2020. No revdeps left.
# Removal on 2023-03-19. Bug #895120.