summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-15 20:26:16 +0000
committerSam James <sam@gentoo.org>2021-03-15 20:58:37 +0000
commit62e6604d69ea1b0bfb4abdbd1d7c2fa9726a2023 (patch)
tree1267dc24166d6fc0a4bbddb894ef6fc23f4428cd
parentnet-analyzer/bwm-ng: add github upstream metadata (diff)
downloadgentoo-62e6604d69ea1b0bfb4abdbd1d7c2fa9726a2023.tar.gz
gentoo-62e6604d69ea1b0bfb4abdbd1d7c2fa9726a2023.tar.bz2
gentoo-62e6604d69ea1b0bfb4abdbd1d7c2fa9726a2023.zip
net-analyzer/bwm-ng: add 0.6.3
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-analyzer/bwm-ng/Manifest1
-rw-r--r--net-analyzer/bwm-ng/bwm-ng-0.6.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/bwm-ng/Manifest b/net-analyzer/bwm-ng/Manifest
index 44c35c9cce13..3a067d36e83b 100644
--- a/net-analyzer/bwm-ng/Manifest
+++ b/net-analyzer/bwm-ng/Manifest
@@ -1,2 +1,3 @@
DIST bwm-ng-0.6.1.tar.gz 162620 BLAKE2B 28e201ac681fcb1d79afead8a7d2c31d52bfa9ee1ebc132d3cd1080a7edd8ddcc8c0cd6df1897d23a1c79a4a5d9157214a8f3224bd5f8f2c1a12cad96ec188bd SHA512 3f8d4a10f5cbf743d6aee9c6170f334c4274224a2f1886f04338c9a1bf0cf13af5be4aaea0445c9e5b5d361915cc3a93bbfe7c4abf69a0d24e42bc414d8056cd
DIST bwm-ng-0.6.2.tar.gz 70079 BLAKE2B 4e0c5dd73bdcaabf5138ce842e5ce50709ba3bc0792f11ebee2640b6246f5bd740fcf8ad79b7dcffabdbc8f44c5ec2d925b20cf28609f8735e537f6920f92aba SHA512 4a7f141692f96dfab0c1729a7df36f5213a75ddb891b967b2cf951419daea7b84354c276705a0ee7c09f4ed26948ca068f65a04b8f9d18b2b8ed2df97b5e3b0a
+DIST bwm-ng-0.6.3.tar.gz 70094 BLAKE2B bfc5007470a2e4d7f50dc43dc33898f5bcb34a0eaeeb0f53ed74029299ac2b732d343eaf725144a05b778ad8a204c5d546f0ea0b6aaf997995e2e7a6bc3c6cf6 SHA512 85ce29e6ffa9643b4e7c1d731f4e928ddca8cfdc71c86b65ec4e55058b951eb8da9ab80139145300518223589d5fece5bdc11ede91a1ea394d569993ccdb0ab8
diff --git a/net-analyzer/bwm-ng/bwm-ng-0.6.3.ebuild b/net-analyzer/bwm-ng/bwm-ng-0.6.3.ebuild
new file mode 100644
index 000000000000..d7770f571f23
--- /dev/null
+++ b/net-analyzer/bwm-ng/bwm-ng-0.6.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Bandwidth Monitor NG is a small and simple console-based bandwidth monitor"
+HOMEPAGE="http://www.gropp.org/"
+SRC_URI="https://github.com/vgropp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+csv +html"
+
+RDEPEND="
+ >=sys-apps/net-tools-1.60-r1
+ sys-libs/ncurses:0=
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.2-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable csv) \
+ $(use_enable html) \
+ --with-ncurses \
+ --with-procnetdev
+}