summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-01-01 14:14:48 -0500
committerCraig Andrews <candrews@gentoo.org>2020-01-01 14:15:23 -0500
commit6304c0dfc487b0dc2515aafec6444306f057438e (patch)
tree8de9ed1f256ad51a04046854b1e151d7ab18f475
parentsci-chemistry/gromacs: arm stable wrt bug #703794 (diff)
downloadgentoo-6304c0dfc487b0dc2515aafec6444306f057438e.tar.gz
gentoo-6304c0dfc487b0dc2515aafec6444306f057438e.tar.bz2
gentoo-6304c0dfc487b0dc2515aafec6444306f057438e.zip
dev-libs/libfmt: Switch to cmake.eclass
Bug: https://bugs.gentoo.org/704462 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--dev-libs/libfmt/libfmt-6.1.2.ebuild5
-rw-r--r--dev-libs/libfmt/libfmt-9999.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/dev-libs/libfmt/libfmt-6.1.2.ebuild b/dev-libs/libfmt/libfmt-6.1.2.ebuild
index fc0c0c0b8bef..78c2d74959bb 100644
--- a/dev-libs/libfmt/libfmt-6.1.2.ebuild
+++ b/dev-libs/libfmt/libfmt-6.1.2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
DESCRIPTION="Small, safe and fast formatting library"
@@ -31,5 +32,5 @@ multilib_src_configure() {
-DFMT_LIB_DIR="$(get_libdir)"
-DFMT_TEST=$(usex test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/dev-libs/libfmt/libfmt-9999.ebuild b/dev-libs/libfmt/libfmt-9999.ebuild
index fc0c0c0b8bef..78c2d74959bb 100644
--- a/dev-libs/libfmt/libfmt-9999.ebuild
+++ b/dev-libs/libfmt/libfmt-9999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
DESCRIPTION="Small, safe and fast formatting library"
@@ -31,5 +32,5 @@ multilib_src_configure() {
-DFMT_LIB_DIR="$(get_libdir)"
-DFMT_TEST=$(usex test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}