summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-10-02 05:36:26 -0500
committerBen Kohler <bkohler@gentoo.org>2021-10-02 05:50:55 -0500
commit630b751e7063f9043b1c81d700ccb98d2329a3e7 (patch)
tree6db6f437cc4b4fa78afcca5a9076860ea87ed99f
parentdev-python/ndg-httpsclient: Keyword 0.5.1 for ~m68k (diff)
downloadgentoo-630b751e7063f9043b1c81d700ccb98d2329a3e7.tar.gz
gentoo-630b751e7063f9043b1c81d700ccb98d2329a3e7.tar.bz2
gentoo-630b751e7063f9043b1c81d700ccb98d2329a3e7.zip
media-gfx/fotoxx: bump to 21.55
Package-Manager: Portage-3.0.26, Repoman-3.0.3 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--media-gfx/fotoxx/Manifest1
-rw-r--r--media-gfx/fotoxx/fotoxx-21.55.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/media-gfx/fotoxx/Manifest b/media-gfx/fotoxx/Manifest
index 79fd1bafd235..ce695387e91d 100644
--- a/media-gfx/fotoxx/Manifest
+++ b/media-gfx/fotoxx/Manifest
@@ -2,3 +2,4 @@ DIST fotoxx-21.41.tar.gz 8619224 BLAKE2B 28ec5fef8780001a023527c0859b58e1b3347b9
DIST fotoxx-21.44.tar.gz 8670703 BLAKE2B e3c1a0d68ab530345048833c5c33ababa1f3ef27e99379888c748297a2d69a248eb64b6881b53bcdde759f53aea75292d3c205ca11d9ed291465514bf294d323 SHA512 06446fbd0c44a632d5525acec155f8d51ee9ffd66dc9ba97a01bb30f4a8e4b9355650ea50967a537cbf077062898def227c46b07dd7d6d2c6ab8af3f4654c490
DIST fotoxx-21.50.tar.gz 8693590 BLAKE2B d3bed82c3e856d6ce2433e0357955f32d462d0dfcf8de673a7c0fbe8aeeea766711c2617730c6a83501b07bd5f5ab60c9d56caeacd6ea938428758a39b5a75b3 SHA512 018735ff4b1fc99a64eccb05af05e9858f9dfce3c6925704f1739c22a49d3209f66d668b21cb6030d971bbe116c978c5d491aaba033683d5ed5268ee0e46ff9e
DIST fotoxx-21.52.tar.gz 8666385 BLAKE2B 3d994cdc7ca80029df00b661409d9ce64de6f568e90840d92576ffeee9f305175875a5b506a91ab9be394850817d64541c96d8e2cf10fac5a9b0afa3ebd4855f SHA512 da73c176456ff904093c648565cc69d270e5282df5687a8302614624ceac565b3131f035190ef7b6d84f937b84409cdc02a650bfbe7d9051200d19b22bf0d0f6
+DIST fotoxx-21.55.tar.gz 8667304 BLAKE2B 9a324883ba29d8847763985ff33d3e7eaf2a73449fab9c60dee05144c5dc98caf8bef8ce886736fcfae38a7f58526bfb3868da3d3ae2a283ecfabf1bb8858061 SHA512 a207a861b1bc2d8a41ec36a58b1bc9f61db380ae651dee98faf295a1e98730b7fed5a361ab0f09630d8d0f170e58bdf897424ca1d86f27cb669e75f305ea3fb8
diff --git a/media-gfx/fotoxx/fotoxx-21.55.ebuild b/media-gfx/fotoxx/fotoxx-21.55.ebuild
new file mode 100644
index 000000000000..12a78336fe75
--- /dev/null
+++ b/media-gfx/fotoxx/fotoxx-21.55.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature xdg-utils
+
+DESCRIPTION="Program for improving image files made with a digital camera"
+HOMEPAGE="https://kornelix.net/fotoxx/fotoxx.html"
+SRC_URI="https://kornelix.net/downloads/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+# For required dependencies read doc/README, for required tools read
+# data/userguide [INSTALLATION]. xdg-open (x11-misc/xdg-utils) is an
+# alternative to firefox and chromium-browser. `grep '"which ' * -R`
+# is helpful to report some required tools run via the shell.
+
+DEPEND="
+ media-libs/clutter
+ media-libs/clutter-gtk
+ media-libs/lcms:2
+ media-libs/libpng:0
+ media-libs/tiff:0
+ media-libs/libchamplain[gtk]
+ virtual/jpeg
+ x11-libs/gtk+:3"
+RDEPEND="
+ ${DEPEND}
+ media-gfx/dcraw
+ media-libs/exiftool
+ x11-misc/xdg-utils
+"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}/${PN}-21.40-documentation.patch" )
+
+DOCS=()
+HTML_DOCS=()
+
+src_prepare() {
+ sed -i -e "/^DOCDIR/ s/${PN}$/${PF}/" Makefile || die
+ default
+}
+
+src_install() {
+ # For the Help menu items to work, *.html must be in /usr/share/doc/${PF},
+ # and README, changelog, copyright, license, etc. must not be compressed.
+ emake DESTDIR="${D}" install
+ rm -f "${D}"/usr/share/doc/${PF}/*.man || die
+ docompress -x /usr/share/doc
+}
+
+pkg_postinst() {
+ optfeature "HEIC file support" media-libs/libheif
+ optfeature "additional RAW file support" media-gfx/rawtherapee
+ optfeature "additional RAW file support" media-gfx/darktable
+ optfeature "video thumbnails & playback" media-video/ffmpeg
+ optfeature "copying images to optical media" app-cdr/dvd+rw-tools
+ optfeature "additional panorama support" media-gfx/hugin
+ optfeature "WEBP file support" media-libs/libwebp
+
+ elog
+ elog "Please read the Help > User Guide for details. The source location is"
+ elog "/usr/share/fotoxx/data/userguide and after running fotoxx a copy will"
+ elog "be placed at /home/<user>/.fotoxx/userguide."
+ elog
+ elog "To play videos, in Tools > Preferences set 'Video File Play Command'."
+ elog
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}