summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-09 05:41:48 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-09 06:58:46 +0100
commit6377a98b7b753b44c360e8717bcf49bb585b14d7 (patch)
tree20694759b3bd307cc2b2d5db9683c638352ea994
parentdev-python/botocore: Bump to 1.29.87 (diff)
downloadgentoo-6377a98b7b753b44c360e8717bcf49bb585b14d7.tar.gz
gentoo-6377a98b7b753b44c360e8717bcf49bb585b14d7.tar.bz2
gentoo-6377a98b7b753b44c360e8717bcf49bb585b14d7.zip
dev-python/boto3: Bump to 1.26.87
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.87.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 232d5f27d5a4..776bc969456d 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.26.79.gh.tar.gz 605312 BLAKE2B c36b86ab289be9c08a1ab43274a4f4db71ce
DIST boto3-1.26.84.gh.tar.gz 612921 BLAKE2B cf98272681299aa11454d65a6bf8bc6aa28244803e3d448f01425e62bb5dc01d93e0790ecaf6b2949ea1978130782f5ac282766c8fea94682e33b0cec65e2148 SHA512 d72117cb2f258fccf4a25e201a2dad8e13e8a80a03859edec2f27da01209185cbbb2f02a7924819214a612c6f6d3758ba0aba0047fab1cced3312d1662a7482b
DIST boto3-1.26.85.gh.tar.gz 613010 BLAKE2B 724ebf1264717652b2d671f96f34b546b1cc5663844454bd3925c985f4624e21370d90b4408f7d0ea7de151f8e9e6bdf11089db1836cf46eacc1d7fc671ff342 SHA512 d4ae39fd0be03ebe73d0ce7ab1467c93997c5d11b4409e6832ca40e292f7a0c7151519c3784d634157534546b84e208c529b785e4bce35c09bcbb2bb4aa76389
DIST boto3-1.26.86.gh.tar.gz 613310 BLAKE2B 4b16a9d637af664331a1197324219e9e58ba3569636f1707f907f44ffca284948daa2c702cc95a6fc85bc2ccb00d12bd80ffd79eb562325a709c87d9d3181880 SHA512 1a6bb7b7d3e14611099e938def383c7444801702a401003a91f47dc95656c0fb22450d670b908902b85d6caa0f20c6572f891364b20a98ef0669fdb7cdcfeb62
+DIST boto3-1.26.87.gh.tar.gz 614323 BLAKE2B b2dab2b5850777e493d7b4df7bda8cce8bb4f3b316f9551489a1942caaa0deca915cf50e4dd3e910a4ceff0d0a49ec2539dfc8bdf955745a4d5b8018453f8280 SHA512 0577e56f4cef0386e113e0ee67796ddbd8084fdb1e2b4229525f7818a8d89f1177c875b0b80f9d3334fc774fd151805f673bc29211cf4ee6e08806a5917ec619
diff --git a/dev-python/boto3/boto3-1.26.87.ebuild b/dev-python/boto3/boto3-1.26.87.ebuild
new file mode 100644
index 000000000000..9523f65d5fb9
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.87.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}