summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-28 06:49:18 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-28 07:00:15 +0200
commit6378f9ea2767792799024ec4390aa9daea0cb2d8 (patch)
tree729bcf9b47dd91ae3b2cb6b841bf484f5f213ae7
parentdev-python/autopage: Bump to 0.5.1 (diff)
downloadgentoo-6378f9ea2767792799024ec4390aa9daea0cb2d8.tar.gz
gentoo-6378f9ea2767792799024ec4390aa9daea0cb2d8.tar.bz2
gentoo-6378f9ea2767792799024ec4390aa9daea0cb2d8.zip
net-misc/electrum: Bump to 4.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--net-misc/electrum/Manifest1
-rw-r--r--net-misc/electrum/electrum-4.2.2.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/net-misc/electrum/Manifest b/net-misc/electrum/Manifest
index 305abd47b912..656adb310ef9 100644
--- a/net-misc/electrum/Manifest
+++ b/net-misc/electrum/Manifest
@@ -1 +1,2 @@
DIST electrum-4.2.1.gh.tar.gz 5066728 BLAKE2B 66b1ef4ec21f74f2f5c25de97a31c2ec23f907526df2ac661fdcb563e1e857ca88f4f534f2373e809ba978c66b78af72260af27944ac7aa8a92e86531827fef6 SHA512 b32ee5f8779bdb9bcda6a163f3f0a4cd95e91efb37418734c9f08930221ad15e54868fca0d5d0fb1dd3b1fac91b8cdea6c6ec822d98ad6b3d6ee01c841972e88
+DIST electrum-4.2.2.gh.tar.gz 5071636 BLAKE2B a13ae03e513736e5f24ded46a9b6ce13312a7d9243082f1d5b1948e7519f40f1fab238ec73550f72607ff2463a54a31f47c6ab8e511efddfcec362d5e427c6c1 SHA512 ae39ca0b548f3e4c7454096a7a05f9400a738e3b1c217ae9d41bf6156f7d642d3f1911f97829bfadbf6fdb6873538f38525363d256b363dac41d378c6b41002d
diff --git a/net-misc/electrum/electrum-4.2.2.ebuild b/net-misc/electrum/electrum-4.2.2.ebuild
new file mode 100644
index 000000000000..24459edb0784
--- /dev/null
+++ b/net-misc/electrum/electrum-4.2.2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="ncurses?"
+
+inherit desktop distutils-r1 xdg-utils
+
+DESCRIPTION="User friendly Bitcoin client"
+HOMEPAGE="https://electrum.org/"
+SRC_URI="
+ https://github.com/spesmilo/electrum/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cli ncurses qrcode +qt5"
+REQUIRED_USE="|| ( cli ncurses qt5 )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libsecp256k1
+ >=dev-python/aiohttp-socks-0.3[${PYTHON_USEDEP}]
+ =dev-python/aiorpcX-0.22*[${PYTHON_USEDEP}]
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ dev-python/bitstring[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-2[${PYTHON_USEDEP}]
+ dev-python/pbkdf2[${PYTHON_USEDEP}]
+ dev-python/PySocks[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.12[${PYTHON_USEDEP}]
+ qrcode? ( media-gfx/zbar[v4l] )
+ qt5? (
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+ )
+ ncurses? ( $(python_gen_impl_dep 'ncurses') )
+"
+BDEPEND="
+ test? (
+ dev-python/pyaes[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ eapply "${FILESDIR}/3.1.2-no-user-root.patch"
+
+ # Prevent data files from being installed in the wrong location
+ sed -i -e '/icons_dirname/d' -e '/applications/d' setup.py || die
+
+ # use backwards-compatible cryptodome API
+ sed -i -e 's:Cryptodome:Crypto:' electrum/crypto.py || die
+
+ # make qdarkstyle dep optional
+ sed -i -e '/qdarkstyle/d' contrib/requirements/requirements.txt || die
+
+ local bestgui
+ if use qt5; then
+ bestgui=qt
+ elif use ncurses; then
+ bestgui=text
+ else
+ bestgui=stdio
+ fi
+ sed -i 's/^\([[:space:]]*\)\(config_options\['\''cwd'\''\] = .*\)$/\1\2\n\1config_options.setdefault("gui", "'"${bestgui}"'")\n/' ${PN}/${PN} || die
+
+ eapply_user
+
+ xdg_environment_reset
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ doicon -s 128 electrum/gui/icons/${PN}.png
+ domenu electrum.desktop
+ dodoc RELEASE-NOTES
+ distutils-r1_src_install
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}