summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-07 06:42:57 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-07 06:42:57 +0200
commit637e284c75735e485555554709e3c7033d376d5b (patch)
treebd2ec8f5bac4f11cf70370ba83e642cd8876584b
parentdev-python/trimesh: Remove old (diff)
downloadgentoo-637e284c75735e485555554709e3c7033d376d5b.tar.gz
gentoo-637e284c75735e485555554709e3c7033d376d5b.tar.bz2
gentoo-637e284c75735e485555554709e3c7033d376d5b.zip
dev-python/sabyenc: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sabyenc/Manifest1
-rw-r--r--dev-python/sabyenc/files/sabyenc-4.0.2-fix-segfault.patch28
-rw-r--r--dev-python/sabyenc/sabyenc-4.0.2.ebuild28
3 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/sabyenc/Manifest b/dev-python/sabyenc/Manifest
index 26a0a7656ff2..c3cc9df57aff 100644
--- a/dev-python/sabyenc/Manifest
+++ b/dev-python/sabyenc/Manifest
@@ -1,2 +1 @@
-DIST sabyenc-4.0.2.tar.gz 19579235 BLAKE2B 26af61a979f94b954a6fb7fa425ca07a8d757fb16c9d434e9a1e0019d84d156b527e9309cc65113fef64dd3f2afb92b46619dc9506327273f2ba7822337e9ccf SHA512 88e8b47b1438ca55b51dbf8a407c33ec335f0604abf8a3dcbc45853b6dadadf9932d97cf3f0adabd71a9405e2deaeff2777483d9ea692c9d3cbab99dfbfbc901
DIST sabyenc-5.4.2.gh.tar.gz 19774424 BLAKE2B fbb954435236eb1794611a8e5852534b0f7dbd79806e8a9ca1bb57274df7cc89a6a26aa92c89c596e0c2857d4bfbd4e4c34f1d529cb5d2464a669d6d15a3f392 SHA512 a07a57e6b3416e147fcef4f27e52fea4b3a522ebb722b4d223469b63e9d08f42689950d86c544a41bfe81bba934514a43094c13b98aa585167cae69a5aa1f405
diff --git a/dev-python/sabyenc/files/sabyenc-4.0.2-fix-segfault.patch b/dev-python/sabyenc/files/sabyenc-4.0.2-fix-segfault.patch
deleted file mode 100644
index 1a80d5f13da8..000000000000
--- a/dev-python/sabyenc/files/sabyenc-4.0.2-fix-segfault.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From: Arthur Zamarin <arthurzam@gmail.com>
-Date: Sat, 18 Sep 2021 21:07:45 +0300
-Subject: Fix Segfault during testing
-
-decode_usenet_chunks might receive it argument as bytesarray, or
-as bytes object, but the C code expects only bytesarray.
-Add code, to apply variant for each case, and fail using assert when
-both don't apply.
-
-Signed-off-by: Arthur Zamarin <arthurzam@gmail.com>
-
---- a/src/sabyenc3.c
-+++ b/src/sabyenc3.c
-@@ -593,7 +593,13 @@ PyObject* decode_usenet_chunks(PyObject* self, PyObject* args) {
- num_bytes_reserved = 0;
- lp_max = (int)PyList_Size(Py_input_list);
- for(lp = 0; lp < lp_max; lp++) {
-- num_bytes_reserved += (int)PyByteArray_GET_SIZE(PyList_GetItem(Py_input_list, lp));
-+ PyObject *temp = PyList_GetItem(Py_input_list, lp);
-+ if (PyByteArray_Check(temp))
-+ num_bytes_reserved += (int)PyByteArray_GET_SIZE(temp);
-+ else if (PyBytes_Check(temp))
-+ num_bytes_reserved += (int)PyBytes_GET_SIZE(temp);
-+ else
-+ assert(PyByteArray_Check(temp) || PyBytes_Check(temp));
- }
- }
-
diff --git a/dev-python/sabyenc/sabyenc-4.0.2.ebuild b/dev-python/sabyenc/sabyenc-4.0.2.ebuild
deleted file mode 100644
index d9536017b50b..000000000000
--- a/dev-python/sabyenc/sabyenc-4.0.2.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Module providing raw yEnc encoding/decoding for SABnzbd"
-HOMEPAGE="https://github.com/sabnzbd/sabyenc"
-SRC_URI="https://github.com/sabnzbd/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-BDEPEND="test? (
- dev-python/chardet[${PYTHON_USEDEP}]
- )"
-
-DOCS=( CHANGES.md README.md doc/yenc-draft.1.3.txt )
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-segfault.patch"
-)
-
-distutils_enable_tests pytest