summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-11-01 13:44:18 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-11-01 13:53:54 +0100
commit63c34af6e95e4ca1b7ea4245cc6935e6c0e7989f (patch)
treef8946cf8610f6fd36a9f4f460341dbdf160c415c
parentdev-ros/test_rosparam: Bump to 1.12.6. (diff)
downloadgentoo-63c34af6e95e4ca1b7ea4245cc6935e6c0e7989f.tar.gz
gentoo-63c34af6e95e4ca1b7ea4245cc6935e6c0e7989f.tar.bz2
gentoo-63c34af6e95e4ca1b7ea4245cc6935e6c0e7989f.zip
dev-ros/test_rospy: Bump to 1.12.6.
Package-Manager: portage-2.3.2
-rw-r--r--dev-ros/test_rospy/Manifest1
-rw-r--r--dev-ros/test_rospy/test_rospy-1.12.6.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ros/test_rospy/Manifest b/dev-ros/test_rospy/Manifest
index eb7e799264b2..8da7b7792430 100644
--- a/dev-ros/test_rospy/Manifest
+++ b/dev-ros/test_rospy/Manifest
@@ -7,3 +7,4 @@ DIST ros_comm-1.12.1.tar.gz 954159 SHA256 cc9fddd81b01808f8b95505b3bb16cd2e212de
DIST ros_comm-1.12.2.tar.gz 956358 SHA256 693f5ed4fbaf537f104f7d279e267af5046b017126e6e2dd3ecb999192af80a7 SHA512 37489f4378386318284295f9ada52c04268ae1879b0c9f0ac5401efa0cb14e4f430aa205d7a3f0975626de8a7441d24f68c981c21693a493f8fd71d75bfe09e6 WHIRLPOOL eec6b6954617b85146f5b2dd6ba60e8df13c5843f3ef34615a96324fdc4f13e181551cde10af69a7a45d81e68e73f3cc9c72a6ffac323d8c36153af789652b5d
DIST ros_comm-1.12.4.tar.gz 966122 SHA256 b166141f7243d81abf1692a08d7f28a061cb9b74692b93eb0282ade45ed02717 SHA512 0f8f8b4c21e5cba1a2d86f829839242eb5db53eb41631d2a4a1ce6a95231f5c3e06bc0c6a375821228febd55af13ee7e9dc13165b350f2ba81b631cc25043f42 WHIRLPOOL 1a6f4570b1d96a94f9d01edabe6a1cc00ce7b83e6bce662e1ff13774c872e3d2755b544fa612f5347d065c2d199eb8ff818001b3c507de60dbd4099f430ed747
DIST ros_comm-1.12.5.tar.gz 966478 SHA256 a53039f5106133b67689ba579e29c9045e3b1468713019cf72b848ce979b6964 SHA512 0d97eac0b0cf200a1e217597176d55c82249e2e7b9f3c4706dce84068a65c6642e099fb16c69d33b62d6c780d2c2775b7330fb497bc936f9d4bc73a2b5ba12ca WHIRLPOOL 3f1c8239ef146a0915b8f2c183c68eda094f480fa099846c6b152325bd1e8574114ecbb4a5bcd609bf1323f29767dc8110e175c79b07183cc8ff9e51f9a62b19
+DIST ros_comm-1.12.6.tar.gz 967763 SHA256 8585d952b1168d2011949b38c68160180b1f3ee1648a506bcb5989f9807335ca SHA512 1987c6362ae0c7c019a226223c73a7aefdc14a3fc66469ab6cdf9c41e9efdf4d7b7d4932af2a52f2082d716342a307b2e415c0ab45f77dfd9a7c1e4274deab5c WHIRLPOOL a719bb81da6b1b7e2f253d3bf6c8db8339333b4fa7f89a18d0fa734e9ff1700e1dac7b537f154015b4ada7455a6673c1715a89e2fdd3da9bbbb70081fc2943cd
diff --git a/dev-ros/test_rospy/test_rospy-1.12.6.ebuild b/dev-ros/test_rospy/test_rospy-1.12.6.ebuild
new file mode 100644
index 000000000000..48cb395c90ff
--- /dev/null
+++ b/dev-ros/test_rospy/test_rospy-1.12.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/test_rosmaster"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/test_rosmaster[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-ros/rosbuild
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"