summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2022-05-16 05:18:28 -0400
committerMike Pagano <mpagano@gentoo.org>2022-05-16 05:18:28 -0400
commit64004e95748d89a05d6189548735c1e4e1d32ff2 (patch)
tree31f3c0c2f1a90e56b0a9738c114609c19ba9ffa1
parentpackage.mask: Last rite dev-python/typish (diff)
downloadgentoo-64004e95748d89a05d6189548735c1e4e1d32ff2.tar.gz
gentoo-64004e95748d89a05d6189548735c1e4e1d32ff2.tar.bz2
gentoo-64004e95748d89a05d6189548735c1e4e1d32ff2.zip
sys-kernel/git-sources: add 5.18_rc7
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.18_rc7.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index d695e964c372..a951a563571e 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -5,3 +5,4 @@ DIST patch-5.18-rc3.patch 113219039 BLAKE2B 53b7e45c5d9b87286509f727e6edc3f455d2
DIST patch-5.18-rc4.patch 113439466 BLAKE2B e1c09d06a721c5bf34d3ed5d2b760032947a39d8bd09aaba99c1cd1fe21f40bd720cf5613672f35ee8890358ea5bd317b699bcf20348fe11666bf91fd2d73138 SHA512 c3ae845310be78d63a09983ce5815d41d2e18ad8be87e21048a28549bde8bc61fef268b00e35da645be633a3aba825491406944b1e0a1ff33ebb79adc5cbda9e
DIST patch-5.18-rc5.patch 113766752 BLAKE2B f0a10b3b14c7ec52ee330679dcea0f0a452226f3f6524177ae73f9a3e248380848cc0f0b9324a0b1b8705c02c087e8650376adf4f6f4459071e967d478789646 SHA512 e53d0d0346300d2ae3db66314464a52afcf1da5eb19a5236872f5dc226782e4005b879d28971ff308e6ba6833111fd2bd575cd443f1b5ad85b54d95897810ef4
DIST patch-5.18-rc6.patch 113973406 BLAKE2B b98869d18829ae1d7e6a2240727623469cb25abe50923e1e5df77134ff1e2496fb4f945b13f1c7dc14687253249d50c298f72cfe371b737f11b097c91b1e88ac SHA512 f375221195d68d57541892ca27316bf80aed6b6a2cf8d23df71bd772b774e550bbc4e0800f0b6cdaa691af2f9aebc63b5907cc065913a03838a5dc7837fa1755
+DIST patch-5.18-rc7.patch 114117540 BLAKE2B 1985a6db4b5622a1baa27d60f0072046613685a7bcbd30d7fc3449901c6b0b835f0f61104cfdc22cdbb50f1c5207b0cd2c7d0da9ee36a4b2fb1a8a42839fc66f SHA512 58f3c0fdcb91a1edb71d2312afc77572c4dc0803a74b3d6d8d43f34399bd0174d546ae987c2b562a92d9e9f79e07ccf57204df8b3189fc721ac7ace034e35c7a
diff --git a/sys-kernel/git-sources/git-sources-5.18_rc7.ebuild b/sys-kernel/git-sources/git-sources-5.18_rc7.ebuild
new file mode 100644
index 000000000000..1b58d3fd64da
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.18_rc7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.17"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}