summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2022-11-05 04:26:00 +0100
committerLouis Sautier <sbraz@gentoo.org>2022-11-05 05:30:28 +0100
commit640f8e674a25c16d37f95ba1b647628615847f5f (patch)
tree627a26a1fbd345c6246e460c6387933c97c7cbec
parentdev-libs/libgrapheme: drop 2.0.1 (diff)
downloadgentoo-640f8e674a25c16d37f95ba1b647628615847f5f.tar.gz
gentoo-640f8e674a25c16d37f95ba1b647628615847f5f.tar.bz2
gentoo-640f8e674a25c16d37f95ba1b647628615847f5f.zip
app-arch/cfv: resurrect package, version 3.0.0
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--app-arch/cfv/Manifest1
-rw-r--r--app-arch/cfv/cfv-3.0.0.ebuild48
-rw-r--r--app-arch/cfv/metadata.xml20
3 files changed, 69 insertions, 0 deletions
diff --git a/app-arch/cfv/Manifest b/app-arch/cfv/Manifest
new file mode 100644
index 000000000000..db038dfc39a1
--- /dev/null
+++ b/app-arch/cfv/Manifest
@@ -0,0 +1 @@
+DIST cfv-3.0.0.gh.tar.gz 91600 BLAKE2B 5a0d53a2b75973967ef976ce55d5262f71af97a8d7c64e8ea94ed9d66fd12778e10321e82bdbc4b8037df3f1a9c9c817694a7cd5e60615fc903127df9057b04f SHA512 9a44bf20f0a4f48a93631353d0b0ab79ea15d19f1da5492296dd4bd4e6208d3f0d71e957165e31d07b5faa7fc75122f0ae5ddbd8d54b9c6b633c43695b362640
diff --git a/app-arch/cfv/cfv-3.0.0.ebuild b/app-arch/cfv/cfv-3.0.0.ebuild
new file mode 100644
index 000000000000..5b940295d074
--- /dev/null
+++ b/app-arch/cfv/cfv-3.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+# Tests fail with pypy3 as of PyPy 7.3.9 / Python 3.9.12
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Command-line File Verify - versatile file checksum creator and verifier"
+HOMEPAGE="https://github.com/cfv-project/cfv/"
+# Tests aren't included in PyPI tarballs
+SRC_URI="https://github.com/cfv-project/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ app-arch/cksfv
+ )
+"
+
+python_prepare_all() {
+ # Remove upstream's attempt to install the man page
+ sed -i '/\sdata_files=/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # In order to run integration tests in addition to unit tests, we can't
+ # just rely on pytest here, we need to use upstream's runner.
+ "${EPYTHON}" "test/test.py" || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman cfv.1
+}
+
+pkg_postinst() {
+ optfeature "the dimension column of JPEG Sheriff crc files" dev-python/pillow
+}
diff --git a/app-arch/cfv/metadata.xml b/app-arch/cfv/metadata.xml
new file mode 100644
index 000000000000..373591c9c7a7
--- /dev/null
+++ b/app-arch/cfv/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sbraz@gentoo.org</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <longdescription>
+ cfv is a utility to test and create a wide range of checksum
+ verification files. It currently supports testing and creating sfv,
+ sfvmd5, csv, csv2, csv4, md5, bsdmd5, sha1, sha224, sha256, sha384,
+ sha512, torrent and crc files. Test-only support is available for par,
+ par2.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">cfv</remote-id>
+ <remote-id type="github">cfv-project/cfv</remote-id>
+ <bugs-to>https://github.com/cfv-project/cfv/issues</bugs-to>
+ </upstream>
+</pkgmetadata>