summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-04 14:23:33 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-04 15:12:07 +0100
commit641d681def59c7c34626f27f50418b04851ad14c (patch)
tree1fe22a7335c705252288e35a947d63894fc1bae8
parentdev-python/precis-i18n: Bump to 1.0.5 (diff)
downloadgentoo-641d681def59c7c34626f27f50418b04851ad14c.tar.gz
gentoo-641d681def59c7c34626f27f50418b04851ad14c.tar.bz2
gentoo-641d681def59c7c34626f27f50418b04851ad14c.zip
dev-python/simplejson: Bump to 3.18.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/simplejson/Manifest1
-rw-r--r--dev-python/simplejson/simplejson-3.18.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/simplejson/Manifest b/dev-python/simplejson/Manifest
index 6d9a5847a4b6..4d003c72bbc6 100644
--- a/dev-python/simplejson/Manifest
+++ b/dev-python/simplejson/Manifest
@@ -1 +1,2 @@
DIST simplejson-3.18.0.tar.gz 83533 BLAKE2B 83c6f7f3734507f5a96b51d52dd39b0bd8ff772d51ce1f12ff2ee68f83747f519f418f78247727af7c408da4e7818d1b0d1f7b54b7780e3bc427add1eeaebb06 SHA512 952177fc707e5b1fb6450093876f9a7af1026271cb792bb8dc0418b83906ae32e7f2251b96f531101197d0b3204a97124bff02f7abc4cf700da4edf1320b6b08
+DIST simplejson-3.18.1.tar.gz 83603 BLAKE2B 5f51d06238210b0bdd3dbb2338979023324e1056c2278f7eef7b929cc0bf9f9178d032829a3ce49c0b630f3367268d68753f250968962159e9a9aafcd3105d20 SHA512 3a18d02f42624e27c536582cf9b6ceb8559d54dd97224294a6f6ee8173ee37c0cc9cd21bad777c29ab432ac41b1495fca9d45da300b5040c175980d236d3b9d6
diff --git a/dev-python/simplejson/simplejson-3.18.1.ebuild b/dev-python/simplejson/simplejson-3.18.1.ebuild
new file mode 100644
index 000000000000..b36a545149a5
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.18.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="
+ https://github.com/simplejson/simplejson/
+ https://pypi.org/project/simplejson/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+DOCS=( README.rst CHANGES.txt )
+
+distutils_enable_tests unittest