summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-08-19 19:09:28 +0200
committerJeroen Roovers <jer@gentoo.org>2020-08-19 21:43:51 +0200
commit645166282e80e07f35f00b5cc6262343a672669f (patch)
tree154273a404c037b7ea6fdbc025ceb2e4216f7730
parentnet-libs/gsoap: fix DoubleEmptyLine (diff)
downloadgentoo-645166282e80e07f35f00b5cc6262343a672669f.tar.gz
gentoo-645166282e80e07f35f00b5cc6262343a672669f.tar.bz2
gentoo-645166282e80e07f35f00b5cc6262343a672669f.zip
www-client/opera-beta: Version 71.0.3770.50
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--www-client/opera-beta/Manifest1
-rw-r--r--www-client/opera-beta/opera-beta-71.0.3770.50.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/www-client/opera-beta/Manifest b/www-client/opera-beta/Manifest
index 1bbee3553f9c..11eefcd93aaf 100644
--- a/www-client/opera-beta/Manifest
+++ b/www-client/opera-beta/Manifest
@@ -1 +1,2 @@
DIST opera-beta_70.0.3728.59_amd64.deb 67482688 BLAKE2B 3c4596f5315b5faa71fd25e62c92d75ca4fdb9a3593b9a6f10e043a0405b4a201c41f97c399e80cf157cb2b1e766ff0eea88d65f2f2a9b53f2ba17e436b22ef6 SHA512 923dbbb909a09aef85e16f387c7f0934cf52e5defa3bb22d22885bbba88a627561595339841b4af6e4678b0967fde8829f7894a922061edd58ae70f50661184b
+DIST opera-beta_71.0.3770.50_amd64.deb 68263536 BLAKE2B 0a48ff6994e6e7343c0e7fa67db6ab149e521390d598d1c1b464ed8d16e12e1c368920929c93ee53128d871a95021ab4f51441723e3be7fafef4ab20d0258f6d SHA512 68b3d636bc70cd41b97d7b57297f553886a06c1f48b950f81f5c672f6c29290a141784a44c599bd7d564845ae838dffa402a096a87c509f4b6d31a8bf499ac2d
diff --git a/www-client/opera-beta/opera-beta-71.0.3770.50.ebuild b/www-client/opera-beta/opera-beta-71.0.3770.50.ebuild
new file mode 100644
index 000000000000..99905f624666
--- /dev/null
+++ b/www-client/opera-beta/opera-beta-71.0.3770.50.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+CHROMIUM_LANGS="
+ be bg bn ca cs da de el en-GB es es-419 fi fil fr fr-CA hi hr hu id it
+ ja ko lt lv ms nb nl pl pt-BR pt-PT ro ru sk sr sv sw ta te th tr uk vi
+ zh-CN zh-TW
+"
+inherit chromium-2 multilib unpacker xdg-utils
+
+DESCRIPTION="A fast and secure web browser"
+HOMEPAGE="https://www.opera.com/"
+LICENSE="OPERA-2014"
+SLOT="0"
+SRC_URI_BASE="
+ https://download1.operacdn.com/pub/
+ https://download2.operacdn.com/pub/
+ https://download3.operacdn.com/pub/
+ https://download4.operacdn.com/pub/
+"
+SRC_URI="amd64? ("
+for uri in ${SRC_URI_BASE}; do
+SRC_URI+="
+ "${uri}${PN}/${PV}/linux/${PN}_${PV}_amd64.deb"
+"
+done
+SRC_URI+=")"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ gnome-base/gconf:2
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/freetype
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libnotify
+ x11-libs/pango[X]
+"
+
+QA_PREBUILT="*"
+S=${WORKDIR}
+
+pkg_setup() {
+ OPERA_HOME="usr/$(get_libdir)/${PN}"
+}
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_prepare() {
+ default
+
+ case ${ARCH} in
+ amd64)
+ mv usr/lib/x86_64-linux-gnu usr/$(get_libdir) || die
+ rm -r usr/lib || die
+ ;;
+ x86)
+ mv usr/lib/i386-linux-gnu/${PN} usr/$(get_libdir)/ || die
+ ;;
+ esac
+
+ mv usr/share/doc/${PN} usr/share/doc/${PF} || die
+ gunzip usr/share/doc/${PF}/changelog.gz || die
+
+ rm usr/bin/${PN} || die
+
+ pushd "${OPERA_HOME}/localization" > /dev/null || die
+ chromium_remove_language_paks
+ popd > /dev/null || die
+
+ sed -i \
+ -e 's|^TargetEnvironment|X-&|g' \
+ usr/share/applications/${PN}.desktop || die
+}
+
+src_install() {
+ mv * "${D}" || die
+ dosym ../$(get_libdir)/${PN}/${PN} /usr/bin/${PN}
+ fperms 4711 /usr/$(get_libdir)/${PN}/opera_sandbox
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}