summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-06-21 18:05:16 +0200
committerMichał Górny <mgorny@gentoo.org>2016-06-21 19:20:38 +0200
commit6521d68830165d2a140ef661be83d40319de0c39 (patch)
tree40fea9b91a7de01d202e631f6cfd803c0fc86bdd
parentsys-apps/checkpolicy: stable userspace 2.5 (diff)
downloadgentoo-6521d68830165d2a140ef661be83d40319de0c39.tar.gz
gentoo-6521d68830165d2a140ef661be83d40319de0c39.tar.bz2
gentoo-6521d68830165d2a140ef661be83d40319de0c39.zip
toolchain.eclass: [QA] Remove meaningless USE=multislot, #584610
The USE=multislot as defined partially by toolchain.eclass and partially by sys-devel/gcc was used for two purposes: - enabling build-time (only) blockers on old gcc versions -- which do not make any sense because they are build-time only and there is no technical reason for two gcc version ranges not to be installed at the same time, both at build time and at run time, - changing behavior of post-install wrt conditional gcc-config calls. Both cases are invalid use of USE flags, considering that the flag does not affect the installed files in any way.
-rw-r--r--eclass/toolchain.eclass6
-rw-r--r--sys-devel/gcc-apple/metadata.xml1
-rw-r--r--sys-devel/gcc/gcc-4.9.3.ebuild1
-rw-r--r--sys-devel/gcc/gcc-5.3.0.ebuild1
-rw-r--r--sys-devel/gcc/gcc-5.4.0.ebuild1
-rw-r--r--sys-devel/gcc/metadata.xml1
-rw-r--r--sys-devel/kgcc64/metadata.xml1
7 files changed, 1 insertions, 11 deletions
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index 9dd1604e9638..5dff279503c1 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -131,7 +131,7 @@ else
LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
fi
-IUSE="multislot regression-test vanilla"
+IUSE="regression-test vanilla"
IUSE_DEF=( nls nptl )
if [[ ${PN} != "kgcc64" && ${PN} != gcc-* ]] ; then
@@ -2142,10 +2142,6 @@ should_we_gcc_config() {
local curr_branch_ver=$(get_version_component_range 1-2 ${curr_config_ver})
- # If we're using multislot, just run gcc-config if we're installing
- # to the same profile as the current one.
- use multislot && return $([[ ${curr_config_ver} == ${GCC_CONFIG_VER} ]])
-
if [[ ${curr_branch_ver} == ${GCC_BRANCH_VER} ]] ; then
return 0
else
diff --git a/sys-devel/gcc-apple/metadata.xml b/sys-devel/gcc-apple/metadata.xml
index 6f00f68c384e..eb4d397c67f0 100644
--- a/sys-devel/gcc-apple/metadata.xml
+++ b/sys-devel/gcc-apple/metadata.xml
@@ -6,7 +6,6 @@
<name>Gentoo Prefix</name>
</maintainer>
<use>
- <flag name="multislot">Allow for multiple versions to be emerged at once for same CTARGET</flag>
<flag name="objc">Build support for the Objective C code language</flag>
<flag name="objc++">Build support for the Objective C++ language</flag>
<flag name="regression-test">Run the testsuite and install the results (requires FEATURES=test)</flag>
diff --git a/sys-devel/gcc/gcc-4.9.3.ebuild b/sys-devel/gcc/gcc-4.9.3.ebuild
index a66d2d6ea6a4..85dbc89097c2 100644
--- a/sys-devel/gcc/gcc-4.9.3.ebuild
+++ b/sys-devel/gcc/gcc-4.9.3.ebuild
@@ -27,7 +27,6 @@ KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86
RDEPEND=""
DEPEND="${RDEPEND}
elibc_glibc? ( >=sys-libs/glibc-2.8 )
- !multislot? ( !<${CATEGORY}/gcc-4.9 )
>=${CATEGORY}/binutils-2.20"
if [[ ${CATEGORY} != cross-* ]] ; then
diff --git a/sys-devel/gcc/gcc-5.3.0.ebuild b/sys-devel/gcc/gcc-5.3.0.ebuild
index 48a7567638b0..1730b19efefd 100644
--- a/sys-devel/gcc/gcc-5.3.0.ebuild
+++ b/sys-devel/gcc/gcc-5.3.0.ebuild
@@ -27,7 +27,6 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~s
RDEPEND=""
DEPEND="${RDEPEND}
elibc_glibc? ( >=sys-libs/glibc-2.8 )
- !multislot? ( !<${CATEGORY}/gcc-4.9 )
>=${CATEGORY}/binutils-2.20"
if [[ ${CATEGORY} != cross-* ]] ; then
diff --git a/sys-devel/gcc/gcc-5.4.0.ebuild b/sys-devel/gcc/gcc-5.4.0.ebuild
index 243a370902f8..d40ef5466aaf 100644
--- a/sys-devel/gcc/gcc-5.4.0.ebuild
+++ b/sys-devel/gcc/gcc-5.4.0.ebuild
@@ -27,7 +27,6 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~s
RDEPEND=""
DEPEND="${RDEPEND}
elibc_glibc? ( >=sys-libs/glibc-2.8 )
- !multislot? ( !<${CATEGORY}/gcc-4.9 )
>=${CATEGORY}/binutils-2.20"
if [[ ${CATEGORY} != cross-* ]] ; then
diff --git a/sys-devel/gcc/metadata.xml b/sys-devel/gcc/metadata.xml
index 7b6c493e9e5d..38f4396bcaaa 100644
--- a/sys-devel/gcc/metadata.xml
+++ b/sys-devel/gcc/metadata.xml
@@ -21,7 +21,6 @@
code in the C library (DO NOT ENABLE THIS IF YOU DON'T KNOW WHAT IT DOES)</flag>
<flag name="mpx">Enable support for Intel Memory Protection Extensions (MPX)</flag>
<flag name="mudflap">Add support for mudflap, a pointer use checking library</flag>
- <flag name="multislot">Allow for multiple versions to be emerged at once for same CTARGET</flag>
<flag name="nopie">Disable PIE support (NOT FOR GENERAL USE)</flag>
<flag name="nossp">Disable SSP support (NOT FOR GENERAL USE)</flag>
<flag name="objc">Build support for the Objective C code language</flag>
diff --git a/sys-devel/kgcc64/metadata.xml b/sys-devel/kgcc64/metadata.xml
index 817d146fe23a..2753a6abd172 100644
--- a/sys-devel/kgcc64/metadata.xml
+++ b/sys-devel/kgcc64/metadata.xml
@@ -6,7 +6,6 @@
<name>Gentoo Toolchain Project</name>
</maintainer>
<use>
-<flag name="multislot">Allow for multiple versions to be emerged at once for same CTARGET</flag>
<flag name="regression-test">Run the testsuite and install the results (requires FEATURES=test)</flag>
</use>
</pkgmetadata>