summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-09-17 16:56:45 -0700
committerZac Medico <zmedico@gentoo.org>2019-09-17 16:56:45 -0700
commit6554a30e6a47756812ab17110bf2a66be55edbe7 (patch)
tree4be6d4572dba192e5eb5c5dc90cf1d7989576fc5
parentapp-admin/mtail: LICENSE: account for vendored software (diff)
downloadgentoo-6554a30e6a47756812ab17110bf2a66be55edbe7.tar.gz
gentoo-6554a30e6a47756812ab17110bf2a66be55edbe7.tar.bz2
gentoo-6554a30e6a47756812ab17110bf2a66be55edbe7.zip
app-benchmarks/hey: Fix compile with go-1.13
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--app-benchmarks/hey/hey-0.1.1_p20181017.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/app-benchmarks/hey/hey-0.1.1_p20181017.ebuild b/app-benchmarks/hey/hey-0.1.1_p20181017.ebuild
index 0be025d4eb3e..1b73bfe82c49 100644
--- a/app-benchmarks/hey/hey-0.1.1_p20181017.ebuild
+++ b/app-benchmarks/hey/hey-0.1.1_p20181017.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -22,8 +22,8 @@ RDEPEND=""
S=${WORKDIR}/${P}/src/${EGO_SRC}
src_compile() {
- GOPATH="${WORKDIR}/${P}" GOBIN="${WORKDIR}/${P}/bin" \
- go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}" || die
+ GOPATH="${WORKDIR}/${P}" GOBIN="${WORKDIR}/${P}/bin" GO111MODULE=on \
+ go install -mod=vendor -v -x ${EGO_BUILD_FLAGS} "${EGO_PN}" || die
}
src_install() {