summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-28 17:05:50 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-28 17:13:13 +0200
commit658c32c00bfdd6b9b3a4f22735923188584312f2 (patch)
treed4281f2e4b61d1749780da7a1574207860060d47
parentapp-emacs/with-editor: drop old 3.0.5 (diff)
downloadgentoo-658c32c00bfdd6b9b3a4f22735923188584312f2.tar.gz
gentoo-658c32c00bfdd6b9b3a4f22735923188584312f2.tar.bz2
gentoo-658c32c00bfdd6b9b3a4f22735923188584312f2.zip
app-emacs/with-editor: add live version
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/with-editor/with-editor-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-emacs/with-editor/with-editor-9999.ebuild b/app-emacs/with-editor/with-editor-9999.ebuild
new file mode 100644
index 000000000000..d949e77a6c7f
--- /dev/null
+++ b/app-emacs/with-editor/with-editor-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Use the Emacsclient as the \$EDITOR of child processes"
+HOMEPAGE="https://magit.vc/manual/with-editor/
+ https://github.com/magit/with-editor/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+S="${WORKDIR}"/${P}/lisp
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.1
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+DOCS=( ../README.org ../docs/${PN}.org )
+ELISP_TEXINFO="../docs/*.texi"
+SITEFILE="50${PN}-gentoo.el"