summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-14 19:57:20 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-14 20:00:19 +0100
commit6703c6a7ca6d3882192ca32a826f219f2bdd7e03 (patch)
tree29a75db57efb6ae861681cca7779ef4e04d9ae31
parentsys-apps/gptfdisk: Revbump to fix spurious MBR warnings (diff)
downloadgentoo-6703c6a7ca6d3882192ca32a826f219f2bdd7e03.tar.gz
gentoo-6703c6a7ca6d3882192ca32a826f219f2bdd7e03.tar.bz2
gentoo-6703c6a7ca6d3882192ca32a826f219f2bdd7e03.zip
xfce-extra/xfce4-cpugraph-plugin: Bump to 1.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cpugraph-plugin/Manifest b/xfce-extra/xfce4-cpugraph-plugin/Manifest
index 5feae79d1e74..9b96be8d1b99 100644
--- a/xfce-extra/xfce4-cpugraph-plugin/Manifest
+++ b/xfce-extra/xfce4-cpugraph-plugin/Manifest
@@ -1,3 +1,4 @@
DIST xfce4-cpugraph-plugin-1.1.0.tar.bz2 391629 BLAKE2B e1a18df75461466abf908100e3ace73c46751d78527a9928a5712e3b3388cb0908b697055bd229f700f3e36e908cbc90f2732fc65568ebbe47d876aa376fd087 SHA512 c928baac776517da8929b8ce3842be7e02a2b3394b7cc848028d1720ca611e1aa4ef706bd00736fecfed0b3b2d0cce94c09b0f905a226db5e50c036dabb8df2a
DIST xfce4-cpugraph-plugin-1.2.0.tar.bz2 416669 BLAKE2B 1adc1ac15b5280cb20dbc9e346ac99692fa5ce345431ffadad0e202cbad462d8210433b03d58f6970c493987a69866e97287b4a4ce655afe3d867258c8f8c14d SHA512 b7d8402646bb4bca82c767b2a4e25a96d6d9a0327f13b934afd2165e9884a134686cf18e43c6fb30f93f9aba5f41aeceb0cbfb49c15f165ce972ed82eb9eb563
DIST xfce4-cpugraph-plugin-1.2.1.tar.bz2 424101 BLAKE2B 228277cccbe89ac43b78d41de489f1b58e30cc8e6f900840bf0d3c41d3f392d10fcba43b64bb8edb4ecade363d63af2860f1174b5b1b944ac7dc261071397111 SHA512 ca8b7dc1ccad163e8bbe28723ded0c9cf5a1b72aa350e1d9c8e0b0654e97704f0ffba9a7128fc6da289dbea7b9668f1d493eca09e87abd0cdd109998a2749fe1
+DIST xfce4-cpugraph-plugin-1.2.2.tar.bz2 425245 BLAKE2B 1ca1bc0d210b607079ba4706db5c0bd58b3fae17d22f82722f55d685132bf4ea04ec28d148eafe1183cff517c7ea859032a92ed1e5a20c7bbaac77ba9249a4ed SHA512 18bdda603e657b87bf3c4bbf5785aaa5b735102dfde515f2850396b2501ba8d5305245b5b4cbf3157bde8178167499ba3def7535ba357750a311531b9c2072a9
diff --git a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.2.ebuild b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.2.ebuild
new file mode 100644
index 000000000000..45e92732fa92
--- /dev/null
+++ b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A system load plug-in for the Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}