summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-10 20:51:41 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-10 21:00:07 +0100
commit67458a2adffd6fc73f6f592c5909b15bc0b977ff (patch)
treea53e51661826cba7acf1c1dd0c100157fc5671b7
parentdev-ml/opam-state: Stabilize 2.0.9 arm, #817749 (diff)
downloadgentoo-67458a2adffd6fc73f6f592c5909b15bc0b977ff.tar.gz
gentoo-67458a2adffd6fc73f6f592c5909b15bc0b977ff.tar.bz2
gentoo-67458a2adffd6fc73f6f592c5909b15bc0b977ff.zip
dev-python/cfn-lint: Bump to 0.56.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.56.4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 3a1dee5ea7a5..08a30413f645 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1 +1,2 @@
DIST cfn-lint-0.56.3.tar.gz 8278034 BLAKE2B 894d30add7a193d256dc2195c0cd1d4b75f10f60abe9e37c5b0bdd84178d9559759326ad3e55d2321b99588094b436dc2dc8dff1cc561ae56dd4cee98d6b43bd SHA512 8aeaf44a626f9bfc05ebeefc8aec9211fcac1a65de681d5d700f3621631bff15e74ed644b9d0dc8af4d9b0b14802c2259dbc4ccf38594705040f5fd3af1cf482
+DIST cfn-lint-0.56.4.tar.gz 8550039 BLAKE2B 99efd99b423e068717f3050e4da444436463c16b0a55dfc36ca7ca45b1136d08bbce84441c8c4170eff7c82cbd4ecf87b6f78504b1d09d850d803a7e957903c9 SHA512 b7c94d85d58f9e44ff8d5575bb33c8c7fafcb908afe144d585765f02d645436d6583ecc802f0fa376597b75c72ada9a23862141cf1170c1ac1f64f2467d346fb
diff --git a/dev-python/cfn-lint/cfn-lint-0.56.4.ebuild b/dev-python/cfn-lint/cfn-lint-0.56.4.ebuild
new file mode 100644
index 000000000000..3a28103e724a
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.56.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="https://pypi.org/project/cfn-lint/ https://github.com/aws-cloudformation/cfn-lint/"
+SRC_URI="
+ https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.42.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.11[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_2
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}