summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 12:35:13 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commit675996b4703770742e27007fc1c7e247d6f6d048 (patch)
tree216cc6957c84d55c0e2354c5c8dd168530934704
parentdev-python/pyasn1: Add python3.5 support (diff)
downloadgentoo-675996b4703770742e27007fc1c7e247d6f6d048.tar.gz
gentoo-675996b4703770742e27007fc1c7e247d6f6d048.tar.bz2
gentoo-675996b4703770742e27007fc1c7e247d6f6d048.zip
dev-python/pyasn1-modules: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/pyasn1-modules/metadata.xml2
-rw-r--r--dev-python/pyasn1-modules/pyasn1-modules-0.0.8-r1.ebuild38
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/pyasn1-modules/metadata.xml b/dev-python/pyasn1-modules/metadata.xml
index f95ded46068f..a9d9baa85472 100644
--- a/dev-python/pyasn1-modules/metadata.xml
+++ b/dev-python/pyasn1-modules/metadata.xml
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>python</herd>
diff --git a/dev-python/pyasn1-modules/pyasn1-modules-0.0.8-r1.ebuild b/dev-python/pyasn1-modules/pyasn1-modules-0.0.8-r1.ebuild
new file mode 100644
index 000000000000..a34c654789e4
--- /dev/null
+++ b/dev-python/pyasn1-modules/pyasn1-modules-0.0.8-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="pyasn1 modules"
+HOMEPAGE="http://pyasn1.sourceforge.net/ https://pypi.python.org/pypi/pyasn1-modules"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ echoit() { echo "$@"; "$@"; }
+ local exit_status=0 test
+ for test in test/*.sh; do
+ PATH="${S}/tools:${PATH}" \
+ echoit sh "${test}" || exit_status=1
+ done
+ return ${exit_status}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ insinto /usr/share/${P}
+ doins -r tools
+}