summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Vasquez <fearedbliss@gentoo.org>2018-02-26 20:22:24 -0500
committerJonathan Vasquez <fearedbliss@gentoo.org>2018-02-26 20:22:24 -0500
commit67828fe1c9b5e418c6a6280dd36c2a85985301be (patch)
treebed4b142269259293ff4584ff1b2e3d0c2212e04
parentsys-kernel/bliss-initramfs: version bump to 7.1.3 (diff)
downloadgentoo-67828fe1.tar.gz
gentoo-67828fe1.tar.bz2
gentoo-67828fe1.zip
media-tv/plex-media-server: version bump to 1.11.3
Package-Manager: Portage-2.3.21, Repoman-2.3.6
-rw-r--r--media-tv/plex-media-server/Manifest1
-rw-r--r--media-tv/plex-media-server/plex-media-server-1.11.3.ebuild153
2 files changed, 154 insertions, 0 deletions
diff --git a/media-tv/plex-media-server/Manifest b/media-tv/plex-media-server/Manifest
index 3731189161f1..807cb4e4e31f 100644
--- a/media-tv/plex-media-server/Manifest
+++ b/media-tv/plex-media-server/Manifest
@@ -1 +1,2 @@
DIST plexmediaserver_1.10.1.4602-f54242b6b_amd64.deb 108445778 BLAKE2B 8c71bbc7a90d5465aa23b4ddaddbec8ccc81f7e5f09e2e3b98a878c5375158381c5fc20fd6542a3a9e642007ab06045eb3afe210ef5f16a5f60f1d3abd8c3fe7 SHA512 16f3f28e1ba409b141c8f2f7ecb912bcf47485e68d8e813c4908465407d8e6e3c455e6358538445e06b73380f82c46a5b29e6d02d4b4576407dc8d7bc0644b38
+DIST plexmediaserver_1.11.3.4803-c40bba82e_amd64.deb 108830880 BLAKE2B 7ed912756b8bdedb695c4cbf99d0565da53904814cedb8e026614b8db9bb638cbd437f35e05915d6d22221c87ecf1136ea9ae08797bca2ebbe4f2e0a861b4841 SHA512 0bda324e733b1e86e8dba7c10f6bab3e9dad5463113c5998059492bd7d4a49e105068d1d9313c9405d7a3c85c99e6528be6c0f1c9f52db115a1da1545a9485b5
diff --git a/media-tv/plex-media-server/plex-media-server-1.11.3.ebuild b/media-tv/plex-media-server/plex-media-server-1.11.3.ebuild
new file mode 100644
index 000000000000..b9c6e337a7b4
--- /dev/null
+++ b/media-tv/plex-media-server/plex-media-server-1.11.3.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils user systemd unpacker pax-utils python-single-r1
+
+MINOR_VERSION="4803-c40bba82e"
+
+_APPNAME="plexmediaserver"
+_USERNAME="plex"
+_SHORTNAME="${_USERNAME}"
+_FULL_VERSION="${PV}.${MINOR_VERSION}"
+
+URI="https://downloads.plex.tv/plex-media-server"
+
+DESCRIPTION="A free media library that is intended for use with a plex client."
+HOMEPAGE="http://www.plex.tv/"
+SRC_URI="amd64? ( ${URI}/${_FULL_VERSION}/plexmediaserver_${_FULL_VERSION}_amd64.deb )"
+SLOT="0"
+LICENSE="Plex"
+RESTRICT="bindist strip"
+KEYWORDS="-* ~amd64"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ sys-apps/fix-gnustack
+ dev-python/virtualenv[${PYTHON_USEDEP}]"
+
+RDEPEND="
+ net-dns/avahi
+ ${PYTHON_DEPS}"
+
+QA_DESKTOP_FILE="usr/share/applications/plexmediamanager.desktop"
+QA_PREBUILT="*"
+QA_MULTILIB_PATHS=(
+ "usr/lib/${_APPNAME}/.*"
+ "usr/lib/${_APPNAME}/Resources/Python/lib/python2.7/.*"
+)
+
+EXECSTACKED_BINS=( "${ED%/}/usr/lib/plexmediaserver/libgnsdk_dsp.so*" )
+BINS_TO_PAX_MARK=( "${ED%/}/usr/lib/plexmediaserver/Plex Script Host" )
+
+S="${WORKDIR}"
+PATCHES=( "${FILESDIR}/virtualenv_start_pms.patch" )
+
+pkg_setup() {
+ enewgroup ${_USERNAME}
+ enewuser ${_USERNAME} -1 /bin/bash /var/lib/${_APPNAME} "${_USERNAME},video"
+ python-single-r1_pkg_setup
+}
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_install() {
+ # Move the config to the correct place
+ local CONFIG_VANILLA="/etc/default/plexmediaserver"
+ local CONFIG_PATH="/etc/${_SHORTNAME}"
+ dodir "${CONFIG_PATH}"
+ insinto "${CONFIG_PATH}"
+ doins "${CONFIG_VANILLA#/}"
+ sed -e "s#${CONFIG_VANILLA}#${CONFIG_PATH}/${_APPNAME}#g" -i "${S}"/usr/sbin/start_pms || die
+
+ # Remove Debian specific files
+ rm -rf "usr/share/doc" || die
+
+ # Copy main files over to image and preserve permissions so it is portable
+ cp -rp usr/ "${ED}" || die
+
+ # Make sure the logging directory is created
+ local LOGGING_DIR="/var/log/pms"
+ dodir "${LOGGING_DIR}"
+ chown "${_USERNAME}":"${_USERNAME}" "${ED%/}/${LOGGING_DIR}" || die
+
+ # Create default library folder with correct permissions
+ local DEFAULT_LIBRARY_DIR="/var/lib/${_APPNAME}"
+ dodir "${DEFAULT_LIBRARY_DIR}"
+ chown "${_USERNAME}":"${_USERNAME}" "${ED%/}/${DEFAULT_LIBRARY_DIR}" || die
+
+ # Install the OpenRC init/conf files
+ doinitd "${FILESDIR}/init.d/${PN}"
+ doconfd "${FILESDIR}/conf.d/${PN}"
+
+ # Disabling due to Bug 644694
+ #_handle_multilib
+
+ # Mask Plex libraries so that revdep-rebuild doesn't try to rebuild them.
+ # Plex has its own precompiled libraries.
+ _mask_plex_libraries_revdep
+
+ # Install systemd service file
+ local INIT_NAME="${PN}.service"
+ local INIT="${FILESDIR}/systemd/${INIT_NAME}"
+ systemd_newunit "${INIT}" "${INIT_NAME}"
+
+ _remove_execstack_markings
+ _add_pax_markings
+
+ einfo "Configuring virtualenv"
+ virtualenv -v --no-pip --no-setuptools --no-wheel "${ED}"usr/lib/plexmediaserver/Resources/Python || die
+ pushd "${ED}"usr/lib/plexmediaserver/Resources/Python &>/dev/null || die
+ find . -type f -exec sed -i -e "s#${D}##g" {} + || die
+ popd &>/dev/null || die
+}
+
+pkg_postinst() {
+ einfo ""
+ elog "Plex Media Server is now installed. Please check the configuration file in /etc/${_SHORTNAME}/${_APPNAME} to verify the default settings."
+ elog "To start the Plex Server, run 'rc-config start plex-media-server', you will then be able to access your library at http://<ip>:32400/web/"
+}
+
+# Disabling the follow function due to Bug 644694.
+# We shouldn't register plex libraries in global
+# library path since this will cause other packages
+# on the system to break.
+
+# Finds out where the library directory is for this system
+# and handles ldflags as to not break library dependencies
+# during rebuilds.
+_handle_multilib() {
+ # Prevent revdep-rebuild, @preserved-rebuild breakage
+ cat > "${T}"/66plex <<-EOF || die
+ LDPATH="${EPREFIX}/usr/$(get_libdir)/plexmediaserver"
+ EOF
+
+ doenvd "${T}"/66plex
+}
+
+# Adds the precompiled plex libraries to the revdep-rebuild's mask list
+# so it doesn't try to rebuild libraries that can't be rebuilt.
+_mask_plex_libraries_revdep() {
+ dodir /etc/revdep-rebuild/
+ echo "SEARCH_DIRS_MASK=\"${EPREFIX}/usr/$(get_libdir)/plexmediaserver\"" > "${ED}"/etc/revdep-rebuild/80plexmediaserver
+}
+
+# Remove execstack flags from some libraries/executables
+# so that it works in hardened setups.
+_remove_execstack_markings() {
+ for f in "${EXECSTACKED_BINS[@]}"; do
+ # Unquoting 'f' so that expansion works.
+ fix-gnustack -f ${f} > /dev/null
+ done
+}
+
+# Add pax markings to some binaries so that they work on hardened setup.
+_add_pax_markings() {
+ for f in "${BINS_TO_PAX_MARK[@]}"; do
+ pax-mark m "${f}"
+ done
+}