summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-04 06:38:59 +0100
committerSam James <sam@gentoo.org>2022-10-04 08:09:23 +0100
commit6791747772fac59091dea9be75074c106c97ebeb (patch)
tree86d6319db22625368292b09349e581506f9b1e3a
parentnet-wireless/blueman: Require gtk+[X] (diff)
downloadgentoo-6791747772fac59091dea9be75074c106c97ebeb.tar.gz
gentoo-6791747772fac59091dea9be75074c106c97ebeb.tar.bz2
gentoo-6791747772fac59091dea9be75074c106c97ebeb.zip
dev-libs/pslib: add 0.4.6
Closes: https://bugs.gentoo.org/871300 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/pslib/Manifest1
-rw-r--r--dev-libs/pslib/files/pslib-0.4.6-Fix-implicit-function-declarations.patch29
-rw-r--r--dev-libs/pslib/pslib-0.4.6.ebuild54
3 files changed, 84 insertions, 0 deletions
diff --git a/dev-libs/pslib/Manifest b/dev-libs/pslib/Manifest
index 979f121724a2..b826a83df9ad 100644
--- a/dev-libs/pslib/Manifest
+++ b/dev-libs/pslib/Manifest
@@ -1 +1,2 @@
DIST pslib-0.4.5.tar.gz 493687 BLAKE2B cca0709bc3fa9f464166b02ca54d85056c510f677b478b4f187fba653b3a17af38c3c7ffbea23113d5ad3a146e881d183f138d836cd5f373a116e836ba8d4974 SHA512 410abfdca6c52f16c07b7d0157930fbb7a996f03bfb84aee2bc951b2d859bc2186d3ba742b724cd957b9b1c48201364fbeb11c15d7f4ead34f78b0d0746abc6f
+DIST pslib-0.4.6.tar.gz 543950 BLAKE2B 18f85ce5c2d558b2abe8c3297a65201890813d57d3e14353333c1e1b221ee89e0d2c27e6f247be8c1066c9be1e3cf390205217f2ca2fe76fe76208d4be2e2ac6 SHA512 aa1fb217fa36b33e8e4b1a9cf5057803f9dd2d50c76f8d33c6494939a592fba0bddef53d4e5d2c14769508df6d409b3bd18cd6d716014cd99224be5e1d64282b
diff --git a/dev-libs/pslib/files/pslib-0.4.6-Fix-implicit-function-declarations.patch b/dev-libs/pslib/files/pslib-0.4.6-Fix-implicit-function-declarations.patch
new file mode 100644
index 000000000000..7548ced79b87
--- /dev/null
+++ b/dev-libs/pslib/files/pslib-0.4.6-Fix-implicit-function-declarations.patch
@@ -0,0 +1,29 @@
+From ffd2e04b8e32d916cc513e73e92afa98348d3a73 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 4 Oct 2022 06:37:32 +0100
+Subject: [PATCH] Fix implicit function declarations
+
+Bug: https://bugs.gentoo.org/871300
+--- a/src/bmp.c
++++ b/src/bmp.c
+@@ -34,6 +34,9 @@
+ #ifdef HAVE_CONFIG_H
+ #include "config.h"
+ #endif
++
++#include <ps_error.h>
++
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+--- a/src/ps_error.h
++++ b/src/ps_error.h
+@@ -1,5 +1,8 @@
+ #ifndef __PS_ERROR_H__
+ #define __PS_ERROR_H__
++
++#include "ps_intern.h"
++
+ void _ps_errorhandler(PSDoc *p, int error, const char *str, void *data);
+ void ps_error(PSDoc *p, int type, const char *fmt, ...);
+ #endif
diff --git a/dev-libs/pslib/pslib-0.4.6.ebuild b/dev-libs/pslib/pslib-0.4.6.ebuild
new file mode 100644
index 000000000000..4391cb1b9132
--- /dev/null
+++ b/dev-libs/pslib/pslib-0.4.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="pslib is a C-library to create PostScript files on the fly"
+HOMEPAGE="http://pslib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pslib/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug jpeg png tiff"
+
+RDEPEND="
+ png? ( media-libs/libpng:= )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ tiff? ( media-libs/tiff:= )"
+#gif? requires libungif, not in portage
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/perl
+ dev-libs/glib:2
+ dev-util/intltool
+ dev-perl/XML-Parser
+ sys-devel/gettext"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.5-fix-build-system.patch
+ "${FILESDIR}"/${PN}-0.4.6-Fix-implicit-function-declarations.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-bmp \
+ $(use_with png) \
+ $(use_with jpeg) \
+ $(use_with tiff) \
+ $(use_with debug)
+}
+
+src_install() {
+ default
+
+ # package installs .pc files
+ find "${ED}" -name '*.la' -delete || die
+}