summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2019-11-02 12:10:51 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2019-11-02 12:10:57 -0400
commit681f42e078527a1a2f7a47d8cb00e72e3f8990d2 (patch)
tree845c1e1dab10564689f2bf785321f4709c5f1148
parentapp-office/libreoffice-l10n: Drop 6.2.5.2 (diff)
downloadgentoo-681f42e078527a1a2f7a47d8cb00e72e3f8990d2.tar.gz
gentoo-681f42e078527a1a2f7a47d8cb00e72e3f8990d2.tar.bz2
gentoo-681f42e078527a1a2f7a47d8cb00e72e3f8990d2.zip
sys-auth/libnss-pgsql: Bump EAPI to 7
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
-rw-r--r--sys-auth/libnss-pgsql/libnss-pgsql-1.5.0_beta-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-auth/libnss-pgsql/libnss-pgsql-1.5.0_beta-r1.ebuild b/sys-auth/libnss-pgsql/libnss-pgsql-1.5.0_beta-r1.ebuild
new file mode 100644
index 000000000000..62a4efe90179
--- /dev/null
+++ b/sys-auth/libnss-pgsql/libnss-pgsql-1.5.0_beta-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Name Service Switch module for use with PostgreSQL"
+HOMEPAGE="http://pgfoundry.org/projects/sysauth/"
+
+MY_P="${P/_/-}"
+SRC_URI="http://pgfoundry.org/frs/download.php/1878/${MY_P}.tgz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-db/postgresql:*"
+DEPEND="${RDEPEND}
+ app-text/xmlto"
+
+src_prepare() {
+ eapply "${FILESDIR}/${P}-gentoo.patch"
+ eapply_user
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -delete || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+ insinto /usr/share/doc/${PF}/examples
+ doins conf/*
+}
+
+pkg_postinst() {
+ elog "Next steps:"
+ elog "1. Create the required tables in the database:"
+ elog " $ psql a_database -f /usr/share/doc/${PF}/examples/dbschema.sql"
+ elog "2. Create the configuration file '/etc/nss-pgsql.conf'"
+ elog " You can copy the example from /usr/share/doc/${PF}/examples/nss-pgsql.conf"
+ elog "3. Edit /etc/nsswitch.conf to use the NSS service 'pgsql'"
+ elog " An example is available here: /usr/share/doc/${PF}/examples/nsswitch.conf"
+}