summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-01-22 20:22:54 -0500
committerMichael Orlitzky <mjo@gentoo.org>2024-01-22 20:29:34 -0500
commit68585b45441f0dab9c77d0210e5baf523de74436 (patch)
tree6653d46fea85101418b575a7e663d886b8870441
parentRevert "net-im/gajim: Drop obsolete dependencies" (diff)
downloadgentoo-68585b45441f0dab9c77d0210e5baf523de74436.tar.gz
gentoo-68585b45441f0dab9c77d0210e5baf523de74436.tar.bz2
gentoo-68585b45441f0dab9c77d0210e5baf523de74436.zip
dev-gap/edim: patch to support user *FLAGS
Upstream suggested we fix this in EDIM, so: https://github.com/frankluebeck/EDIM/pull/23 Closes: https://bugs.gentoo.org/922705 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--dev-gap/edim/edim-1.3.7-r1.ebuild (renamed from dev-gap/edim/edim-1.3.7.ebuild)4
-rw-r--r--dev-gap/edim/files/edim-1.3.7-user-flags.patch29
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-gap/edim/edim-1.3.7.ebuild b/dev-gap/edim/edim-1.3.7-r1.ebuild
index 292e252f717b..e3376c37f636 100644
--- a/dev-gap/edim/edim-1.3.7.ebuild
+++ b/dev-gap/edim/edim-1.3.7-r1.ebuild
@@ -15,4 +15,8 @@ LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3.7-user-flags.patch"
+)
+
gap-pkg_enable_tests
diff --git a/dev-gap/edim/files/edim-1.3.7-user-flags.patch b/dev-gap/edim/files/edim-1.3.7-user-flags.patch
new file mode 100644
index 000000000000..b26b5c289c74
--- /dev/null
+++ b/dev-gap/edim/files/edim-1.3.7-user-flags.patch
@@ -0,0 +1,29 @@
+From 305d6d280b2ed859ffbcf6d1de27b6e1826a4956 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Mon, 22 Jan 2024 20:03:53 -0500
+Subject: [PATCH] Makefile.in: pass user CPPFLAGS, CFLAGS, and LDFLAGS to gac
+
+As in the upstream Makefile.gappkg, and consistent with the idea that
+gac should be treated like a compiler, we now pass CPPFLAGS, CFLAGS,
+and LDFLAGS to gac explicitly, to later be passed on to the C compiler
+and linker.
+---
+ Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index a6936e7..30971c3 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -8,7 +8,7 @@ include $(GAPPATH)/sysinfo.gap
+
+ bin/$(GAParch)/ediv.so: src/ediv.c Makefile
+ @mkdir -p bin/$(GAParch)
+- $(GAC) -d -o bin/$(GAParch)/ediv.so src/ediv.c
++ $(GAC) -d -p "$(CPPFLAGS)" -p "$(CFLAGS)" -P "$(LDFLAGS)" -o bin/$(GAParch)/ediv.so src/ediv.c
+
+ doc:
+ $(GAP) makedocrel.g
+--
+2.43.0
+