summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-03-09 15:13:12 +0100
committerDavid Seifert <soap@gentoo.org>2022-03-09 15:13:12 +0100
commit68863a7fcacbc8dd55be9e44768870bbf6c9bd9b (patch)
tree39325a32c47213d3b32284c238633007a6ea3ae5
parentsys-firmware/iwl3160-ucode: update EAPI 5 -> 8 (diff)
downloadgentoo-68863a7fcacbc8dd55be9e44768870bbf6c9bd9b.tar.gz
gentoo-68863a7fcacbc8dd55be9e44768870bbf6c9bd9b.tar.bz2
gentoo-68863a7fcacbc8dd55be9e44768870bbf6c9bd9b.zip
sys-firmware/iwl7260-ucode: update EAPI 5 -> 8
Closes: https://bugs.gentoo.org/826562 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sys-firmware/iwl7260-ucode/iwl7260-ucode-0.16.242414-r1.ebuild (renamed from sys-firmware/iwl7260-ucode/iwl7260-ucode-0.16.242414.ebuild)33
1 files changed, 10 insertions, 23 deletions
diff --git a/sys-firmware/iwl7260-ucode/iwl7260-ucode-0.16.242414.ebuild b/sys-firmware/iwl7260-ucode/iwl7260-ucode-0.16.242414-r1.ebuild
index 3abce4765618..7bb42e888f01 100644
--- a/sys-firmware/iwl7260-ucode/iwl7260-ucode-0.16.242414.ebuild
+++ b/sys-firmware/iwl7260-ucode/iwl7260-ucode-0.16.242414-r1.ebuild
@@ -1,46 +1,33 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit linux-info versionator
+EAPI=8
+
+inherit linux-info
DEV_N="${PN:3:4}"
-vc=($(get_all_version_components "${PV}"))
-MY_PV="${vc[2]}.${vc[4]}.${vc[0]}"
+MY_PV="$(ver_cut 2).$(ver_cut 3).$(ver_cut 1)"
MY_PN="iwlwifi-${DEV_N}-ucode"
-DV_MAJOR="4"
-DV_MINOR="3"
-DV_PATCH="0"
-
DESCRIPTION="Firmware for Intel (R) Dual Band Wireless-AC ${DEV_N}"
HOMEPAGE="https://wireless.kernel.org/en/users/Drivers/iwlwifi"
SRC_URI="https://wireless.wiki.kernel.org/_media/en/users/drivers/${MY_PN}-${MY_PV}.tgz -> ${P}.tgz"
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
LICENSE="ipw3945"
-SLOT="${vc[2]}"
+SLOT="$(ver_cut 2)"
KEYWORDS="~amd64 ~x86"
IUSE="bluetooth"
-DEPEND=""
-RDEPEND="bluetooth? ( sys-firmware/iwl3160-7260-bt-ucode )
+RDEPEND="
+ bluetooth? ( sys-firmware/iwl3160-7260-bt-ucode )
!sys-kernel/linux-firmware[-savedconfig]"
-S="${WORKDIR}/${MY_PN}-${MY_PV}"
-
CONFIG_CHECK="~IWLMVM"
ERROR_IWLMVM="CONFIG_IWLMVM is required to be enabled in /usr/src/linux/.config for the kernel to be able to load the ${DEV_N} firmware"
-pkg_pretend() {
- if kernel_is lt "${DV_MAJOR}" "${DV_MINOR}" "${DV_PATCH}"; then
- ewarn "Your kernel version is ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}."
- ewarn "This microcode image requires a kernel >= ${DV_MAJOR}.${DV_MINOR}.${DV_PATCH}."
- ewarn "For kernel versions < ${DV_MAJOR}.${DV_MINOR}.${DV_PATCH}, you may install older SLOTS"
- fi
-}
-
src_install() {
insinto /lib/firmware
- doins "${S}/iwlwifi-${DEV_N}-${vc[2]}.ucode"
+ doins iwlwifi-${DEV_N}-$(ver_cut 2).ucode
dodoc README*
}