summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-02-06 11:49:20 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-02-06 11:49:20 +0100
commit68954313c0a0c1715d05989798ee12a2819f8c23 (patch)
treefbe6689c03b1022c0e70de5fdde9a764645e2afb
parentprofiles/arch/arm64: update xscreensaver mask (diff)
downloadgentoo-68954313c0a0c1715d05989798ee12a2819f8c23.tar.gz
gentoo-68954313c0a0c1715d05989798ee12a2819f8c23.tar.bz2
gentoo-68954313c0a0c1715d05989798ee12a2819f8c23.zip
dev-tcltk/tclpython: PythonCompatUpdate
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-tcltk/tclpython/files/tclpython-5.0-gentoo.patch20
-rw-r--r--dev-tcltk/tclpython/tclpython-5.0-r1.ebuild4
2 files changed, 22 insertions, 2 deletions
diff --git a/dev-tcltk/tclpython/files/tclpython-5.0-gentoo.patch b/dev-tcltk/tclpython/files/tclpython-5.0-gentoo.patch
index c77339982fd6..39bdf20c095c 100644
--- a/dev-tcltk/tclpython/files/tclpython-5.0-gentoo.patch
+++ b/dev-tcltk/tclpython/files/tclpython-5.0-gentoo.patch
@@ -24,3 +24,23 @@
ifneq ($(MAKECMDGOALS), clean)
-include $(DEPEND)
+--- a/src/py.c 2022-02-06 10:20:03.352580186 +0100
++++ b/src/py.c 2022-02-06 11:16:49.504796684 +0100
+@@ -24,7 +24,6 @@
+ // First time initializing Python
+ Py_NoSiteFlag = 1;
+ Py_Initialize();
+- PyEval_InitThreads();
+ GlobalThread = PyEval_SaveThread();
+ }
+
+@@ -60,7 +59,8 @@
+ #ifdef WITH_THREAD
+ PyEval_RestoreThread(interp->thread_state);
+ Py_EndInterpreter(interp->thread_state);
+- PyEval_ReleaseLock();
++ PyThreadState_Swap(GlobalThread);
++ PyEval_SaveThread();
+ #endif
+
+ free(interp);
diff --git a/dev-tcltk/tclpython/tclpython-5.0-r1.ebuild b/dev-tcltk/tclpython/tclpython-5.0-r1.ebuild
index 05156fc6ea87..92a9fda120d9 100644
--- a/dev-tcltk/tclpython/tclpython-5.0-r1.ebuild
+++ b/dev-tcltk/tclpython/tclpython-5.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit python-single-r1 toolchain-funcs