summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-10-06 22:23:46 +0300
committerMart Raudsepp <leio@gentoo.org>2018-10-06 23:21:11 +0300
commit6897c8cdac67c020837b217f11900879f45895b4 (patch)
tree2814a6a501eb36a6f15bb8cc8985d6c1e3b5c25b
parentapp-arch/engrampa: remove old (diff)
downloadgentoo-6897c8cdac67c020837b217f11900879f45895b4.tar.gz
gentoo-6897c8cdac67c020837b217f11900879f45895b4.tar.bz2
gentoo-6897c8cdac67c020837b217f11900879f45895b4.zip
app-editors/pluma: remove old
Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
-rw-r--r--app-editors/pluma/Manifest3
-rw-r--r--app-editors/pluma/metadata.xml3
-rw-r--r--app-editors/pluma/pluma-1.12.2-r1.ebuild91
-rw-r--r--app-editors/pluma/pluma-1.14.1.ebuild93
-rw-r--r--app-editors/pluma/pluma-1.16.2.ebuild93
5 files changed, 0 insertions, 283 deletions
diff --git a/app-editors/pluma/Manifest b/app-editors/pluma/Manifest
index 92fbbd6b817..cffe5bc4d61 100644
--- a/app-editors/pluma/Manifest
+++ b/app-editors/pluma/Manifest
@@ -1,4 +1 @@
-DIST pluma-1.12.2.tar.xz 3397280 BLAKE2B 23af095549ff944b0936889deda6576717a6376aa2f2be8ed9b7d8ad70f8bb0524aff7314f9c335a42d80951c047c8008278144f45c2c5edb09a259b298c0024 SHA512 db2878161903868703514531ba214fc34dad1789885f18756e9192d6ba17950c8be03141ada72f8c386b515d8b0f9d58a0ee94a33fe3ffe00f360ea667c2b275
-DIST pluma-1.14.1.tar.xz 3415364 BLAKE2B 9449fc6b5e98d8ecb25f70df6c114c13cc32a8c0348ed2047eb874e85c7d448d3d7f0b4d7dd6e2fada3de847ded425651dc6d0ca92ce3c784fd32948735f3b25 SHA512 5d04e053ab2eb0f90e34d9af541004867c7317fd9386229c4e702e95a80420df16b20e4ae4c30bbee79fe904282f6134f7c361971be07cd6952612d975c88d11
-DIST pluma-1.16.2.tar.xz 3428472 BLAKE2B c3b543fb11678269fbbc2d049686b2a553aa1fede4ef1bab8abbc7fed316f27ba67cbb366908966b6c844f8ad0c4899499e52b4720378364555ef9156c80ae95 SHA512 bf91a7e4e1cfb92f9fd9a1d5b4ac9f0fd2704785b2da5d7a3aa360b4c217a57653d6f7bf509c156b8711bc5164e022c685331c93a139f55ea41431bc72e848fe
DIST pluma-1.18.3.tar.xz 3355188 BLAKE2B d53f381aa9c74cad0df82ccc73aaab9f87347cb8e3886471a2531bdd4d49a84ee97a50f2333b2e375f9bc2a634c25dc69b36659dcb589ace716e523a9d0b4544 SHA512 62ad57a8d7626e34c15610e121869ee9b06a2498acb40ec0a60839ca0273d146bd59682d352c3e98d892460c444c5442d32673c2f63897bb8c3e9e595e771dc1
diff --git a/app-editors/pluma/metadata.xml b/app-editors/pluma/metadata.xml
index e740906c492..3daddb1815d 100644
--- a/app-editors/pluma/metadata.xml
+++ b/app-editors/pluma/metadata.xml
@@ -5,9 +5,6 @@
<email>mate@gentoo.org</email>
<name>Gentoo MATE Desktop</name>
</maintainer>
- <use>
- <flag name="gtk3">Build with GTK+3 instead of GTK+2</flag>
- </use>
<upstream>
<remote-id type="github">mate-desktop/pluma</remote-id>
</upstream>
diff --git a/app-editors/pluma/pluma-1.12.2-r1.ebuild b/app-editors/pluma/pluma-1.12.2-r1.ebuild
deleted file mode 100644
index a9646a9a642..00000000000
--- a/app-editors/pluma/pluma-1.12.2-r1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MATE_LA_PUNT="yes"
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit mate multilib python-single-r1 virtualx
-
-if [[ ${PV} != 9999 ]]; then
- KEYWORDS="amd64 ~arm x86"
-fi
-
-DESCRIPTION="Pluma text editor for the MATE desktop"
-LICENSE="GPL-2"
-SLOT="0"
-
-IUSE="gtk3 python spell"
-
-REQUIRED_USE="
- gtk3? ( !python )
- python? ( ${PYTHON_REQUIRED_USE} )"
-
-# Tests require gvfs sftp fs mounted and schema's installed. Disable tests.
-# https://github.com/mate-desktop/mate-text-editor/issues/33
-RESTRICT="test"
-
-RDEPEND="app-text/rarian:0
- dev-libs/atk:0
- >=dev-libs/glib-2.36:2
- >=dev-libs/libxml2-2.5:2
- >=mate-base/mate-desktop-1.9[gtk3(-)=]
- x11-libs/cairo:0
- x11-libs/gdk-pixbuf:2
- x11-libs/libICE:0
- x11-libs/libX11:0
- >=x11-libs/libSM-1.0
- x11-libs/pango:0
- virtual/libintl:0
- !gtk3? (
- >=x11-libs/gtk+-2.24:2
- >=x11-libs/gtksourceview-2.9.7:2.0
- )
- gtk3? (
- >=x11-libs/gtk+-3.0:3
- >=x11-libs/gtksourceview-2.9.7:3.0
- )
- spell? (
- >=app-text/enchant-1.2:0
- >=app-text/iso-codes-0.35:0
- )
- python? (
- ${PYTHON_DEPS}
- >=dev-python/pygobject-2.15.4:2[${PYTHON_USEDEP}]
- >=dev-python/pygtk-2.12:2[${PYTHON_USEDEP}]
- >=dev-python/pygtksourceview-2.9.2:2
- )
- !!app-editors/mate-text-editor"
-
-DEPEND="${RDEPEND}
- ~app-text/docbook-xml-dtd-4.1.2
- >=app-text/scrollkeeper-dtd-1:1.0
- app-text/yelp-tools:0
- dev-util/gtk-doc
- dev-util/gtk-doc-am
- >=dev-util/intltool-0.50.1:*
- >=sys-devel/libtool-2.2.6:2
- >=sys-devel/gettext-0.17:*
- virtual/pkgconfig:*"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- mate_src_configure \
- --with-gtk=$(usex gtk3 3.0 2.0) \
- $(use_enable python) \
- $(use_enable spell)
-}
-
-src_test() {
- # FIXME: This should be handled at eclass level.
- "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
-
- unset DBUS_SESSION_BUS_ADDRESS
-
- GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
-}
diff --git a/app-editors/pluma/pluma-1.14.1.ebuild b/app-editors/pluma/pluma-1.14.1.ebuild
deleted file mode 100644
index a1c96eaebad..00000000000
--- a/app-editors/pluma/pluma-1.14.1.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MATE_LA_PUNT="yes"
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit mate multilib python-single-r1 virtualx
-
-if [[ ${PV} != 9999 ]]; then
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-DESCRIPTION="Pluma text editor for the MATE desktop"
-LICENSE="GPL-2"
-SLOT="0"
-
-IUSE="gtk3 python spell"
-
-REQUIRED_USE="
- gtk3? ( !python )
- python? ( ${PYTHON_REQUIRED_USE} )"
-
-# Tests require gvfs sftp fs mounted and schema's installed. Disable tests.
-# https://github.com/mate-desktop/mate-text-editor/issues/33
-RESTRICT="test"
-
-COMMON_DEPEND="dev-libs/atk:0
- >=dev-libs/glib-2.36:2
- >=dev-libs/libxml2-2.5:2
- >=mate-base/mate-desktop-1.9[gtk3(-)=]
- x11-libs/cairo:0
- x11-libs/gdk-pixbuf:2
- x11-libs/libICE:0
- x11-libs/libX11:0
- >=x11-libs/libSM-1.0
- x11-libs/pango:0
- virtual/libintl:0
- !gtk3? (
- >=x11-libs/gtk+-2.24:2
- >=x11-libs/gtksourceview-2.9.7:2.0
- )
- gtk3? (
- >=x11-libs/gtk+-3.0:3
- >=x11-libs/gtksourceview-2.9.7:3.0
- )
- spell? (
- >=app-text/enchant-1.2:0
- >=app-text/iso-codes-0.35:0
- )
- python? (
- ${PYTHON_DEPS}
- >=dev-python/pygobject-2.15.4:2[${PYTHON_USEDEP}]
- >=dev-python/pygtk-2.12:2[${PYTHON_USEDEP}]
- >=dev-python/pygtksourceview-2.9.2:2
- )
- !!app-editors/mate-text-editor"
-
-RDEPEND="${COMMON_DEPEND}"
-
-DEPEND="${COMMON_DEPEND}
- ~app-text/docbook-xml-dtd-4.1.2
- app-text/rarian:0
- >=app-text/scrollkeeper-dtd-1:1.0
- app-text/yelp-tools:0
- dev-util/gtk-doc
- dev-util/gtk-doc-am
- >=dev-util/intltool-0.50.1:*
- >=sys-devel/libtool-2.2.6:2
- >=sys-devel/gettext-0.17:*
- virtual/pkgconfig:*"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- mate_src_configure \
- --with-gtk=$(usex gtk3 3.0 2.0) \
- $(use_enable python) \
- $(use_enable spell)
-}
-
-src_test() {
- # FIXME: This should be handled at eclass level.
- "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
-
- unset DBUS_SESSION_BUS_ADDRESS
-
- GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
-}
diff --git a/app-editors/pluma/pluma-1.16.2.ebuild b/app-editors/pluma/pluma-1.16.2.ebuild
deleted file mode 100644
index 801ac0a4733..00000000000
--- a/app-editors/pluma/pluma-1.16.2.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MATE_LA_PUNT="yes"
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit mate multilib python-single-r1 virtualx
-
-if [[ ${PV} != 9999 ]]; then
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-DESCRIPTION="Pluma text editor for the MATE desktop"
-LICENSE="GPL-2"
-SLOT="0"
-
-IUSE="gtk3 python spell"
-
-REQUIRED_USE="
- gtk3? ( !python )
- python? ( ${PYTHON_REQUIRED_USE} )"
-
-# Tests require gvfs sftp fs mounted and schema's installed. Disable tests.
-# https://github.com/mate-desktop/mate-text-editor/issues/33
-RESTRICT="test"
-
-COMMON_DEPEND="dev-libs/atk:0
- >=dev-libs/glib-2.36:2
- >=dev-libs/libxml2-2.5:2
- x11-libs/cairo:0
- x11-libs/gdk-pixbuf:2
- x11-libs/libICE:0
- x11-libs/libX11:0
- >=x11-libs/libSM-1.0
- x11-libs/pango:0
- virtual/libintl:0
- !gtk3? (
- >=x11-libs/gtk+-2.24:2
- >=x11-libs/gtksourceview-2.9.7:2.0
- )
- gtk3? (
- >=x11-libs/gtk+-3.0:3
- >=x11-libs/gtksourceview-2.9.7:3.0
- )
- spell? (
- >=app-text/enchant-1.2:0
- >=app-text/iso-codes-0.35:0
- )
- python? (
- ${PYTHON_DEPS}
- >=dev-python/pygobject-2.15.4:2[${PYTHON_USEDEP}]
- >=dev-python/pygtk-2.12:2[${PYTHON_USEDEP}]
- >=dev-python/pygtksourceview-2.9.2:2
- )
- !!app-editors/mate-text-editor"
-
-RDEPEND="${COMMON_DEPEND}
- >=mate-base/mate-desktop-1.9[gtk3(-)=]"
-
-DEPEND="${COMMON_DEPEND}
- ~app-text/docbook-xml-dtd-4.1.2
- app-text/rarian:0
- >=app-text/scrollkeeper-dtd-1:1.0
- app-text/yelp-tools:0
- dev-util/gtk-doc
- dev-util/gtk-doc-am
- >=dev-util/intltool-0.50.1:*
- >=sys-devel/libtool-2.2.6:2
- >=sys-devel/gettext-0.17:*
- virtual/pkgconfig:*"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- mate_src_configure \
- --with-gtk=$(usex gtk3 3.0 2.0) \
- $(use_enable python) \
- $(use_enable spell)
-}
-
-src_test() {
- # FIXME: This should be handled at eclass level.
- "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
-
- unset DBUS_SESSION_BUS_ADDRESS
-
- GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
-}