summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Fischl <github@fischl-online.de>2023-01-10 07:40:11 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-01-20 15:29:00 +0200
commit68b7a096e41387c5912995e33ebaad9f840571ea (patch)
tree77c567bd8d9d97a17d602632f47c0ccbdf276979
parentkde-plasma/xembed-sni-proxy: 5.26.90 version bump (diff)
downloadgentoo-68b7a096e41387c5912995e33ebaad9f840571ea.tar.gz
gentoo-68b7a096e41387c5912995e33ebaad9f840571ea.tar.bz2
gentoo-68b7a096e41387c5912995e33ebaad9f840571ea.zip
app-text/xlsx2csv: bump 0.8.0
Signed-off-by: Anton Fischl <github@fischl-online.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-text/xlsx2csv/Manifest1
-rw-r--r--app-text/xlsx2csv/files/xlsx2csv-0.7.8-tests.patch13
-rw-r--r--app-text/xlsx2csv/xlsx2csv-0.8.0.ebuild35
3 files changed, 49 insertions, 0 deletions
diff --git a/app-text/xlsx2csv/Manifest b/app-text/xlsx2csv/Manifest
index 1f9a7ac7c375..d4c75dbb6f6c 100644
--- a/app-text/xlsx2csv/Manifest
+++ b/app-text/xlsx2csv/Manifest
@@ -1 +1,2 @@
DIST xlsx2csv-0.7.6.tar.gz 231283 BLAKE2B d0271c6a82b7ed2825e3224f0e34637db3dacda3fe99c6ef5a087cc8d248592efc169b466514abd18b50f6625e8d9743c812b46ecb6f76ce7d1fdc51dfe34fc4 SHA512 7fc8e0da0c050e12d0cfd73f16ffd9c00f19bf05925b54cc68d6a0858a75db89d52e46312956dfd149e0ec88778f68056942a090db44e6148796fad33fa26489
+DIST xlsx2csv-0.8.0.tar.gz 208842 BLAKE2B bfe69c39a8312feec35bb9a8079982f0765cbe975ce9d842ccd969d1399d03202ddf8d41c54f5129d122f535272add38c1489c0804340cc24bf1091779d76a2c SHA512 dd9ced043f347d420371aaf68f65b1ae827f231ceddbfb051174c8072dda27f989490120d0ee6bbe1fb25faf79944242144e196ccf58db5c537d5b0826cb91ee
diff --git a/app-text/xlsx2csv/files/xlsx2csv-0.7.8-tests.patch b/app-text/xlsx2csv/files/xlsx2csv-0.7.8-tests.patch
new file mode 100644
index 000000000000..f692a4931522
--- /dev/null
+++ b/app-text/xlsx2csv/files/xlsx2csv-0.7.8-tests.patch
@@ -0,0 +1,13 @@
+diff --git a/test/run b/test/run
+index 990421c..081729d 100755
+--- a/test/run
++++ b/test/run
+@@ -5,7 +5,7 @@ import sys
+ import subprocess
+ from io import open
+
+-PYTHON_VERSIONS = ["2", "3"]
++PYTHON_VERSIONS = ["3"]
+
+ """
+ This test uses sys.stdout.
diff --git a/app-text/xlsx2csv/xlsx2csv-0.8.0.ebuild b/app-text/xlsx2csv/xlsx2csv-0.8.0.ebuild
new file mode 100644
index 000000000000..38e7ce7168da
--- /dev/null
+++ b/app-text/xlsx2csv/xlsx2csv-0.8.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="xml(+)"
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Convert MS Office xlsx files to CSV"
+HOMEPAGE="https://github.com/dilshod/xlsx2csv/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-lang/perl"
+
+PATCHES=( "${FILESDIR}"/"${PN}-0.7.8-tests.patch" )
+
+python_compile_all() {
+ emake -C man
+}
+
+python_test() {
+ "${EPYTHON}" test/run || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman "man/${PN}.1"
+}