summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-07-19 20:47:20 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-07-19 21:38:03 +0200
commit68cbe2fbe9bc1a1f566b6b65ec26be0efa72374d (patch)
treeb87870f2e9b02fa7e84644beade5e58607215cef
parentdev-libs/level-zero: drop 1.7.15, 1.8.0 (diff)
downloadgentoo-68cbe2fbe9bc1a1f566b6b65ec26be0efa72374d.tar.gz
gentoo-68cbe2fbe9bc1a1f566b6b65ec26be0efa72374d.tar.bz2
gentoo-68cbe2fbe9bc1a1f566b6b65ec26be0efa72374d.zip
dev-util/intel-graphics-system-controller: add 0.8.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-util/intel-graphics-system-controller/Manifest1
-rw-r--r--dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/intel-graphics-system-controller/Manifest b/dev-util/intel-graphics-system-controller/Manifest
index 05d590bf5974..515be2e673ab 100644
--- a/dev-util/intel-graphics-system-controller/Manifest
+++ b/dev-util/intel-graphics-system-controller/Manifest
@@ -1 +1,2 @@
DIST intel-graphics-system-controller-0.6.0.tar.gz 146082 BLAKE2B e67b6d5064aece983d047e1f64e0477c613fb7bc0912c5173cc1c1588151703098e0429c790f25d78a76caab8663b80e9fc20f313be2318c2be2b30aa6ca06f5 SHA512 265716648b1c2a2e8164643eaf8a6cdac57953493d67c805ecfb9077b834e17b13693c56958c219083fc8e4f5fb3e9cafb64d6b3dd40d510434d4517ec945fc3
+DIST intel-graphics-system-controller-0.8.0.tar.gz 166364 BLAKE2B 86a1aeb328554a7260c57bb4513dc236e34aa758b53d4d743562639326d22963742fe1ceca89df648187dfe8e7233c5306977241bb9d37e765d21f52d0073873 SHA512 a2fd38717cd1d02270c97eda20fe4294c634a0520293cdd396b93d474eed2ec903ed565a2d15d5e2671424000bb21c3f04b9812a4c050aa68383a75dee0281ef
diff --git a/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.0.ebuild b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.0.ebuild
new file mode 100644
index 000000000000..af442c4e311c
--- /dev/null
+++ b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="igsc"
+MY_P="${MY_PN}-${PV}"
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="Intel graphics system controller firmware update library"
+HOMEPAGE="https://github.com/intel/igsc"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+cli doc"
+
+RDEPEND="dev-libs/metee:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ ${PYTHON_DEPS}
+ app-doc/doxygen
+ $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
+ )
+"
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CLI="$(usex cli)"
+ -DENABLE_DOCS="$(usex doc)"
+ -DENABLE_ENUM="ON"
+ -DENABLE_PERF="OFF"
+ -DENABLE_WERROR="OFF"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DENABLE_TESTS="OFF"
+ )
+
+ cmake_src_configure
+}