summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-04 07:32:33 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-04 19:04:07 +0200
commit68f18a03b10842b61e8f0080525520a9e774ac1e (patch)
tree7e8a079e3a43350f999045c06fe9bb99cc67170f
parentdev-python/setuptools: Bump to 46.1.3 (diff)
downloadgentoo-68f18a03b10842b61e8f0080525520a9e774ac1e.tar.gz
gentoo-68f18a03b10842b61e8f0080525520a9e774ac1e.tar.bz2
gentoo-68f18a03b10842b61e8f0080525520a9e774ac1e.zip
dev-python/pytest-django: Bump to 3.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-django/Manifest1
-rw-r--r--dev-python/pytest-django/pytest-django-3.9.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pytest-django/Manifest b/dev-python/pytest-django/Manifest
index a7539ffbf8f1..6b064a9364ef 100644
--- a/dev-python/pytest-django/Manifest
+++ b/dev-python/pytest-django/Manifest
@@ -1 +1,2 @@
DIST pytest-django-3.8.0.tar.gz 70013 BLAKE2B 75e2ebf6a3a61cfabdc59ceb6f60a85ab4e257b22e3ff55bcda122a370317bf91a9f90640d9edc17da2cc3bdc6dcf6e84dd1e3438dff91b07f5682713804d513 SHA512 3ce45b08f913c3e20b679c7f7a07818ffab7088fd90757794e1807db2025d655c195304da3ca3905c8ddb58fc9708000dc492f4114df8f4e7bfdb1285ebd997a
+DIST pytest-django-3.9.0.tar.gz 70498 BLAKE2B 0f3cf7ffd528f00dd0c7dd6babcb64833ec3684c7b62dcb8757b0f90cdcdddabffdbff240774ed6fb2a294e27da2acd7f396298ff2884be6e5b4c8d9c632d008 SHA512 92985e66f47c91363d19fe2bfe8ccab14212be577692f90923dbbae4c8d406cf698796d485af2b721863392810fc07c6f11ada0c61589cd1861f0d34a732effe
diff --git a/dev-python/pytest-django/pytest-django-3.9.0.ebuild b/dev-python/pytest-django/pytest-django-3.9.0.ebuild
new file mode 100644
index 000000000000..d8944a9de33a
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-3.9.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for py.test"
+HOMEPAGE="https://pypi.org/project/pytest-django/ https://pytest-django.readthedocs.org https://github.com/pytest-dev/pytest-django"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools_scm-1.11.1[${PYTHON_USEDEP}]
+"
+
+# not all test dependencies are packaged and this package isn't worth it.
+RESTRICT="test"