summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-12 21:38:26 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-12 21:38:26 +0200
commit696eb7407185b7c713f79ac6afadf19d3a93c3a7 (patch)
treeaf509a5ad05b9b1e7aec87c8d906b21bb92200a7
parentdev-python/multidict: Bump to 5.0.0 (diff)
downloadgentoo-696eb7407185b7c713f79ac6afadf19d3a93c3a7.tar.gz
gentoo-696eb7407185b7c713f79ac6afadf19d3a93c3a7.tar.bz2
gentoo-696eb7407185b7c713f79ac6afadf19d3a93c3a7.zip
dev-python/virtualenv: Bump to 20.0.34
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/virtualenv/Manifest1
-rw-r--r--dev-python/virtualenv/virtualenv-20.0.34.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/virtualenv/Manifest b/dev-python/virtualenv/Manifest
index 120a2252fad3..82f5e1fb9c58 100644
--- a/dev-python/virtualenv/Manifest
+++ b/dev-python/virtualenv/Manifest
@@ -2,3 +2,4 @@ DIST virtualenv-16.7.10.tar.gz 5116776 BLAKE2B 42f0a4b4330850b504f8febd991ef6ecd
DIST virtualenv-20.0.31.tar.gz 8300305 BLAKE2B 1574b553b2bc8e05bf00584379f80c1e5c0ee9798595255830059eedea62f02f02d216c421aa2cb312bc9e60694f6a409d0c2495858a89fc1ad7aaddea7965ff SHA512 46220bda37b3b860e44c4d0775a89c22a7ba775287f05438d1d3698201cc213a05b2718ef40be302627005ae349dc59a3141c7a30cc1dab6dc81f7692c7f16a5
DIST virtualenv-20.0.32.tar.gz 8282189 BLAKE2B 91cfece89079cf05bab406e86a7b4d89ff65b058682f989c1a87ed63ffd9a06447983935a05409e1f8116c45434fe5b4040ed713ae01c17887050709af26a422 SHA512 6080a395df16cc4d38a3afa90337fe0f60ce1d6906c4d62f461c90c67df2967a27144def0891407a96405d7b1ca8b838a0daeed4ccc775ffee35f7dc14f54598
DIST virtualenv-20.0.33.tar.gz 8282602 BLAKE2B 702432c39fb4e6802e9d456f2c1c10872e45c616dba72e52397d10328d310a920b1b475fcb0543ba05f7adc5d780adf9d6a9c850f5844b833c9bd66b7bb0fbc9 SHA512 3bb68734884fa88343070c19e5d931a36fb90f1351bbc24c0db7bea26172e9118fa088310d2667b568e268dc33141c62cad372e2ad03106eda72751a0c1895ea
+DIST virtualenv-20.0.34.tar.gz 8282838 BLAKE2B 73352c278bac6d2bc548beee738bf5f9972430681edca242f2945d8301373094a378fe3ecf2a72bae11e2bf9c28b8bf0a8526ee5e52a9a5344ac4f46c3af7a9a SHA512 4ea4b9a13771984dc5e9922ee79f3577dabcb8f49afa0e4a138114e20fb81e136b8c140a3dce471a01beefbff495dc3eb29bf9cf389bdb856e55838a53a49658
diff --git a/dev-python/virtualenv/virtualenv-20.0.34.ebuild b/dev-python/virtualenv/virtualenv-20.0.34.ebuild
new file mode 100644
index 000000000000..a734981f18b9
--- /dev/null
+++ b/dev-python/virtualenv/virtualenv-20.0.34.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1
+
+DESCRIPTION="Virtual Python Environment builder"
+HOMEPAGE="
+ https://virtualenv.pypa.io/en/stable/
+ https://pypi.org/project/virtualenv/
+ https://github.com/pypa/virtualenv/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/appdirs-1.4.3[${PYTHON_USEDEP}]
+ >=dev-python/distlib-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-41[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-0.12[${PYTHON_USEDEP}]
+ ' python3_{6,7} pypy3)
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_resources-1.0[${PYTHON_USEDEP}]
+ ' python3_6 pypy3)"
+# coverage is used somehow magically in virtualenv, maybe it actually
+# tests something useful
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/pip-20.0.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5[${PYTHON_USEDEP}]
+ >=dev-python/pytest-freezegun-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-1.3.4[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ ' 'python3*')
+ )"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme \
+ dev-python/towncrier
+
+src_prepare() {
+ # we don't have xonsh
+ rm tests/unit/activation/test_xonsh.py || die
+ # require internet
+ sed -e 's:test_seed_link_via_app_data:_&:' \
+ -i tests/unit/seed/embed/test_boostrap_link_via_app_data.py || die
+ # TODO: investigate
+ sed -e 's:test_cross_major:_&:' \
+ -i tests/unit/create/test_creator.py || die
+
+ distutils-r1_src_prepare
+}
+
+src_configure() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ if [[ ${EPYTHON} == pypy3 ]]; then
+ # TODO: skip with better granularity
+ ewarn "Skipping broken tests on pypy3"
+ return
+ fi
+
+ distutils_install_for_testing
+
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ elog "Please note that while virtualenv package no longer supports"
+ elog "Python 2.7, you can still create py2.7 virtualenvs via:"
+ elog " $ virtualenv -p 2.7 ..."
+}