summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-10-07 11:10:50 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-10-07 11:12:07 -0500
commit69e8a6f8023958ca82d4f8d2692ce100ad29cf5d (patch)
tree5595e22dbe3189a35e53a38352a5aaaab4303102
parentwww-plugins/chrome-binary-plugins: automated update (diff)
downloadgentoo-69e8a6f8023958ca82d4f8d2692ce100ad29cf5d.tar.gz
gentoo-69e8a6f8023958ca82d4f8d2692ce100ad29cf5d.tar.bz2
gentoo-69e8a6f8023958ca82d4f8d2692ce100ad29cf5d.zip
app-emulation/cloud-init: fixing runlevel stuff
Package-Manager: portage-2.3.0
-rw-r--r--app-emulation/cloud-init/cloud-init-0.7.8-r1.ebuild (renamed from app-emulation/cloud-init/cloud-init-0.7.8.ebuild)9
-rw-r--r--app-emulation/cloud-init/files/cloud-init-0.7.8-gentooinit.patch25
2 files changed, 33 insertions, 1 deletions
diff --git a/app-emulation/cloud-init/cloud-init-0.7.8.ebuild b/app-emulation/cloud-init/cloud-init-0.7.8-r1.ebuild
index 2a4ecb74e34d..f3a40a955036 100644
--- a/app-emulation/cloud-init/cloud-init-0.7.8.ebuild
+++ b/app-emulation/cloud-init/cloud-init-0.7.8-r1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~x86"
IUSE="test"
CDEPEND="
@@ -84,3 +84,10 @@ python_install_all() {
systemd_dounit "${S}"/systemd/cloud-init-local.service
systemd_dounit "${S}"/systemd/cloud-init.service
}
+
+pkg_postinst() {
+ elog "cloud-init-local needs to be run in the boot runlevel because it"
+ elog "modifies services in the default runlevel. When a runlevel is started"
+ elog "it is cached, so modifications that happen to the current runlevel"
+ elog "while you are in it are not acted upon."
+}
diff --git a/app-emulation/cloud-init/files/cloud-init-0.7.8-gentooinit.patch b/app-emulation/cloud-init/files/cloud-init-0.7.8-gentooinit.patch
index b80a60a47b7f..ff0e0149fa3b 100644
--- a/app-emulation/cloud-init/files/cloud-init-0.7.8-gentooinit.patch
+++ b/app-emulation/cloud-init/files/cloud-init-0.7.8-gentooinit.patch
@@ -11,3 +11,28 @@ index bbadd7b..1578a3d 100755
scripts=['tools/cloud-init-per'],
license='GPLv3',
data_files=data_files,
+diff --git a/sysvinit/gentoo/cloud-init b/sysvinit/gentoo/cloud-init
+index 5afc0f2..531a715 100644
+--- a/sysvinit/gentoo/cloud-init
++++ b/sysvinit/gentoo/cloud-init
+@@ -2,6 +2,7 @@
+ # add depends for network, dns, fs etc
+ depend() {
+ after cloud-init-local
++ after net
+ before cloud-config
+ provide cloud-init
+ }
+diff --git a/sysvinit/gentoo/cloud-init-local b/sysvinit/gentoo/cloud-init-local
+index 9bd0b56..0f8cf65 100644
+--- a/sysvinit/gentoo/cloud-init-local
++++ b/sysvinit/gentoo/cloud-init-local
+@@ -2,7 +2,7 @@
+
+ depend() {
+ after localmount
+- after netmount
++ before net
+ before cloud-init
+ provide cloud-init-local
+ }