summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-05-15 03:26:03 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-05-15 03:48:59 -0700
commit6a5c39e050af4e04b28b920a85b145da4841cbe6 (patch)
treeb2f2974f115e90c876a82b39f8fbe8582a3e6984
parentdev-python/pmw: Fix remote-id (diff)
downloadgentoo-6a5c39e050af4e04b28b920a85b145da4841cbe6.tar.gz
gentoo-6a5c39e050af4e04b28b920a85b145da4841cbe6.tar.bz2
gentoo-6a5c39e050af4e04b28b920a85b145da4841cbe6.zip
sys-libs/libvpd: add 2.2.9
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--sys-libs/libvpd/Manifest1
-rw-r--r--sys-libs/libvpd/libvpd-2.2.9.ebuild43
-rw-r--r--sys-libs/libvpd/metadata.xml3
3 files changed, 46 insertions, 1 deletions
diff --git a/sys-libs/libvpd/Manifest b/sys-libs/libvpd/Manifest
index 908a68bb41b4..86db8dfddfa6 100644
--- a/sys-libs/libvpd/Manifest
+++ b/sys-libs/libvpd/Manifest
@@ -1 +1,2 @@
DIST libvpd-2.2.8.tar.gz 52725 BLAKE2B 76bdc6ddf80236a6848185273c2cac181d44214f0c609d7c5af6fa4d09a7cd816324af35745617ce3daa7268311e2ed754335600df1d4970a324eb327015d051 SHA512 d0b7d1760c6ae54717c538405c651317b7318dec5780961f5386c09b7d245e35a84c2fc47d89c47c3cd2168d73d7186f5819981d52c3ba962514639833dc62aa
+DIST libvpd-2.2.9.tar.gz 53747 BLAKE2B c8898e2f604431b74bf5e10fc99e7a9b5540b825f2a996776109a2b2b636f732ff8d9f7956ffea1231e5b023e285eee641a873a68fcd8a2d6a6d9e64c5ab3b18 SHA512 e32a80e0f3aaedbaaac64dbdedfee7eeb2e7a7b6d2d737bca4678d26caadab77032a7c26211a5fc3caed3724488bc8fa99620ceac05f8d156ca90f4452cfaf0a
diff --git a/sys-libs/libvpd/libvpd-2.2.9.ebuild b/sys-libs/libvpd/libvpd-2.2.9.ebuild
new file mode 100644
index 000000000000..d98f5588ae00
--- /dev/null
+++ b/sys-libs/libvpd/libvpd-2.2.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools udev
+
+DESCRIPTION="Library implementation for listing Vital Product Data"
+HOMEPAGE="https://github.com/power-ras/libvpd"
+SRC_URI="https://github.com/power-ras/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/3"
+KEYWORDS="~ppc ~ppc64"
+
+DEPEND="
+ dev-db/sqlite:3
+ sys-libs/zlib:=
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # sysconfdir is used only to establish where the udev rules file should go
+ # unfortunately it also adds the subdirs on its own so we strip it down to
+ # dirname
+ local myconf=(
+ --disable-static
+ --localstatedir="${EPREFIX}/var"
+ --sysconfdir="$( dirname $(get_udevdir) )"
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ keepdir /var/lib/lsvpd
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/sys-libs/libvpd/metadata.xml b/sys-libs/libvpd/metadata.xml
index 2219560b548b..9e9a9d49a2b2 100644
--- a/sys-libs/libvpd/metadata.xml
+++ b/sys-libs/libvpd/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo Linux PowerPC Development</name>
</maintainer>
<upstream>
- <remote-id type="sourceforge">linux-diag</remote-id>
+ <remote-id type="github">power-ras/libvpd</remote-id>
+ <changelog>https://github.com/power-ras/libvpd/blob/master/ChangeLog</changelog>
</upstream>
</pkgmetadata>