summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-26 17:29:41 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-26 17:38:34 +0100
commit6a85df91d15b2a094ac027741e9fa5be271d6c36 (patch)
treef89bd17fa54591c61d91303f5e2cf633f720acc4
parentapp-emulation/libcacard: x86 stable wrt bug #571566 (diff)
downloadgentoo-6a85df91d15b2a094ac027741e9fa5be271d6c36.tar.gz
gentoo-6a85df91d15b2a094ac027741e9fa5be271d6c36.tar.bz2
gentoo-6a85df91d15b2a094ac027741e9fa5be271d6c36.zip
dev-python/packaging: Break circular dep on pyparsing
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=572792 Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/packaging/packaging-16.0.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-python/packaging/packaging-16.0.ebuild b/dev-python/packaging/packaging-16.0.ebuild
index 5bbc7fa32eb8..aa01c022d016 100644
--- a/dev-python/packaging/packaging-16.0.ebuild
+++ b/dev-python/packaging/packaging-16.0.ebuild
@@ -17,13 +17,14 @@ LICENSE="|| ( Apache-2.0 BSD-2 )"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="test"
-RDEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
+RDEPEND=""
DEPEND="${RDEPEND}
test? (
dev-python/pretend[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
)
"
+PDEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
python_test() {
py.test --capture=no --strict -v || die