summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-12-29 03:14:05 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-12-29 07:01:27 +0000
commit6a9a725664ad99e22b74846d102e4ac52167ec46 (patch)
tree31d30e2da04a66052808d6e01f7ebf00873acf03
parentsci-astronomy/astrometry: version bump (diff)
downloadgentoo-6a9a725664ad99e22b74846d102e4ac52167ec46.tar.gz
gentoo-6a9a725664ad99e22b74846d102e4ac52167ec46.tar.bz2
gentoo-6a9a725664ad99e22b74846d102e4ac52167ec46.zip
sci-astronomy/pal: initial import
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--sci-astronomy/pal/Manifest1
-rw-r--r--sci-astronomy/pal/metadata.xml14
-rw-r--r--sci-astronomy/pal/pal-0.9.7.ebuild33
3 files changed, 48 insertions, 0 deletions
diff --git a/sci-astronomy/pal/Manifest b/sci-astronomy/pal/Manifest
new file mode 100644
index 000000000000..68bd52278690
--- /dev/null
+++ b/sci-astronomy/pal/Manifest
@@ -0,0 +1 @@
+DIST pal-0.9.7.tar.gz 1220443 SHA256 7151aa05c2e2456394cae2043feb96e64d779286fb31a27ff11ec3dd66021286 SHA512 d3f13e7ff321500acc71198240392fe9a3304c4142cf5b1f1c3950ddb1351dddac8565ef27b1c724d608cc1053d15647c777c4d0dc466a99a1b08b64e62ec37b WHIRLPOOL e6d9986e43e91f35ee47e6586d3595c62f12d4dabb54f3e9adb6d524fcf075e54e92c6e985005bd3c892a55fbcf469a7a49f0e7672e0923ae2b6f1a321b65c15
diff --git a/sci-astronomy/pal/metadata.xml b/sci-astronomy/pal/metadata.xml
new file mode 100644
index 000000000000..e435a2438c1a
--- /dev/null
+++ b/sci-astronomy/pal/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The Positional Astronomy Library is a collection of code designed
+ to aid in replacing the SLA library with code from NOVAS and
+ ERFA. Where possible the API is similar to the C SLA API except
+ for the use of a "pal" prefix.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-astronomy/pal/pal-0.9.7.ebuild b/sci-astronomy/pal/pal-0.9.7.ebuild
new file mode 100644
index 000000000000..bd8451b6d4d4
--- /dev/null
+++ b/sci-astronomy/pal/pal-0.9.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Positional Astronomy Library"
+HOMEPAGE="http://github.com/Starlink/pal"
+SRC_URI="https://github.com/Starlink/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+RDEPEND="sci-astronomy/erfa:="
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf --without-starlink \
+ --without-stardocs \
+ --with-erfa \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ # remove cruft from non-fhs complient
+ rm -r "${ED}"usr/share/pal || die
+ rm -r "${ED}"usr/{docs,manifests,news} || die
+ use static-libs || prune_libtool_files --all
+}