summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-23 21:50:43 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-23 22:19:47 +0200
commit6aac66b029bb52fe4c6c68556c7c434f9954380d (patch)
tree808e343dd5272247c3d70d3d516a2688af926fbf
parentdev-python/pyparsing: Bump to 3.0.0 (diff)
downloadgentoo-6aac66b029bb52fe4c6c68556c7c434f9954380d.tar.gz
gentoo-6aac66b029bb52fe4c6c68556c7c434f9954380d.tar.bz2
gentoo-6aac66b029bb52fe4c6c68556c7c434f9954380d.zip
app-cdr/gcdemu: Bump to 3.2.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-cdr/gcdemu/Manifest1
-rw-r--r--app-cdr/gcdemu/gcdemu-3.2.6.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-cdr/gcdemu/Manifest b/app-cdr/gcdemu/Manifest
index 158794f37924..9bbcddaf79ca 100644
--- a/app-cdr/gcdemu/Manifest
+++ b/app-cdr/gcdemu/Manifest
@@ -1,2 +1,3 @@
DIST gcdemu-3.2.4.tar.bz2 52209 BLAKE2B 620b1ea8616cf0d7f80954dd00ad1442b55fedafc5ff27ad5aa917e69a803a9629ccadb33ec3fdb2371c464bd484a15e85e00036dee5a67283fbf7e8d64e252c SHA512 920ab87a0b200f3f3983ff878871265084787f1468c042352c319ff3a37131547cc1e981801eefaee1e419ec306b026f7a18da165a17e3ddc6a92998a42e7b41
DIST gcdemu-3.2.5.tar.xz 47960 BLAKE2B 8e45fe31461120b33080b9e40bd1def1c4ddfe562a9ca60814c66fbe073325d867692bd367e89e8281e34955eb232c37d8908a8962f5aa4587000b28c296d32b SHA512 d7e7b6ee1677213d858fca18103dd6d06e5de3f6c65fd16f19925b14ef50c73ebd0cbee3cb5c65aa5a59be3da1865f3e87b5e7c1a5921c496ae083727365e10b
+DIST gcdemu-3.2.6.tar.xz 47968 BLAKE2B edbe8cb46ce020eec20b2740da99c35d3fd9727a1c65a5e6992de7876d55e24527c8c524e2ccc479a7ca01a0e68bff1488db2746838fc56ea29d424928c2338f SHA512 1ed08c159f5de9ed5ad850508356998ad17f4bbb17b111ba385c913f2058daa32d8e9cd7ae04cdeacca9c7f3004f29c3c6e995cfd14a7eb60bdb32489f49515e
diff --git a/app-cdr/gcdemu/gcdemu-3.2.6.ebuild b/app-cdr/gcdemu/gcdemu-3.2.6.ebuild
new file mode 100644
index 000000000000..acd1390fe915
--- /dev/null
+++ b/app-cdr/gcdemu/gcdemu-3.2.6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake gnome2-utils python-single-r1 xdg-utils
+
+DESCRIPTION="Gtk+ GUI for controlling cdemu-daemon"
+HOMEPAGE="https://cdemu.sourceforge.io"
+SRC_URI="https://download.sourceforge.net/cdemu/gcdemu/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# librsvg for pixbuf-loader
+RDEPEND="${PYTHON_DEPS}
+ app-cdr/cdemu-daemon:0/7
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ gnome-base/librsvg:2
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]"
+BDEPEND="${PYTHON_DEPS}
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.21
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ cmake_src_prepare
+ python_fix_shebang src/gcdemu
+}
+
+src_configure() {
+ local mycmakeargs=( -DPOST_INSTALL_HOOKS=OFF )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_schemas_update
+}