summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-29 18:53:01 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-29 23:30:49 +0100
commit6af2c45500656b8b7a9c9eb63f6c43e73b7dd1c0 (patch)
tree8b969e10415a0d6f9f744c245f6a82df2b433a56
parentapp-admin/ide-smart: Port to EAPI 6 (diff)
downloadgentoo-6af2c45500656b8b7a9c9eb63f6c43e73b7dd1c0.tar.gz
gentoo-6af2c45500656b8b7a9c9eb63f6c43e73b7dd1c0.tar.bz2
gentoo-6af2c45500656b8b7a9c9eb63f6c43e73b7dd1c0.zip
app-admin/integrit: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--app-admin/integrit/files/integrit-4.1-fix-build-system.patch43
-rw-r--r--app-admin/integrit/integrit-4.1-r1.ebuild58
2 files changed, 72 insertions, 29 deletions
diff --git a/app-admin/integrit/files/integrit-4.1-fix-build-system.patch b/app-admin/integrit/files/integrit-4.1-fix-build-system.patch
new file mode 100644
index 000000000000..64b3d47e59f8
--- /dev/null
+++ b/app-admin/integrit/files/integrit-4.1-fix-build-system.patch
@@ -0,0 +1,43 @@
+--- a/configure.in
++++ b/configure.in
+@@ -26,7 +26,6 @@
+
+ # ----- you can override these values by setting environment variables
+ # CC=my-compiler ./configure
+-CC=${CC:-"gcc"}
+ # CFLAGS="-g foo -x bar" ./configure
+ CFLAGS=${CFLAGS-"-g -Wall -O2"}
+ STATIC=${STATIC-"-static"}
+@@ -53,10 +52,9 @@
+ dnl AC_PROG_LEX
+ AC_PROG_MAKE_SET
+ AC_PROG_AWK
+-AC_PROGRAM_PATH(RM, rm , rm)
+ dnl syncing is the job of the O.S., and users can always do "make; sync"
+ dnl AC_PROGRAM_PATH(SYNC, sync, sync)
+-AC_PROGRAM_PATH(AR, ar, ar)
++AM_PROG_AR
+ AC_PROG_RANLIB
+
+ dnl ---------- let users override the install that configure finds
+--- a/hashtbl/configure.in
++++ b/hashtbl/configure.in
+@@ -25,17 +25,15 @@
+
+ # ----- you can override these values by setting environment variables
+ # CC=my-compiler ./configure
+-CC=${CC:-"gcc"}
+ # CFLAGS="-g foo -x bar" ./configure
+ CFLAGS=${CFLAGS:-"-g -Wall -O2"}
+ STATIC=${STATIC:-"-static"}
+
+ dnl Checks for programs.
+ AC_PROG_CC
+-AC_PROGRAM_PATH(RM, rm , rm)
+ dnl syncing is the job of the O.S., and users can always do "make; sync"
+ dnl AC_PROGRAM_PATH(SYNC, sync, sync)
+-AC_PROGRAM_PATH(AR, ar, ar)
++AM_PROG_AR
+ AC_PROG_MAKE_SET
+ AC_PROG_RANLIB
+
diff --git a/app-admin/integrit/integrit-4.1-r1.ebuild b/app-admin/integrit/integrit-4.1-r1.ebuild
index d987937dc338..3289a7bc8209 100644
--- a/app-admin/integrit/integrit-4.1-r1.ebuild
+++ b/app-admin/integrit/integrit-4.1-r1.ebuild
@@ -1,61 +1,61 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=6
-inherit autotools toolchain-funcs
+inherit autotools
DESCRIPTION="file integrity verification program"
HOMEPAGE="http://integrit.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
+PATCHES=( "${FILESDIR}"/${PN}-4.1-fix-build-system.patch )
+
src_prepare() {
- sed -i -e "/^CC/d" configure.in hashtbl/configure.in || die
- sed -i -e "/^AC_PROGRAM_PATH/d" configure.in hashtbl/configure.in || die
+ default
+ mv configure.{in,ac} || die
+ mv hashtbl/configure.{in,ac} || die
+
+ # tests are not executable
+ chmod +x test/test || die
+
eautoreconf
- tc-export AR
}
src_compile() {
emake
emake utils
- cd "${S}"/doc && emake
- cd "${S}"/hashtbl && emake hashtest
-}
-
-src_test() {
- chmod +x test/test || die
- default
+ emake -C doc
+ emake -C hashtbl hashtest
}
src_install() {
dosbin integrit
- dolib libintegrit.a
+ dolib.a libintegrit.a
dodoc Changes HACKING README todo.txt
- cd "${S}"/utils
- dosbin i-viewdb
- dobin i-ls
+ # utils
+ dosbin utils/i-viewdb
+ dobin utils/i-ls
- cd "${S}"/hashtbl
- dolib libhashtbl.a
- insinto /usr/include
- doins hashtbl.h
- dobin hashtest
- newdoc README README.hashtbl
+ # hashtbl
+ dolib.a hashtbl/libhashtbl.a
+ doheader hashtbl/hashtbl.h
+ dobin hashtbl/hashtest
+ newdoc hashtbl/README README.hashtbl
- cd "${S}"/doc
- doman i-ls.1 i-viewdb.1 integrit.1
- doinfo integrit.info
+ # doc
+ doman doc/{i-ls.1,i-viewdb.1,integrit.1}
+ doinfo doc/integrit.info
- cd "${S}"/examples
- docinto examples
- dodoc *
+ # examples
+ dodoc -r examples
}
pkg_postinst() {