summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-06-15 23:09:55 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-06-15 23:10:12 +0200
commit6b9ec0075f48c4e6e1a89b1ca7420d1147b33aba (patch)
treef651f957615fb2895b16276ede8897e325d99283
parentmedia-libs/shaderc: Drop 2020.4_pre20200405 version (diff)
downloadgentoo-6b9ec0075f48c4e6e1a89b1ca7420d1147b33aba.tar.gz
gentoo-6b9ec0075f48c4e6e1a89b1ca7420d1147b33aba.tar.bz2
gentoo-6b9ec0075f48c4e6e1a89b1ca7420d1147b33aba.zip
net-misc/dhcpcd: Bump to version 9.1.2
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--net-misc/dhcpcd/Manifest1
-rw-r--r--net-misc/dhcpcd/dhcpcd-9.1.2.ebuild157
-rw-r--r--net-misc/dhcpcd/files/dhcpcd-9.1.2-embedded_config.patch49
3 files changed, 207 insertions, 0 deletions
diff --git a/net-misc/dhcpcd/Manifest b/net-misc/dhcpcd/Manifest
index 9e596f873065..ef2bf485eb85 100644
--- a/net-misc/dhcpcd/Manifest
+++ b/net-misc/dhcpcd/Manifest
@@ -1,3 +1,4 @@
DIST dhcpcd-8.1.9.tar.xz 230288 BLAKE2B 5606ddfce37c67ac3d60257104fcf15bd7da65021b2c1261a45958b628cd066ccd9bc6b60bbb42f8280fcbbf9d4b1c7666b993c37f150b27ef2a0527a0fd5b96 SHA512 40ac106ffca60b32362aacdfae0fa3a2993a3eed72bf452322412a912f594aaade1c24b862233455033158a6e453ec75d6d14fa52df6b4c5ae435dd6ceb29f2a
DIST dhcpcd-9.0.2.tar.xz 244800 BLAKE2B d0c355141aa1e57715c30b2902eed7e2821f2c08fdc97497c9dc271689faf2ca22e3f50f17e6c7ae8fe4434d5c216572a42e1abf789287495e6db44f671d5085 SHA512 2a606bff2e96d1da5d3642ac68341c14b378d9a905cba364ab42eba1285604f8be56b9efeff3eee18d89b71f0f9f3b05cb7b88e8fce568baf1c0d1e5d3becb5f
DIST dhcpcd-9.1.1.tar.xz 246084 BLAKE2B 35acaabb32e6a5b227071376e8a0387cadb776ee94a8b7f92c181440ef72bf60e9867e901347a139e4ce036c85913fa85e61d3c401c8a9f57e81dff76465ccab SHA512 7b1eb052293218e9b52f7ff40768eaa9db832979ffa8e4ba4724ce98bac9e9c809505b40aaebd4cf13192d0b30f2e963d34ca3b9c1e05458e86e11d06e1cbed8
+DIST dhcpcd-9.1.2.tar.xz 248552 BLAKE2B b7330da009bc0b906593b60db6af20a75ad49d21e1852514bad7bc6034246df8080372f2c4ffcdbbb0cd9122b2f48614159a1b0f2629584e8b2d2ed0f366ee2b SHA512 0db9a509dbd8ea8e24bf4a45780433107708d0ea42b28cd63b9828f55e0182670286f5cb678d96d7f626d8a6e404693f7f43e62ac5608d5f61b5e80de4afb965
diff --git a/net-misc/dhcpcd/dhcpcd-9.1.2.ebuild b/net-misc/dhcpcd/dhcpcd-9.1.2.ebuild
new file mode 100644
index 000000000000..0942b0cd0435
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-9.1.2.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd toolchain-funcs
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://roy.marples.name/cgit/dhcpcd.git"
+else
+ MY_P="${P/_alpha/-alpha}"
+ MY_P="${MY_P/_beta/-beta}"
+ MY_P="${MY_P/_rc/-rc}"
+ SRC_URI="https://roy.marples.name/downloads/${PN}/${MY_P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
+HOMEPAGE="https://roy.marples.name/projects/dhcpcd"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="debug elibc_glibc +embedded ipv6 kernel_linux privsep +udev"
+
+COMMON_DEPEND="udev? ( virtual/udev )"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="
+ ${COMMON_DEPEND}
+ privsep? (
+ acct-group/dhcpcd
+ acct-user/dhcpcd
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-embedded_config.patch"
+)
+
+src_configure() {
+ local myeconfargs=(
+ --dbdir="${EPREFIX}/var/lib/dhcpcd"
+ --libexecdir="${EPREFIX}/lib/dhcpcd"
+ --localstatedir="${EPREFIX}/var"
+ --prefix="${EPREFIX}"
+ --with-hook=ntp.conf
+ $(use_enable debug)
+ $(use_enable embedded)
+ $(use_enable ipv6)
+ $(use_enable privsep)
+ $(usex elibc_glibc '--with-hook=yp.conf' '')
+ --rundir=$(usex kernel_linux "${EPREFIX}/run/dhcpcd" "${EPREFIX}/var/run/dhcpcd")
+ $(usex privsep '--privsepuser=dhcpcd' '')
+ $(usex udev '' '--without-dev --without-udev')
+ CC="$(tc-getCC)"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ keepdir /var/lib/dhcpcd
+ newinitd "${FILESDIR}"/dhcpcd.initd-r1 dhcpcd
+ systemd_newunit "${FILESDIR}"/dhcpcd.service-r1 dhcpcd.service
+}
+
+pkg_postinst() {
+ local dbdir="${EROOT}"/var/lib/dhcpcd old_files=()
+
+ local old_old_duid="${EROOT}"/var/lib/dhcpcd/dhcpcd.duid
+ local old_duid="${EROOT}"/etc/dhcpcd.duid
+ local new_duid="${dbdir}"/duid
+ if [[ -e "${old_old_duid}" ]] ; then
+ # Upgrade the duid file to the new format if needed
+ if ! grep -q '..:..:..:..:..:..' "${old_old_duid}"; then
+ sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_old_duid}"
+ fi
+
+ # Move the duid to /etc, a more sensible location
+ if [[ ! -e "${old_duid}" ]] ; then
+ cp -p "${old_old_duid}" "${new_duid}"
+ fi
+ old_files+=( "${old_old_duid}" )
+ fi
+
+ # dhcpcd-7 moves the files out of /etc
+ if [[ -e "${old_duid}" ]] ; then
+ if [[ ! -e "${new_duid}" ]] ; then
+ cp -p "${old_duid}" "${new_duid}"
+ fi
+ old_files+=( "${old_duid}" )
+ fi
+ local old_secret="${EROOT}"/etc/dhcpcd.secret
+ local new_secret="${dbdir}"/secret
+ if [[ -e "${old_secret}" ]] ; then
+ if [[ ! -e "${new_secret}" ]] ; then
+ cp -p "${old_secret}" "${new_secret}"
+ fi
+ old_files+=( "${old_secret}" )
+ fi
+
+ # dhcpcd-7 renames some files in /var/lib/dhcpcd
+ local old_rdm="${dbdir}"/dhcpcd-rdm.monotonic
+ local new_rdm="${dbdir}"/rdm_monotonic
+ if [[ -e "${old_rdm}" ]] ; then
+ if [[ ! -e "${new_rdm}" ]] ; then
+ cp -p "${old_rdm}" "${new_rdm}"
+ fi
+ old_files+=( "${old_rdm}" )
+ fi
+ local lease=
+ for lease in "${dbdir}"/dhcpcd-*.lease*; do
+ [[ -f "${lease}" ]] || continue
+ old_files+=( "${lease}" )
+ local new_lease=$(basename "${lease}" | sed -e "s/dhcpcd-//")
+ [[ -e "${dbdir}/${new_lease}" ]] && continue
+ cp "${lease}" "${dbdir}/${new_lease}"
+ done
+
+ # Warn about removing stale files
+ if [[ -n "${old_files[@]}" ]] ; then
+ elog
+ elog "dhcpcd-7 has copied dhcpcd.duid and dhcpcd.secret from"
+ elog "${EROOT}/etc to ${dbdir}"
+ elog "and copied leases in ${dbdir} to new files with the dhcpcd-"
+ elog "prefix dropped."
+ elog
+ elog "You should remove these files if you don't plan on reverting"
+ elog "to an older version:"
+ local old_file=
+ for old_file in ${old_files[@]}; do
+ elog " ${old_file}"
+ done
+ fi
+
+ if [ -z "${REPLACING_VERSIONS}" ]; then
+ elog
+ elog "dhcpcd has zeroconf support active by default."
+ elog "This means it will always obtain an IP address even if no"
+ elog "DHCP server can be contacted, which will break any existing"
+ elog "failover support you may have configured in your net configuration."
+ elog "This behaviour can be controlled with the noipv4ll configuration"
+ elog "file option or the -L command line switch."
+ elog "See the dhcpcd and dhcpcd.conf man pages for more details."
+
+ elog
+ elog "Dhcpcd has duid enabled by default, and this may cause issues"
+ elog "with some dhcp servers. For more information, see"
+ elog "https://bugs.gentoo.org/show_bug.cgi?id=477356"
+ fi
+
+ if ! has_version net-dns/bind-tools; then
+ elog
+ elog "If you activate the lookup-hostname hook to look up your hostname"
+ elog "using the dns, you need to install net-dns/bind-tools."
+ fi
+}
diff --git a/net-misc/dhcpcd/files/dhcpcd-9.1.2-embedded_config.patch b/net-misc/dhcpcd/files/dhcpcd-9.1.2-embedded_config.patch
new file mode 100644
index 000000000000..5401317a2ece
--- /dev/null
+++ b/net-misc/dhcpcd/files/dhcpcd-9.1.2-embedded_config.patch
@@ -0,0 +1,49 @@
+From 9dc6d4b7c8df8425c9b1e893e86b8463abb2053c Mon Sep 17 00:00:00 2001
+From: Roy Marples <roy@marples.name>
+Date: Mon, 15 Jun 2020 22:04:37 +0100
+Subject: configure: Fix fallout with disabling embedded config
+
+---
+ configure | 19 ++++++++++---------
+ 1 file changed, 10 insertions(+), 9 deletions(-)
+
+diff --git a/configure b/configure
+index 8398ad69..a3701726 100755
+--- a/configure
++++ b/configure
+@@ -545,15 +545,6 @@ if [ -z "$AUTH" -o "$AUTH" = yes ]; then
+ echo "SRCS+= auth.c" >>$CONFIG_MK
+ fi
+
+-if [ -z "$EMBEDDED" -o "$EMBEDDED" = yes ]; then
+- echo "$DHCPCD_DEFS will be embedded in dhcpcd itself"
+- echo "DHCPCD_SRCS+= dhcpcd-embedded.c" >>$CONFIG_MK
+-else
+- echo "$DHCPCD_DEFS will be installed to $LIBEXECDIR"
+- echo "CPPFLAGS+= -DEMBEDDED_CONFIG=\\\"$LIBEXECDIR/dhcpcd-definitions.conf\\\"" >>$CONFIG_MK
+- echo "EMBEDDEDINSTALL= _embeddedinstall" >>$CONFIG_MK
+-fi
+-
+ if [ -z "$PRIVSEP" ]; then
+ # privilege separation works fine .... except on Solaris
+ case "$OS" in
+@@ -665,6 +656,16 @@ EOF
+ rm -f _pledge.c _pledge
+ fi
+
++# This block needs to be after the compiler test due to embedded quotes.
++if [ -z "$EMBEDDED" -o "$EMBEDDED" = yes ]; then
++ echo "$DHCPCD_DEFS will be embedded in dhcpcd itself"
++ echo "DHCPCD_SRCS+= dhcpcd-embedded.c" >>$CONFIG_MK
++else
++ echo "$DHCPCD_DEFS will be installed to $LIBEXECDIR"
++ echo "CPPFLAGS+= -DEMBEDDED_CONFIG=\\\"$LIBEXECDIR/dhcpcd-definitions.conf\\\"" >>$CONFIG_MK
++ echo "EMBEDDEDINSTALL= _embeddedinstall" >>$CONFIG_MK
++fi
++
+ if [ "$OS" = linux ]; then
+ printf "Testing for nl80211 ... "
+ cat <<EOF >_nl80211.c
+--
+cgit v1.2.3
+