summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-15 22:01:10 +0000
committerSam James <sam@gentoo.org>2021-03-15 22:01:30 +0000
commit6c9b3eddfee95a0fd06e279643434f1af9ec5e8f (patch)
tree6d22961b8d7af532bf74f9523b683a753ed7a87c
parentx11-misc/xkeycaps: drop 2.47-r2 (diff)
downloadgentoo-6c9b3eddfee95a0fd06e279643434f1af9ec5e8f.tar.gz
gentoo-6c9b3eddfee95a0fd06e279643434f1af9ec5e8f.tar.bz2
gentoo-6c9b3eddfee95a0fd06e279643434f1af9ec5e8f.zip
net-analyzer/amap: drop 5.4
Bug: https://bugs.gentoo.org/776505 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-analyzer/amap/amap-5.4.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/net-analyzer/amap/amap-5.4.ebuild b/net-analyzer/amap/amap-5.4.ebuild
deleted file mode 100644
index ef97cd2aec15..000000000000
--- a/net-analyzer/amap/amap-5.4.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="A network scanning tool for pentesters"
-HOMEPAGE="https://www.thc.org/thc-amap/"
-SRC_URI="https://www.thc.org/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86"
-IUSE="ssl"
-
-DEPEND="
- dev-libs/libpcre
- ssl? ( >=dev-libs/openssl-0.9.6j )
-"
-RDEPEND="
- ${DEPEND}
- !sci-biology/amap
-"
-
-src_prepare() {
- rm -r pcre-3.9 || die
- sed -i -e "s:etc/:share/amap/:g" amap-lib.c || die
- # Above change requires below change. See sources...
- sed -i '/strlen(AMAP_PREFIX/s: 5 : 12 :' amap-lib.c || die
- sed -i 's:/usr/local:/usr:' amap.h || die
- # Files to be updated are at different location, bug 207839.
- sed -i '/AMAP_RESOURCE/s:www:freeworld:' amap.h || die
-
- sed -i '/DATADIR/s:/etc:/share/amap:' Makefile.am || die
-
- epatch "${FILESDIR}"/4.8-system-pcre.patch
-}
-
-src_configure() {
- # non-autotools configure script
- ./configure || die
- sed -i \
- -e '/^XDEFINES=/s:=.*:=:' \
- -e '/^XLIBS=/s:=.*:=:' \
- -e '/^XLIBPATHS/s:=.*:=:' \
- -e '/^XIPATHS=/s:=.*:=:' \
- -e "/^CC=/d" \
- Makefile || die
- if use ssl ; then
- sed -i \
- -e '/^XDEFINES=/s:=:=-DOPENSSL:' \
- -e '/^XLIBS=/s:=:=-lcrypto -lssl:' \
- Makefile || die
- fi
- sed -i Makefile \
- -e '/-o amap/{s|(OPT) |(OPT) $(LDFLAGS) |g}' \
- || die
-}
-
-src_compile() {
- emake CC=$(tc-getCC) OPT="${CFLAGS}"
-}
-
-src_install() {
- dobin amap amapcrap
- insinto /usr/share/amap
- doins appdefs.*
-
- doman ${PN}.1
- dodoc README TODO CHANGES
-}